LCP100-PC-Software: Class List

  • Main Page
  • Packages
  • Classes
  • Files
  • Class List
  • Class Members

Class List

Here are the classes, structs, unions and interfaces with brief descriptions:
Eq3.Communication.AsyncDataFrameReader | Liest asynchron Datenrahmen aus einem Stream
Eq3.Communication.AsyncDataFrameReader.ReceiveDataFrameEventArgs | Argumente des Ereignises ReceiveDataFrame
Eq3.Communication.CRC16 | Berechnet CRC16-Prüfsummen
Eq3.Communication.DataFrameDecoder | Decodiert eine Datenrahmen byteweise
Eq3.Communication.DataFrameReader | Liest synchron Datenrahmen aus einem Stream
Eq3.Communication.DataFrameWriter | Schreibt einen Datenrahmen synchron in einen Stream
Eq3.Communication.DLEDecoder | DLE-Decodierung
Eq3.Communication.DLEEncoder | Führt eine DLE-Codierug durch
Eq3.Communication.DLEEncoding |
Eq3.LCP100.LCP100 | Zugriff auf das LCP100-Gerät
Eq3.LCP100.LCP100.Version | Versionsnummer des LCP100
EQ3.LCP100.Demo.MainForm | Hauptfenster der Demo-Anwendung
EQ3.LCP100.Demo.Program |
LCP100Demo.Properties.Resources | Eine stark typisierte Ressourcenklasse zum Suchen von lokalisierten Zeichenfolgen usw
LCP100Demo.Properties.Settings |
Generated on Thu May 7 08:08:53 2009 for LCP100-PC-Software by doxygen 1.5.7.1


LCP100-PC-Software: Eq3.Communication.AsyncDataFrameReader Class Reference

  • Files
  • Class List
  • Class Members
Eq3.Communication.AsyncDataFrameReader

Eq3.Communication.AsyncDataFrameReader Class Reference

Liest asynchron Datenrahmen aus einem Stream. More...

Collaboration diagram for Eq3.Communication.AsyncDataFrameReader:
[legend]

List of all members.

Classes

class | ReceiveDataFrameEventArgs
Argumente des Ereignises ReceiveDataFrame. More...

Public Member Functions

AsyncDataFrameReader (Stream baseStream)
Erstellt und startet den AsyncDataFrameReader. Der Puffer hat eine Standardgröße von 4096 Bytes.
AsyncDataFrameReader (Stream baseStream, int bufferSize)
Erstellt und startet den AsyncDataFrameReader.
void | Stop ()
Beendet den AsyncDataFrameReader.

Properties

Stream | BaseStream [get]
Zugrundeliegender Stream.

Events

EventHandler
< ReceiveDataFrameEventArgs > 		ReceiveDataFrame
Wird beim Empfang eines kompletten Datenrahmens ausgelöst.

Private Member Functions

void | OnReceiveData (IAsyncResult asyncResult)
Event-Handler. Verarbeitet eingegange Daten.
void | FireReceiveDataFrame (byte[] payload)
Feuert das ReceiveDataFrame-Ereignis.

Private Attributes

Stream | baseStream
Zugrundeliegender Stream.
DataFrameDecoder decoder
DLE-Decoder.
byte[] | buffer
Datenpuffer.
IAsyncResult | asyncResult
Handle auf den asynchronen Lesevorgang.

Detailed Description

Liest asynchron Datenrahmen aus einem Stream.

Constructor & Destructor Documentation

Eq3.Communication.AsyncDataFrameReader.AsyncDataFrameReader ( Stream baseStream )

Erstellt und startet den AsyncDataFrameReader. Der Puffer hat eine Standardgröße von 4096 Bytes.

Parameters:
baseStream Zugrundeliegender Datenstrom

Eq3.Communication.AsyncDataFrameReader.AsyncDataFrameReader | ( | Stream | baseStream,
 |  | int | bufferSize
 | ) |  |

Erstellt und startet den AsyncDataFrameReader.

Parameters:
baseStream | Zugrundeliegender Datenstrom
bufferSize | Puffergröße

Member Function Documentation

void Eq3.Communication.AsyncDataFrameReader.FireReceiveDataFrame ( byte[] payload ) [private]

Feuert das ReceiveDataFrame-Ereignis.

Parameters:
payload Nutzdaten

void Eq3.Communication.AsyncDataFrameReader.OnReceiveData ( IAsyncResult asyncResult ) [private]

Event-Handler. Verarbeitet eingegange Daten.

Parameters:
asyncResult

void Eq3.Communication.AsyncDataFrameReader.Stop ( )

Beendet den AsyncDataFrameReader.

Member Data Documentation

IAsyncResult Eq3.Communication.AsyncDataFrameReader.asyncResult [private]

Handle auf den asynchronen Lesevorgang.

Stream Eq3.Communication.AsyncDataFrameReader.baseStream [private]

Zugrundeliegender Stream.

byte [] Eq3.Communication.AsyncDataFrameReader.buffer [private]

Datenpuffer.

DataFrameDecoder Eq3.Communication.AsyncDataFrameReader.decoder [private]

DLE-Decoder.

Property Documentation

Stream Eq3.Communication.AsyncDataFrameReader.BaseStream [get]

Zugrundeliegender Stream.

Event Documentation

EventHandler<ReceiveDataFrameEventArgs> Eq3.Communication.AsyncDataFrameReader.ReceiveDataFrame

Wird beim Empfang eines kompletten Datenrahmens ausgelöst.

The documentation for this class was generated from the following file:
  • AsyncDataFrameReader.cs


LCP100-PC-Software: Eq3.Communication.AsyncDataFrameReader.ReceiveDataFrameEventArgs Class Reference

Eq3.Communication.AsyncDataFrameReader.ReceiveDataFrameEventArgs

Eq3.Communication.AsyncDataFrameReader.ReceiveDataFrameEventArgs Class Reference

Argumente des Ereignises ReceiveDataFrame. More...

List of all members.

Public Member Functions

ReceiveDataFrameEventArgs (byte[] payload)
Erstellt und initialisiert eine Instanz von ReceiveDataFrameEventArgs.

Public Attributes

readonly byte[] Payload
Nutzdaten des Datenrahmens.

Detailed Description

Argumente des Ereignises ReceiveDataFrame.

Constructor & Destructor Documentation

Eq3.Communication.AsyncDataFrameReader.ReceiveDataFrameEventArgs.ReceiveDataFrameEventArgs ( byte[] payload )

Erstellt und initialisiert eine Instanz von ReceiveDataFrameEventArgs.

Parameters:
payload

Member Data Documentation

readonly byte [] Eq3.Communication.AsyncDataFrameReader.ReceiveDataFrameEventArgs.Payload

Nutzdaten des Datenrahmens.

The documentation for this class was generated from the following file:
  • AsyncDataFrameReader.cs


LCP100-PC-Software: Eq3.Communication.CRC16 Class Reference

Eq3.Communication.CRC16

Eq3.Communication.CRC16 Class Reference

Berechnet CRC16-Prüfsummen. More...

List of all members.

Public Member Functions

CRC16 ()
Erzeugt und Initialisiert eine CRC16-Instanz.
CRC16 Reset ()
Setzt die CRC16-Prüfsumme zurück.
CRC16 | Process (byte b)
Verarbeitet ein einzelnes Byte.
CRC16 | Process (byte[] bytes)
Verarbeitet ein Byte-Array.

Static Public Member Functions

static UInt16 | GetChecksum (byte[] bytes)
Berechnet die CRC16-Prüfsumme für ein Byte-Array.

Public Attributes

const UInt16 | POLYNOM = 0x8005
CRC16-Polynom.
const UInt16 | INIT = 0xffff
Initialwert der Prüfsumme.

Properties

UInt16 | Checksum [get]
Aktuelle CRC-16 Prüfsumme.

Private Attributes

UInt16 | checksum
Aktuelle CRC16-Prüfsumme.

Detailed Description

Berechnet CRC16-Prüfsummen.

Constructor & Destructor Documentation

Eq3.Communication.CRC16.CRC16 ( )

Erzeugt und Initialisiert eine CRC16-Instanz.

Member Function Documentation

static UInt16 Eq3.Communication.CRC16.GetChecksum ( byte[] bytes ) [static]

Berechnet die CRC16-Prüfsumme für ein Byte-Array.

Parameters:
bytes Grundlage der Prüfsumme.
Returns:
CRC16-Prüfsumme für das Byte-Array.

CRC16 Eq3.Communication.CRC16.Process ( byte[] bytes )

Verarbeitet ein Byte-Array.

Parameters:
bytes
Returns:
Aktuelle CRC16-Prüfsumme.

CRC16 Eq3.Communication.CRC16.Process ( byte b )

Verarbeitet ein einzelnes Byte.

Parameters:
b
Returns:
Aktuelle CRC16-Prüfsumme.

CRC16 Eq3.Communication.CRC16.Reset ( )

Setzt die CRC16-Prüfsumme zurück.

Member Data Documentation

UInt16 Eq3.Communication.CRC16.checksum [private]

Aktuelle CRC16-Prüfsumme.

const UInt16 Eq3.Communication.CRC16.INIT = 0xffff

Initialwert der Prüfsumme.

const UInt16 Eq3.Communication.CRC16.POLYNOM = 0x8005

CRC16-Polynom.

Property Documentation

UInt16 Eq3.Communication.CRC16.Checksum [get]

Aktuelle CRC-16 Prüfsumme.

The documentation for this class was generated from the following file:
  • CRC16.cs


LCP100-PC-Software: Eq3.Communication.DataFrameDecoder Class Reference

Eq3.Communication.DataFrameDecoder

Eq3.Communication.DataFrameDecoder Class Reference

Decodiert eine Datenrahmen byteweise. More...

Collaboration diagram for Eq3.Communication.DataFrameDecoder:
[legend]

List of all members.

Public Member Functions

DataFrameDecoder ()
Erzeugt und initialisiert einen neuen DataFrameReader. Dieser läuft in einem eigenen Thread ab.
byte[] | Decode (byte b)
Decodiert ein Byte. Ein neuer Datenrahmen beginnt mit dem Steuerzeichen STX. Sobald ein Datenrahmen fertig ist, wird ein entsprechendes Ereignis ausgelöst.

Public Attributes

const int | MAX_PAYLOAD_LENGTH = 65535
Maximale Länge eines Datenrahmens (Nutzdaten).

Private Types

enum State {
WAIT_FOR_STX, LENGTH_HIGH, LENGTH_LOW, READ_DATA,
CRC_HIGH, CRC_LOW
}
Zustand des Decoders. More...

Private Member Functions

byte[] | Process (byte b)
Verarbeitet ein Byte. Sobald der Datenrahmen komplett ist, wird ein entsprechendes Ereignis ausgelöst.

Private Attributes

DLEDecoder dleDecoder
DLE-Decoder.
CRC16 crc
Aktuelle CRC-Prüfsumme.
int | payloadLength
Länge der Nutzdaten.
int | payloadIndex
Aktuelle Position in den Nutzdaten.
byte[] | payload
Nutzdaten (Datenrahmen).
State state
Akuteller Zustand des DataFrameReaders.

Detailed Description

Decodiert eine Datenrahmen byteweise.

Member Enumeration Documentation

enum Eq3::Communication::DataFrameDecoder::State [private]

Zustand des Decoders.

Enumerator:
WAIT_FOR_STX
LENGTH_HIGH
LENGTH_LOW
READ_DATA
CRC_HIGH
CRC_LOW

Constructor & Destructor Documentation

Eq3.Communication.DataFrameDecoder.DataFrameDecoder ( )

Erzeugt und initialisiert einen neuen DataFrameReader. Dieser läuft in einem eigenen Thread ab.

Member Function Documentation

byte [] Eq3.Communication.DataFrameDecoder.Decode ( byte b )

Decodiert ein Byte. Ein neuer Datenrahmen beginnt mit dem Steuerzeichen STX. Sobald ein Datenrahmen fertig ist, wird ein entsprechendes Ereignis ausgelöst.

Parameters:
b Zu decodierendes Byte

byte [] Eq3.Communication.DataFrameDecoder.Process ( byte b ) [private]

Verarbeitet ein Byte. Sobald der Datenrahmen komplett ist, wird ein entsprechendes Ereignis ausgelöst.

Parameters:
b Zu verarbeitendes Byte.

Member Data Documentation

CRC16 Eq3.Communication.DataFrameDecoder.crc [private]

Aktuelle CRC-Prüfsumme.

DLEDecoder Eq3.Communication.DataFrameDecoder.dleDecoder [private]

DLE-Decoder.

const int Eq3.Communication.DataFrameDecoder.MAX_PAYLOAD_LENGTH = 65535

Maximale Länge eines Datenrahmens (Nutzdaten).

byte [] Eq3.Communication.DataFrameDecoder.payload [private]

Nutzdaten (Datenrahmen).

int Eq3.Communication.DataFrameDecoder.payloadIndex [private]

Aktuelle Position in den Nutzdaten.

int Eq3.Communication.DataFrameDecoder.payloadLength [private]

Länge der Nutzdaten.

State Eq3.Communication.DataFrameDecoder.state [private]

Akuteller Zustand des DataFrameReaders.

The documentation for this class was generated from the following file:
  • DataFrameDecoder.cs
Generated on Thu May 7 08:08:54 2009 for LCP100-PC-Software by doxygen 1.5.7.1


LCP100-PC-Software: Eq3.Communication.DataFrameReader Class Reference

Eq3.Communication.DataFrameReader

Eq3.Communication.DataFrameReader Class Reference

Liest synchron Datenrahmen aus einem Stream. More...

Collaboration diagram for Eq3.Communication.DataFrameReader:
[legend]

List of all members.

Public Member Functions

DataFrameReader (Stream baseStream)
Erstellt und initialisiert einen.
byte[] | Read ()
Liest einen Datenrahmen aus dem Stream.

Properties

Stream | BaseStream [get]
Zugrundeliegender Stream.

Private Attributes

Stream | baseStream
Zugrundeliegender Stream.
DataFrameDecoder decoder
DataFrameDecoder.

Detailed Description

Liest synchron Datenrahmen aus einem Stream.

Constructor & Destructor Documentation

Eq3.Communication.DataFrameReader.DataFrameReader ( Stream baseStream )

Erstellt und initialisiert einen.

Parameters:
baseStream

Member Function Documentation

byte [] Eq3.Communication.DataFrameReader.Read ( )

Liest einen Datenrahmen aus dem Stream.

Returns:

Member Data Documentation

Stream Eq3.Communication.DataFrameReader.baseStream [private]

Zugrundeliegender Stream.

DataFrameDecoder Eq3.Communication.DataFrameReader.decoder [private]

DataFrameDecoder.

Property Documentation

Stream Eq3.Communication.DataFrameReader.BaseStream [get]

Zugrundeliegender Stream.

The documentation for this class was generated from the following file:
  • DataFrameReader.cs


LCP100-PC-Software: Eq3.Communication.DataFrameWriter Class Reference

Eq3.Communication.DataFrameWriter

Eq3.Communication.DataFrameWriter Class Reference

Schreibt einen Datenrahmen synchron in einen Stream. More...

List of all members.

Public Member Functions

DataFrameWriter (Stream baseStream)
Erstellt und initialisiert einen neuen DataFrameWriter.
DataFrameWriter | Write (byte[] payload)
Schreibt einen Datenrahmen.

Properties

Stream | BaseStream [get]
Zugrundeliegender Stream.

Private Member Functions

byte[] | Encode (byte[] payload)
Codiert die Nutzdaten in einen Datenrahmen.
byte | HighByte (UInt16 i)
Liefert das höherwertige Byte eines 16-Bit-Wertes.
byte | LowByte (UInt16 i)
Liefert das niederwerte Byte.

Private Attributes

Stream | baseStream
Zugrundelisgender Stream.

Detailed Description

Schreibt einen Datenrahmen synchron in einen Stream.

Constructor & Destructor Documentation

Eq3.Communication.DataFrameWriter.DataFrameWriter ( Stream baseStream )

Erstellt und initialisiert einen neuen DataFrameWriter.

Parameters:
baseStream

Member Function Documentation

byte [] Eq3.Communication.DataFrameWriter.Encode ( byte[] payload ) [private]

Codiert die Nutzdaten in einen Datenrahmen.

Parameters:
payload
Returns:

byte Eq3.Communication.DataFrameWriter.HighByte ( UInt16 i ) [private]

Liefert das höherwertige Byte eines 16-Bit-Wertes.

Parameters:
i 16-bit-Wert
Returns:

byte Eq3.Communication.DataFrameWriter.LowByte ( UInt16 i ) [private]

Liefert das niederwerte Byte.

Parameters:
i 16-Bit-Wert
Returns:

DataFrameWriter Eq3.Communication.DataFrameWriter.Write ( byte[] payload )

Schreibt einen Datenrahmen.

Parameters:
payload Nutzdaten
Returns:
DataFrameWriter

Member Data Documentation

Stream Eq3.Communication.DataFrameWriter.baseStream [private]

Zugrundelisgender Stream.

Property Documentation

Stream Eq3.Communication.DataFrameWriter.BaseStream [get]

Zugrundeliegender Stream.

The documentation for this class was generated from the following file:
  • DataFrameWriter.cs


LCP100-PC-Software: Eq3.Communication.DLEDecoder Class Reference

Eq3.Communication.DLEDecoder

Eq3.Communication.DLEDecoder Class Reference

DLE-Decodierung. More...

List of all members.

Public Member Functions

DLEDecoder ()
Erzeugt und initialisiert einen neuen DLEDecoder.
DLEDecoder Reset ()
Setzt den Decoder zurück.
int | Decode (byte b)
Decodiert ein Byte in Abhängigkeit des inneren Zustandes.

Private Attributes

bool | isEscaped
Zeigt an, ob das aktuelle Zeichen codiert ist.

Detailed Description

DLE-Decodierung.

Constructor & Destructor Documentation

Eq3.Communication.DLEDecoder.DLEDecoder ( )

Erzeugt und initialisiert einen neuen DLEDecoder.

Member Function Documentation

int Eq3.Communication.DLEDecoder.Decode ( byte b )

Decodiert ein Byte in Abhängigkeit des inneren Zustandes.

Parameters:
b Zu dekodierendes Byte.
Returns:
Wert des Bytes oder -ESC, falls b ein Escape-Zeichen ist.

DLEDecoder Eq3.Communication.DLEDecoder.Reset ( )

Setzt den Decoder zurück.

Returns:
Zurückgesetzter DLEDecoder

Member Data Documentation

bool Eq3.Communication.DLEDecoder.isEscaped [private]

Zeigt an, ob das aktuelle Zeichen codiert ist.

The documentation for this class was generated from the following file:
  • DLEDecoder.cs


LCP100-PC-Software: Eq3.Communication.DLEEncoder Class Reference

Eq3.Communication.DLEEncoder

Eq3.Communication.DLEEncoder Class Reference

Führt eine DLE-Codierug durch. More...

List of all members.

Static Public Member Functions

static byte[] Encode (byte[] bytes)
Führt die DLE-Codierung für ein Byte-Array durch.

Detailed Description

Führt eine DLE-Codierug durch.

Member Function Documentation

static byte [] Eq3.Communication.DLEEncoder.Encode ( byte[] bytes ) [static]

Führt die DLE-Codierung für ein Byte-Array durch.

Parameters:
bytes Uncodiertes Byte-Array.
Returns:
DLE-Codiertes Byte-Array.

The documentation for this class was generated from the following file:
  • DLEEncoder.cs


LCP100-PC-Software: Eq3.Communication.DLEEncoding Class Reference

Eq3.Communication.DLEEncoding

Eq3.Communication.DLEEncoding Class Reference

List of all members.

Static Public Member Functions

static bool | IsControlChar (byte b)
Prüft, ob ein Byte b ein Steuerzeichen ist.

Public Attributes

const byte | STX = 0x02
Start of TeXt.
const byte | DLE = 0x10
Data Link Escape.

Member Function Documentation

static bool Eq3.Communication.DLEEncoding.IsControlChar ( byte b ) [static]

Prüft, ob ein Byte b ein Steuerzeichen ist.

Parameters:
b Zu prüfendes Byte.
Returns:
true, falls b den Wert STX oder DLE hat.

Member Data Documentation

const byte Eq3.Communication.DLEEncoding.DLE = 0x10

Data Link Escape.

const byte Eq3.Communication.DLEEncoding.STX = 0x02

Start of TeXt.

The documentation for this class was generated from the following file:
  • DLEEncoding.cs


LCP100-PC-Software: Eq3.LCP100.LCP100 Class Reference

Eq3.LCP100.LCP100

Eq3.LCP100.LCP100 Class Reference

Zugriff auf das LCP100-Gerät. More...

Collaboration diagram for Eq3.LCP100.LCP100:
[legend]

List of all members.

Classes

struct | Version
Versionsnummer des LCP100. More...

Public Member Functions

LCP100 (Stream baseStream)
Erstellt und initialisiert ein LCP100.
Version GetVersion ()
Liefert die Version der LCP100-Firmware.
bool | ClearDisplay ()
Löscht das Display.
bool | ShowTestImage ()
Gibt ein Testbild aus.
bool | SendCommand (byte command)
Sendet einen Befehl an das LCP100.
bool | SendData (byte data)
Sendet Daten an das LCP100.
bool | SwitchBacklightOn ()
Schaltet die Hintergrundbeleuchtung an.
bool | SwitchBacklightOff ()
Schaltet die Hintergrundbeleuchtung aus.
bool | SavePage (int index, byte[] page)
Speichert eine Seite.
bool | ShowPage (int pageNumber, int count)
Zeigt eine Page im Display an.
byte[] | LoadPage (int pageNumber, int count)
Lädt eine Seite.

Properties

Stream | BaseStream [get]
Zugrundeliegender Stream.

Private Member Functions

bool | WriteBuffer (byte[] buffer)
Sendet Daten an das LCP100.

Private Attributes

const byte | ACK = 0x06
ACKnowledge.
const byte | NAK = 0x15
Negative AcKnowledge.
DataFrameReader reader
DataFrameReader.
DataFrameWriter writer
DataFrameWriter.
Stream | baseStream
Zugrundeliegender Stream.

Detailed Description

Zugriff auf das LCP100-Gerät.

Constructor & Destructor Documentation

Eq3.LCP100.LCP100.LCP100 ( Stream baseStream )

Erstellt und initialisiert ein LCP100.

Parameters:
baseStream

Member Function Documentation

bool Eq3.LCP100.LCP100.ClearDisplay ( )

Löscht das Display.

Returns:
Display erfolgreich gelöscht (true)

Version Eq3.LCP100.LCP100.GetVersion ( )

Liefert die Version der LCP100-Firmware.

Returns:
Firmware-Version

byte [] Eq3.LCP100.LCP100.LoadPage | ( | int | pageNumber,
 |  | int | count
 | ) |  |

Lädt eine Seite.

Parameters:
pageNumber
count Anzahl der Bytes, die geladen werden sollen
Returns:

bool Eq3.LCP100.LCP100.SavePage | ( | int | index,
 |  | byte[] | page
 | ) |  |

Speichert eine Seite.

Parameters:
index | Index
page | Seitendaten
Returns:
Seite erfolgreich gespeichert (true)

bool Eq3.LCP100.LCP100.SendCommand ( byte command )

Sendet einen Befehl an das LCP100.

Parameters:
command Befehl
Returns:
Befehl erfolgreich gesendet (true)

bool Eq3.LCP100.LCP100.SendData ( byte data )

Sendet Daten an das LCP100.

Parameters:
data Datenbyte
Returns:
Daten erfoglreich gesendet (true)

bool Eq3.LCP100.LCP100.ShowPage | ( | int | pageNumber,
 |  | int | count
 | ) |  |

Zeigt eine Page im Display an.

Parameters:
pageNumber
count
Returns:

bool Eq3.LCP100.LCP100.ShowTestImage ( )

Gibt ein Testbild aus.

Returns:
Testbild wird ausgegeben (true)

bool Eq3.LCP100.LCP100.SwitchBacklightOff ( )

Schaltet die Hintergrundbeleuchtung aus.

Returns:
Hintergrundbeleuchtung ist aus (true)

bool Eq3.LCP100.LCP100.SwitchBacklightOn ( )

Schaltet die Hintergrundbeleuchtung an.

Returns:
Hintergrundbeleuchtung ist an (true)

bool Eq3.LCP100.LCP100.WriteBuffer ( byte[] buffer ) [private]

Sendet Daten an das LCP100.

Parameters:
buffer Daten
Returns:
Senden war erfolgreich (true)

Member Data Documentation

const byte Eq3.LCP100.LCP100.ACK = 0x06 [private]

ACKnowledge.

Stream Eq3.LCP100.LCP100.baseStream [private]

Zugrundeliegender Stream.

const byte Eq3.LCP100.LCP100.NAK = 0x15 [private]

Negative AcKnowledge.

DataFrameReader Eq3.LCP100.LCP100.reader [private]

DataFrameReader.

DataFrameWriter Eq3.LCP100.LCP100.writer [private]

DataFrameWriter.

Property Documentation

Stream Eq3.LCP100.LCP100.BaseStream [get]

Zugrundeliegender Stream.

The documentation for this class was generated from the following file:
  • LCP100.cs


LCP100-PC-Software: Eq3.LCP100.LCP100.Version Struct Reference

Eq3.LCP100.LCP100.Version

Eq3.LCP100.LCP100.Version Struct Reference

Versionsnummer des LCP100. More...

List of all members.

Public Attributes

byte | Major
Hauptversion.
byte | Minor
Nebenversion.

Detailed Description

Versionsnummer des LCP100.

Member Data Documentation

byte Eq3.LCP100.LCP100.Version.Major

Hauptversion.

byte Eq3.LCP100.LCP100.Version.Minor

Nebenversion.

The documentation for this struct was generated from the following file:
  • LCP100.cs


LCP100-PC-Software: EQ3.LCP100.Demo.MainForm Class Reference

EQ3.LCP100.Demo.MainForm

EQ3.LCP100.Demo.MainForm Class Reference

Hauptfenster der Demo-Anwendung. More...

List of all members.

Public Member Functions

MainForm ()
Erstellt das Hauptfenster.

Private Member Functions

void | SavePicture (byte index, byte[] image)
Speichert ein Bild.
void | Disable ()
Deaktiviert die Steuerelemente.
void | Enable ()
Aktiviert die Steuerelemente.
void | UpdateVersion (Eq3.LCP100.LCP100.Version version)
Aktualisiert die Version.
void | Connect ()
Baut eine Verbindung auf.
void | Disconnect ()
Schließt die aktuelle Verbindung.
void | ShowImage (int index)
Zeigt ein Bild an.
void | ConnectButton_Click (object sender, EventArgs e)
Öffnet bzw. Schließt die Verbindung.
void | IndexComboBox_SelectedIndexChanged (object sender, EventArgs e)
Zeigt das ausgewählte Bild auf dem Display an.
void | LoadPictureButton_Click (object sender, EventArgs e)
Lädt das Vorschau-Bild.
void | SaveButton_Click (object sender, EventArgs e)
Speichert das Vorschau-Bild im LCP100.
void | ShowTestImageButton_Click (object sender, EventArgs e)
Zeigt das Testbild auf dem LCP100 an.
void | SwitchBackLightOnButton_Click (object sender, EventArgs e)
Schaltet die Hintergrundbeleuchtung ein.
void | SwitchBacklightOffButton_Click (object sender, EventArgs e)
Schaltet die Hintergrundbeleuchtung aus.

Private Attributes

const int | INDEX_COUNT = 64
maximale Anzahl der Bilder
const int | BAUD_RATE = 38400
Baud-Rate (serieller Port).
const int | DATA_BITS = 8
Daten-Bits (serieller Port).
const Parity | PARITY = Parity.Even
Parität (serieller Port).
const StopBits | STOP_BITS = StopBits.One
Stopp-Bits (serieller Port).
const int | READ_TIMEOUT = 10000
Lese-Timeout (serieller Port)exit.
const int | PAGE_SIZE = 512
Seitengröße.
const int | PAGES_PER_IMAGE = 64
Anzahl der 512-Byte-Seiten pro Bild.
Eq3.LCP100.LCP100 lcp100
LCP100.
bool | isConnected
Gibt an, ob momentan eine Verbindung besteht.
SerialPort | serialPort
Serieller Port.

Detailed Description

Hauptfenster der Demo-Anwendung.

Constructor & Destructor Documentation

EQ3.LCP100.Demo.MainForm.MainForm ( )

Erstellt das Hauptfenster.

Member Function Documentation

void EQ3.LCP100.Demo.MainForm.Connect ( ) [private]

Baut eine Verbindung auf.

void EQ3.LCP100.Demo.MainForm.ConnectButton_Click | ( | object | sender,
 |  | EventArgs | e |
 | ) |  |  | [private]

Öffnet bzw. Schließt die Verbindung.

Parameters:
sender
e

void EQ3.LCP100.Demo.MainForm.Disable ( ) [private]

Deaktiviert die Steuerelemente.

void EQ3.LCP100.Demo.MainForm.Disconnect ( ) [private]

Schließt die aktuelle Verbindung.

void EQ3.LCP100.Demo.MainForm.Enable ( ) [private]

Aktiviert die Steuerelemente.

void EQ3.LCP100.Demo.MainForm.IndexComboBox_SelectedIndexChanged | ( | object | sender,
 |  | EventArgs | e |
 | ) |  |  | [private]

Zeigt das ausgewählte Bild auf dem Display an.

Parameters:
sender
e

void EQ3.LCP100.Demo.MainForm.LoadPictureButton_Click | ( | object | sender,
 |  | EventArgs | e |
 | ) |  |  | [private]

Lädt das Vorschau-Bild.

Parameters:
sender
e

void EQ3.LCP100.Demo.MainForm.SaveButton_Click | ( | object | sender,
 |  | EventArgs | e |
 | ) |  |  | [private]

Speichert das Vorschau-Bild im LCP100.

Parameters:
sender
e

void EQ3.LCP100.Demo.MainForm.SavePicture | ( | byte | index,
 |  | byte[] | image |
 | ) |  |  | [private]

Speichert ein Bild.

Parameters:
index | index des Bildes
image | Bildpuffer (32 KByte)

void EQ3.LCP100.Demo.MainForm.ShowImage ( int index ) [private]

Zeigt ein Bild an.

Parameters:
index

void EQ3.LCP100.Demo.MainForm.ShowTestImageButton_Click | ( | object | sender,
 |  | EventArgs | e |
 | ) |  |  | [private]

Zeigt das Testbild auf dem LCP100 an.

Parameters:
sender
e

void EQ3.LCP100.Demo.MainForm.SwitchBacklightOffButton_Click | ( | object | sender,
 |  | EventArgs | e |
 | ) |  |  | [private]

Schaltet die Hintergrundbeleuchtung aus.

Parameters:
sender
e

void EQ3.LCP100.Demo.MainForm.SwitchBackLightOnButton_Click | ( | object | sender,
 |  | EventArgs | e |
 | ) |  |  | [private]

Schaltet die Hintergrundbeleuchtung ein.

Parameters:
sender
e

void EQ3.LCP100.Demo.MainForm.UpdateVersion ( Eq3.LCP100.LCP100.Version version ) [private]

Aktualisiert die Version.

Parameters:
version

Member Data Documentation

const int EQ3.LCP100.Demo.MainForm.BAUD_RATE = 38400 [private]

Baud-Rate (serieller Port).

const int EQ3.LCP100.Demo.MainForm.DATA_BITS = 8 [private]

Daten-Bits (serieller Port).

const int EQ3.LCP100.Demo.MainForm.INDEX_COUNT = 64 [private]

maximale Anzahl der Bilder

bool EQ3.LCP100.Demo.MainForm.isConnected [private]

Gibt an, ob momentan eine Verbindung besteht.

Eq3.LCP100.LCP100 EQ3.LCP100.Demo.MainForm.lcp100 [private]

LCP100.

const int EQ3.LCP100.Demo.MainForm.PAGE_SIZE = 512 [private]

Seitengröße.

const int EQ3.LCP100.Demo.MainForm.PAGES_PER_IMAGE = 64 [private]

Anzahl der 512-Byte-Seiten pro Bild.

const Parity EQ3.LCP100.Demo.MainForm.PARITY = Parity.Even [private]

Parität (serieller Port).

const int EQ3.LCP100.Demo.MainForm.READ_TIMEOUT = 10000 [private]

Lese-Timeout (serieller Port)exit.

SerialPort EQ3.LCP100.Demo.MainForm.serialPort [private]

Serieller Port.

const StopBits EQ3.LCP100.Demo.MainForm.STOP_BITS = StopBits.One [private]

Stopp-Bits (serieller Port).

The documentation for this class was generated from the following file:
  • MainForm.cs


LCP100-PC-Software: EQ3.LCP100.Demo.Program Class Reference

EQ3.LCP100.Demo.Program

EQ3.LCP100.Demo.Program Class Reference

List of all members.

Static Private Member Functions

static void Main ()
Der Haupteinstiegspunkt fÃ¼r die Anwendung.

Member Function Documentation

static void EQ3.LCP100.Demo.Program.Main ( ) [static, private]

Der Haupteinstiegspunkt fÃ¼r die Anwendung.

The documentation for this class was generated from the following file:
  • Program.cs


LCP100-PC-Software: LCP100Demo.Properties.Resources Class Reference

LCP100Demo.Properties.Resources

LCP100Demo.Properties.Resources Class Reference

Eine stark typisierte Ressourcenklasse zum Suchen von lokalisierten Zeichenfolgen usw. More...

Collaboration diagram for LCP100Demo.Properties.Resources:
[legend]

List of all members.

Properties

static internal
global::System.Resources.ResourceManager 		ResourceManager [get]
Gibt die zwischengespeicherte ResourceManager-Instanz zurÃ¼ck, die von dieser Klasse verwendet wird.
static internal
global::System.Globalization.CultureInfo 		Culture [get, set]
Ãberschreibt die CurrentUICulture-Eigenschaft des aktuellen Threads fÃ¼r alle Ressourcenlookups, die diese stark typisierte Ressourcenklasse verwenden.

Private Member Functions

internal Resources ()

Static Private Attributes

static
global::System.Resources.ResourceManager 		resourceMan
static
global::System.Globalization.CultureInfo 		resourceCulture

Detailed Description

Eine stark typisierte Ressourcenklasse zum Suchen von lokalisierten Zeichenfolgen usw.

Constructor & Destructor Documentation

internal LCP100Demo.Properties.Resources.Resources ( ) [private]

Member Data Documentation

global::System.Globalization.CultureInfo LCP100Demo.Properties.Resources.resourceCulture [static, private]

global::System.Resources.ResourceManager LCP100Demo.Properties.Resources.resourceMan [static, private]

Property Documentation

internal global::System.Globalization.CultureInfo LCP100Demo.Properties.Resources.Culture [static, get, set, private]

Ãberschreibt die CurrentUICulture-Eigenschaft des aktuellen Threads fÃ¼r alle Ressourcenlookups, die diese stark typisierte Ressourcenklasse verwenden.

internal global::System.Resources.ResourceManager LCP100Demo.Properties.Resources.ResourceManager [static, get, private]

Gibt die zwischengespeicherte ResourceManager-Instanz zurÃ¼ck, die von dieser Klasse verwendet wird.

The documentation for this class was generated from the following file:
  • Resources.Designer.cs


LCP100-PC-Software: LCP100Demo.Properties.Settings Class Reference

LCP100Demo.Properties.Settings

LCP100Demo.Properties.Settings Class Reference

Collaboration diagram for LCP100Demo.Properties.Settings:
[legend]

List of all members.

Properties

static Settings | Default [get]

Static Private Attributes

static Settings | defaultInstance = ((Settings)(global::System.Configuration.ApplicationSettingsBase.Synchronized(new Settings())))

Member Data Documentation

Settings LCP100Demo.Properties.Settings.defaultInstance = ((Settings)(global::System.Configuration.ApplicationSettingsBase.Synchronized(new Settings()))) [static, private]

Property Documentation

Settings LCP100Demo.Properties.Settings.Default [static, get]

The documentation for this class was generated from the following file:
  • Settings.Designer.cs


LCP100-PC-Software: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • u
  • w
Here is a list of all class members with links to the classes they belong to:

- a -

  • ACK : Eq3.LCP100.LCP100
  • AsyncDataFrameReader() : Eq3.Communication.AsyncDataFrameReader
  • asyncResult : Eq3.Communication.AsyncDataFrameReader

- b -

  • baseStream : Eq3.Communication.AsyncDataFrameReader , Eq3.Communication.DataFrameReader , Eq3.LCP100.LCP100
  • BaseStream : Eq3.LCP100.LCP100 , Eq3.Communication.DataFrameWriter , Eq3.Communication.DataFrameReader , Eq3.Communication.AsyncDataFrameReader
  • baseStream : Eq3.Communication.DataFrameWriter
  • BAUD_RATE : EQ3.LCP100.Demo.MainForm
  • buffer : Eq3.Communication.AsyncDataFrameReader

- c -

  • checksum : Eq3.Communication.CRC16
  • Checksum : Eq3.Communication.CRC16
  • ClearDisplay() : Eq3.LCP100.LCP100
  • Connect() : EQ3.LCP100.Demo.MainForm
  • ConnectButton_Click() : EQ3.LCP100.Demo.MainForm
  • crc : Eq3.Communication.DataFrameDecoder
  • CRC16() : Eq3.Communication.CRC16
  • Culture : LCP100Demo.Properties.Resources

- d -

  • DATA_BITS : EQ3.LCP100.Demo.MainForm
  • DataFrameDecoder() : Eq3.Communication.DataFrameDecoder
  • DataFrameReader() : Eq3.Communication.DataFrameReader
  • DataFrameWriter() : Eq3.Communication.DataFrameWriter
  • Decode() : Eq3.Communication.DataFrameDecoder , Eq3.Communication.DLEDecoder
  • decoder : Eq3.Communication.DataFrameReader , Eq3.Communication.AsyncDataFrameReader
  • Default : LCP100Demo.Properties.Settings
  • defaultInstance : LCP100Demo.Properties.Settings
  • Disable() : EQ3.LCP100.Demo.MainForm
  • Disconnect() : EQ3.LCP100.Demo.MainForm
  • DLE : Eq3.Communication.DLEEncoding
  • dleDecoder : Eq3.Communication.DataFrameDecoder
  • DLEDecoder() : Eq3.Communication.DLEDecoder

- e -

  • Enable() : EQ3.LCP100.Demo.MainForm
  • Encode() : Eq3.Communication.DLEEncoder , Eq3.Communication.DataFrameWriter

- f -

  • FireReceiveDataFrame() : Eq3.Communication.AsyncDataFrameReader

- g -

  • GetChecksum() : Eq3.Communication.CRC16
  • GetVersion() : Eq3.LCP100.LCP100

- h -

  • HighByte() : Eq3.Communication.DataFrameWriter

- i -

  • INDEX_COUNT : EQ3.LCP100.Demo.MainForm
  • IndexComboBox_SelectedIndexChanged() : EQ3.LCP100.Demo.MainForm
  • INIT : Eq3.Communication.CRC16
  • isConnected : EQ3.LCP100.Demo.MainForm
  • IsControlChar() : Eq3.Communication.DLEEncoding
  • isEscaped : Eq3.Communication.DLEDecoder

- l -

  • LCP100() : Eq3.LCP100.LCP100
  • lcp100 : EQ3.LCP100.Demo.MainForm
  • LoadPage() : Eq3.LCP100.LCP100
  • LoadPictureButton_Click() : EQ3.LCP100.Demo.MainForm
  • LowByte() : Eq3.Communication.DataFrameWriter

- m -

  • Main() : EQ3.LCP100.Demo.Program
  • MainForm() : EQ3.LCP100.Demo.MainForm
  • Major : Eq3.LCP100.LCP100.Version
  • MAX_PAYLOAD_LENGTH : Eq3.Communication.DataFrameDecoder
  • Minor : Eq3.LCP100.LCP100.Version

- n -

  • NAK : Eq3.LCP100.LCP100

- o -

  • OnReceiveData() : Eq3.Communication.AsyncDataFrameReader

- p -

  • PAGE_SIZE : EQ3.LCP100.Demo.MainForm
  • PAGES_PER_IMAGE : EQ3.LCP100.Demo.MainForm
  • PARITY : EQ3.LCP100.Demo.MainForm
  • payload : Eq3.Communication.DataFrameDecoder
  • Payload : Eq3.Communication.AsyncDataFrameReader.ReceiveDataFrameEventArgs
  • payloadIndex : Eq3.Communication.DataFrameDecoder
  • payloadLength : Eq3.Communication.DataFrameDecoder
  • POLYNOM : Eq3.Communication.CRC16
  • Process() : Eq3.Communication.DataFrameDecoder , Eq3.Communication.CRC16

- r -

  • Read() : Eq3.Communication.DataFrameReader
  • READ_TIMEOUT : EQ3.LCP100.Demo.MainForm
  • reader : Eq3.LCP100.LCP100
  • ReceiveDataFrame : Eq3.Communication.AsyncDataFrameReader
  • ReceiveDataFrameEventArgs() : Eq3.Communication.AsyncDataFrameReader.ReceiveDataFrameEventArgs
  • Reset() : Eq3.Communication.DLEDecoder , Eq3.Communication.CRC16
  • resourceCulture : LCP100Demo.Properties.Resources
  • resourceMan : LCP100Demo.Properties.Resources
  • ResourceManager : LCP100Demo.Properties.Resources
  • Resources() : LCP100Demo.Properties.Resources

- s -

  • SaveButton_Click() : EQ3.LCP100.Demo.MainForm
  • SavePage() : Eq3.LCP100.LCP100
  • SavePicture() : EQ3.LCP100.Demo.MainForm
  • SendCommand() : Eq3.LCP100.LCP100
  • SendData() : Eq3.LCP100.LCP100
  • serialPort : EQ3.LCP100.Demo.MainForm
  • ShowImage() : EQ3.LCP100.Demo.MainForm
  • ShowPage() : Eq3.LCP100.LCP100
  • ShowTestImage() : Eq3.LCP100.LCP100
  • ShowTestImageButton_Click() : EQ3.LCP100.Demo.MainForm
  • state : Eq3.Communication.DataFrameDecoder
  • State : Eq3.Communication.DataFrameDecoder
  • Stop() : Eq3.Communication.AsyncDataFrameReader
  • STOP_BITS : EQ3.LCP100.Demo.MainForm
  • STX : Eq3.Communication.DLEEncoding
  • SwitchBacklightOff() : Eq3.LCP100.LCP100
  • SwitchBacklightOffButton_Click() : EQ3.LCP100.Demo.MainForm
  • SwitchBacklightOn() : Eq3.LCP100.LCP100
  • SwitchBackLightOnButton_Click() : EQ3.LCP100.Demo.MainForm

- u -

  • UpdateVersion() : EQ3.LCP100.Demo.MainForm

- w -

  • Write() : Eq3.Communication.DataFrameWriter
  • WriteBuffer() : Eq3.LCP100.LCP100
  • writer : Eq3.LCP100.LCP100


LCP100-PC-Software: Package List

  • Packages

Package List

Here are the packages with brief descriptions (if available):
EQ3
Eq3
Eq3.Communication
EQ3.LCP100
Eq3.LCP100
EQ3.LCP100.Demo
LCP100Demo
LCP100Demo.Properties
Generated on Thu May 7 08:08:53 2009 for LCP100-PC-Software by doxygen 1.5.7.1


LCP100-PC-Software: Package EQ3

  • Packages

Package EQ3

Packages

package LCP100


LCP100-PC-Software: Package Eq3

  • Packages

Package Eq3

Packages

package | Communication
package | LCP100


LCP100-PC-Software: Package Eq3.Communication

  • Packages
Eq3.Communication

Package Eq3.Communication

Classes

class | AsyncDataFrameReader
Liest asynchron Datenrahmen aus einem Stream. More...
class | CRC16
Berechnet CRC16-Prüfsummen. More...
class | DataFrameDecoder
Decodiert eine Datenrahmen byteweise. More...
class | DataFrameReader
Liest synchron Datenrahmen aus einem Stream. More...
class | DataFrameWriter
Schreibt einen Datenrahmen synchron in einen Stream. More...
class | DLEDecoder
DLE-Decodierung. More...
class | DLEEncoder
Führt eine DLE-Codierug durch. More...
class | DLEEncoding


LCP100-PC-Software: Package EQ3.LCP100

  • Packages
EQ3.LCP100

Package EQ3.LCP100

Packages

package Demo


LCP100-PC-Software: Package Eq3.LCP100

  • Packages
Eq3.LCP100

Package Eq3.LCP100

Classes

class LCP100
Zugriff auf das LCP100-Gerät. More...


LCP100-PC-Software: Package EQ3.LCP100.Demo

  • Packages
EQ3.LCP100.Demo

Package EQ3.LCP100.Demo

Classes

class | MainForm
Hauptfenster der Demo-Anwendung. More...
class | Program


LCP100-PC-Software: Package LCP100Demo

  • Packages

Package LCP100Demo

Packages

package Properties


LCP100-PC-Software: Package LCP100Demo.Properties

  • Packages
LCP100Demo.Properties

Package LCP100Demo.Properties

Classes

class | Resources
Eine stark typisierte Ressourcenklasse zum Suchen von lokalisierten Zeichenfolgen usw. More...
class | Settings


LCP100-PC-Software: File Index

  • File List
  • File Members

File List

Here is a list of all files with brief descriptions:
Eq3/Properties/AssemblyInfo.cs
LCP100/Properties/AssemblyInfo.cs
LCP100Demo/Properties/AssemblyInfo.cs
AsyncDataFrameReader.cs
CRC16.cs
DataFrameDecoder.cs
DataFrameReader.cs
DataFrameWriter.cs
DLEDecoder.cs
DLEEncoder.cs
DLEEncoding.cs
LCP100.cs
MainForm.cs
MainForm.Designer.cs
Program.cs
Resources.Designer.cs
Settings.Designer.cs
Generated on Thu May 7 08:08:54 2009 for LCP100-PC-Software by doxygen 1.5.7.1


LCP100-PC-Software: AssemblyInfo.cs File Reference

  • File List
  • File Members

AssemblyInfo.cs File Reference

Variables

ï»¿using System. Reflection

Variable Documentation

ï»¿using System. Reflection


LCP100-PC-Software: AsyncDataFrameReader.cs File Reference

  • File List
  • File Members

AsyncDataFrameReader.cs File Reference

Classes

class | Eq3.Communication.AsyncDataFrameReader
Liest asynchron Datenrahmen aus einem Stream. More...
class | Eq3.Communication.AsyncDataFrameReader.ReceiveDataFrameEventArgs
Argumente des Ereignises ReceiveDataFrame. More...

Packages

package | Eq3.Communication


LCP100-PC-Software: CRC16.cs File Reference

  • File List
  • File Members

CRC16.cs File Reference

Classes

class | Eq3.Communication.CRC16
Berechnet CRC16-Prüfsummen. More...

Packages

package | Eq3.Communication


LCP100-PC-Software: DataFrameDecoder.cs File Reference

  • File List
  • File Members

DataFrameDecoder.cs File Reference

Classes

class | Eq3.Communication.DataFrameDecoder
Decodiert eine Datenrahmen byteweise. More...

Packages

package | Eq3.Communication


LCP100-PC-Software: DataFrameReader.cs File Reference

  • File List
  • File Members

DataFrameReader.cs File Reference

Classes

class | Eq3.Communication.DataFrameReader
Liest synchron Datenrahmen aus einem Stream. More...

Packages

package | Eq3.Communication


LCP100-PC-Software: DataFrameWriter.cs File Reference

  • File List
  • File Members

DataFrameWriter.cs File Reference

Classes

class | Eq3.Communication.DataFrameWriter
Schreibt einen Datenrahmen synchron in einen Stream. More...

Packages

package | Eq3.Communication


LCP100-PC-Software: DLEDecoder.cs File Reference

  • File List
  • File Members

DLEDecoder.cs File Reference

Classes

class | Eq3.Communication.DLEDecoder
DLE-Decodierung. More...

Packages

package | Eq3.Communication


LCP100-PC-Software: DLEEncoder.cs File Reference

  • File List
  • File Members

DLEEncoder.cs File Reference

Classes

class | Eq3.Communication.DLEEncoder
Führt eine DLE-Codierug durch. More...

Packages

package | Eq3.Communication


LCP100-PC-Software: DLEEncoding.cs File Reference

  • File List
  • File Members

DLEEncoding.cs File Reference

Classes

class | Eq3.Communication.DLEEncoding

Packages

package | Eq3.Communication


LCP100-PC-Software: LCP100.cs File Reference

  • File List
  • File Members

LCP100.cs File Reference

Classes

class | Eq3.LCP100.LCP100
Zugriff auf das LCP100-Gerät. More...
struct | Eq3.LCP100.LCP100.Version
Versionsnummer des LCP100. More...

Packages

package | Eq3.LCP100


LCP100-PC-Software: MainForm.cs File Reference

  • File List
  • File Members

MainForm.cs File Reference

Classes

class | EQ3.LCP100.Demo.MainForm
Hauptfenster der Demo-Anwendung. More...

Packages

package | EQ3.LCP100.Demo


LCP100-PC-Software: MainForm.Designer.cs File Reference

  • File List
  • File Members

MainForm.Designer.cs File Reference

Variables

ï»¿namespace EQ3.LCP100. Demo

Variable Documentation

ï»¿namespace EQ3.LCP100. Demo


LCP100-PC-Software: Program.cs File Reference

  • File List
  • File Members

Program.cs File Reference

Classes

class | EQ3.LCP100.Demo.Program

Packages

package | EQ3.LCP100.Demo

Variables

ï»¿using | System

Variable Documentation

ï»¿using System


LCP100-PC-Software: Resources.Designer.cs File Reference

  • File List
  • File Members

Resources.Designer.cs File Reference

Classes

class | LCP100Demo.Properties.Resources
Eine stark typisierte Ressourcenklasse zum Suchen von lokalisierten Zeichenfolgen usw. More...

Packages

package | LCP100Demo.Properties


LCP100-PC-Software: Settings.Designer.cs File Reference

  • File List
  • File Members

Settings.Designer.cs File Reference

Classes

class | LCP100Demo.Properties.Settings

Packages

package | LCP100Demo.Properties


LCP100-PC-Software: Class Members

  • File List
  • File Members
  • All
  • Variables
  • Enumerator
Here is a list of all file members with links to the files they belong to:

  • CRC_HIGH : DataFrameDecoder.cs
  • CRC_LOW : DataFrameDecoder.cs
  • Demo : MainForm.Designer.cs
  • LENGTH_HIGH : DataFrameDecoder.cs
  • LENGTH_LOW : DataFrameDecoder.cs
  • READ_DATA : DataFrameDecoder.cs
  • Reflection : LCP100Demo/Properties/AssemblyInfo.cs , LCP100/Properties/AssemblyInfo.cs , Eq3/Properties/AssemblyInfo.cs
  • System : Program.cs
  • WAIT_FOR_STX : DataFrameDecoder.cs


LCP100-PC-Software: Member List

EQ3.LCP100.Demo.MainForm Member List

This is the complete list of members for EQ3.LCP100.Demo.MainForm, including all inherited members.

BAUD_RATE | EQ3.LCP100.Demo.MainForm | [private]
Connect() | EQ3.LCP100.Demo.MainForm | [private]
ConnectButton_Click(object sender, EventArgs e) | EQ3.LCP100.Demo.MainForm | [private]
DATA_BITS | EQ3.LCP100.Demo.MainForm | [private]
Disable() | EQ3.LCP100.Demo.MainForm | [private]
Disconnect() | EQ3.LCP100.Demo.MainForm | [private]
Enable() | EQ3.LCP100.Demo.MainForm | [private]
INDEX_COUNT | EQ3.LCP100.Demo.MainForm | [private]
IndexComboBox_SelectedIndexChanged(object sender, EventArgs e) | EQ3.LCP100.Demo.MainForm | [private]
isConnected | EQ3.LCP100.Demo.MainForm | [private]
lcp100 | EQ3.LCP100.Demo.MainForm | [private]
LoadPictureButton_Click(object sender, EventArgs e) | EQ3.LCP100.Demo.MainForm | [private]
MainForm() | EQ3.LCP100.Demo.MainForm |
PAGE_SIZE | EQ3.LCP100.Demo.MainForm | [private]
PAGES_PER_IMAGE | EQ3.LCP100.Demo.MainForm | [private]
PARITY | EQ3.LCP100.Demo.MainForm | [private]
READ_TIMEOUT | EQ3.LCP100.Demo.MainForm | [private]
SaveButton_Click(object sender, EventArgs e) | EQ3.LCP100.Demo.MainForm | [private]
SavePicture(byte index, byte[] image) | EQ3.LCP100.Demo.MainForm | [private]
serialPort | EQ3.LCP100.Demo.MainForm | [private]
ShowImage(int index) | EQ3.LCP100.Demo.MainForm | [private]
ShowTestImageButton_Click(object sender, EventArgs e) | EQ3.LCP100.Demo.MainForm | [private]
STOP_BITS | EQ3.LCP100.Demo.MainForm | [private]
SwitchBacklightOffButton_Click(object sender, EventArgs e) | EQ3.LCP100.Demo.MainForm | [private]
SwitchBackLightOnButton_Click(object sender, EventArgs e) | EQ3.LCP100.Demo.MainForm | [private]
UpdateVersion(Eq3.LCP100.LCP100.Version version) | EQ3.LCP100.Demo.MainForm | [private]


LCP100-PC-Software: Member List

EQ3.LCP100.Demo.Program Member List

This is the complete list of members for EQ3.LCP100.Demo.Program, including all inherited members.

Main() EQ3.LCP100.Demo.Program [private, static]


LCP100-PC-Software: Member List

Eq3.Communication.AsyncDataFrameReader Member List

This is the complete list of members for Eq3.Communication.AsyncDataFrameReader, including all inherited members.

AsyncDataFrameReader(Stream baseStream) | Eq3.Communication.AsyncDataFrameReader |
AsyncDataFrameReader(Stream baseStream, int bufferSize) | Eq3.Communication.AsyncDataFrameReader |
asyncResult | Eq3.Communication.AsyncDataFrameReader | [private]
baseStream | Eq3.Communication.AsyncDataFrameReader | [private]
BaseStream | Eq3.Communication.AsyncDataFrameReader |
buffer | Eq3.Communication.AsyncDataFrameReader | [private]
decoder | Eq3.Communication.AsyncDataFrameReader | [private]
FireReceiveDataFrame(byte[] payload) | Eq3.Communication.AsyncDataFrameReader | [private]
OnReceiveData(IAsyncResult asyncResult) | Eq3.Communication.AsyncDataFrameReader | [private]
ReceiveDataFrame | Eq3.Communication.AsyncDataFrameReader |
Stop() | Eq3.Communication.AsyncDataFrameReader |


LCP100-PC-Software: Member List

Eq3.Communication.AsyncDataFrameReader.ReceiveDataFrameEventArgs Member List

This is the complete list of members for Eq3.Communication.AsyncDataFrameReader.ReceiveDataFrameEventArgs, including all inherited members.

Payload | Eq3.Communication.AsyncDataFrameReader.ReceiveDataFrameEventArgs
ReceiveDataFrameEventArgs(byte[] payload) | Eq3.Communication.AsyncDataFrameReader.ReceiveDataFrameEventArgs


LCP100-PC-Software: Member List

Eq3.Communication.CRC16 Member List

This is the complete list of members for Eq3.Communication.CRC16, including all inherited members.

checksum | Eq3.Communication.CRC16 | [private]
Checksum | Eq3.Communication.CRC16 |
CRC16() | Eq3.Communication.CRC16 |
GetChecksum(byte[] bytes) | Eq3.Communication.CRC16 | [static]
INIT | Eq3.Communication.CRC16 |
POLYNOM | Eq3.Communication.CRC16 |
Process(byte b) | Eq3.Communication.CRC16 |
Process(byte[] bytes) | Eq3.Communication.CRC16 |
Reset() | Eq3.Communication.CRC16 |


LCP100-PC-Software: Member List

Eq3.Communication.DLEDecoder Member List

This is the complete list of members for Eq3.Communication.DLEDecoder, including all inherited members.

Decode(byte b) | Eq3.Communication.DLEDecoder |
DLEDecoder() | Eq3.Communication.DLEDecoder |
isEscaped | Eq3.Communication.DLEDecoder | [private]
Reset() | Eq3.Communication.DLEDecoder |


LCP100-PC-Software: Member List

Eq3.Communication.DLEEncoder Member List

This is the complete list of members for Eq3.Communication.DLEEncoder, including all inherited members.

Encode(byte[] bytes) Eq3.Communication.DLEEncoder [static]


LCP100-PC-Software: Member List

Eq3.Communication.DLEEncoding Member List

This is the complete list of members for Eq3.Communication.DLEEncoding, including all inherited members.

DLE | Eq3.Communication.DLEEncoding |
IsControlChar(byte b) | Eq3.Communication.DLEEncoding | [static]
STX | Eq3.Communication.DLEEncoding |


LCP100-PC-Software: Member List

Eq3.Communication.DataFrameDecoder Member List

This is the complete list of members for Eq3.Communication.DataFrameDecoder, including all inherited members.

crc | Eq3.Communication.DataFrameDecoder | [private]
DataFrameDecoder() | Eq3.Communication.DataFrameDecoder |
Decode(byte b) | Eq3.Communication.DataFrameDecoder |
dleDecoder | Eq3.Communication.DataFrameDecoder | [private]
MAX_PAYLOAD_LENGTH | Eq3.Communication.DataFrameDecoder |
payload | Eq3.Communication.DataFrameDecoder | [private]
payloadIndex | Eq3.Communication.DataFrameDecoder | [private]
payloadLength | Eq3.Communication.DataFrameDecoder | [private]
Process(byte b) | Eq3.Communication.DataFrameDecoder | [private]
state | Eq3.Communication.DataFrameDecoder | [private]
State enum name | Eq3.Communication.DataFrameDecoder | [private]


LCP100-PC-Software: Member List

Eq3.Communication.DataFrameReader Member List

This is the complete list of members for Eq3.Communication.DataFrameReader, including all inherited members.

baseStream | Eq3.Communication.DataFrameReader | [private]
BaseStream | Eq3.Communication.DataFrameReader |
DataFrameReader(Stream baseStream) | Eq3.Communication.DataFrameReader |
decoder | Eq3.Communication.DataFrameReader | [private]
Read() | Eq3.Communication.DataFrameReader |


LCP100-PC-Software: Member List

Eq3.Communication.DataFrameWriter Member List

This is the complete list of members for Eq3.Communication.DataFrameWriter, including all inherited members.

baseStream | Eq3.Communication.DataFrameWriter | [private]
BaseStream | Eq3.Communication.DataFrameWriter |
DataFrameWriter(Stream baseStream) | Eq3.Communication.DataFrameWriter |
Encode(byte[] payload) | Eq3.Communication.DataFrameWriter | [private]
HighByte(UInt16 i) | Eq3.Communication.DataFrameWriter | [private]
LowByte(UInt16 i) | Eq3.Communication.DataFrameWriter | [private]
Write(byte[] payload) | Eq3.Communication.DataFrameWriter |


LCP100-PC-Software: Member List

Eq3.LCP100.LCP100 Member List

This is the complete list of members for Eq3.LCP100.LCP100, including all inherited members.

ACK | Eq3.LCP100.LCP100 | [private]
baseStream | Eq3.LCP100.LCP100 | [private]
BaseStream | Eq3.LCP100.LCP100 |
ClearDisplay() | Eq3.LCP100.LCP100 |
GetVersion() | Eq3.LCP100.LCP100 |
LCP100(Stream baseStream) | Eq3.LCP100.LCP100 |
LoadPage(int pageNumber, int count) | Eq3.LCP100.LCP100 |
NAK | Eq3.LCP100.LCP100 | [private]
reader | Eq3.LCP100.LCP100 | [private]
SavePage(int index, byte[] page) | Eq3.LCP100.LCP100 |
SendCommand(byte command) | Eq3.LCP100.LCP100 |
SendData(byte data) | Eq3.LCP100.LCP100 |
ShowPage(int pageNumber, int count) | Eq3.LCP100.LCP100 |
ShowTestImage() | Eq3.LCP100.LCP100 |
SwitchBacklightOff() | Eq3.LCP100.LCP100 |
SwitchBacklightOn() | Eq3.LCP100.LCP100 |
WriteBuffer(byte[] buffer) | Eq3.LCP100.LCP100 | [private]
writer | Eq3.LCP100.LCP100 | [private]


LCP100-PC-Software: Member List

LCP100Demo.Properties.Resources Member List

This is the complete list of members for LCP100Demo.Properties.Resources, including all inherited members.

Culture | LCP100Demo.Properties.Resources | [private, static]
resourceCulture | LCP100Demo.Properties.Resources | [private, static]
resourceMan | LCP100Demo.Properties.Resources | [private, static]
ResourceManager | LCP100Demo.Properties.Resources | [private, static]
Resources() | LCP100Demo.Properties.Resources | [private]


LCP100-PC-Software: Member List

LCP100Demo.Properties.Settings Member List

This is the complete list of members for LCP100Demo.Properties.Settings, including all inherited members.

Default | LCP100Demo.Properties.Settings | [static]
defaultInstance | LCP100Demo.Properties.Settings | [private, static]


LCP100-PC-Software: Alphabetical List

Class Index

A | C | D | L | M | P | R | S

A
D
DLEEncoder (Eq3.Communication)
M
R
AsyncDataFrameReader (Eq3.Communication) DataFrameDecoder (Eq3.Communication) DLEEncoding (Eq3.Communication) MainForm (EQ3.LCP100.Demo) Resources (LCP100Demo.Properties)
AsyncDataFrameReader::ReceiveDataFrameEventArgs (Eq3.Communication) DataFrameReader (Eq3.Communication)
L
P
S
C
DataFrameWriter (Eq3.Communication) LCP100 (Eq3.LCP100) Program (EQ3.LCP100.Demo) Settings (LCP100Demo.Properties)
CRC16 (Eq3.Communication) DLEDecoder (Eq3.Communication) LCP100::Version (Eq3.LCP100)

A | C | D | L | M | P | R | S


LCP100-PC-Software: Class Members - Enumerations

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events

  • State : Eq3.Communication.DataFrameDecoder


LCP100-PC-Software: Class Members - Events

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events

  • ReceiveDataFrame : Eq3.Communication.AsyncDataFrameReader


LCP100-PC-Software: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • o
  • p
  • r
  • s
  • u
  • w

- a -

  • AsyncDataFrameReader() : Eq3.Communication.AsyncDataFrameReader

- c -

  • ClearDisplay() : Eq3.LCP100.LCP100
  • Connect() : EQ3.LCP100.Demo.MainForm
  • ConnectButton_Click() : EQ3.LCP100.Demo.MainForm
  • CRC16() : Eq3.Communication.CRC16

- d -

  • DataFrameDecoder() : Eq3.Communication.DataFrameDecoder
  • DataFrameReader() : Eq3.Communication.DataFrameReader
  • DataFrameWriter() : Eq3.Communication.DataFrameWriter
  • Decode() : Eq3.Communication.DataFrameDecoder , Eq3.Communication.DLEDecoder
  • Disable() : EQ3.LCP100.Demo.MainForm
  • Disconnect() : EQ3.LCP100.Demo.MainForm
  • DLEDecoder() : Eq3.Communication.DLEDecoder

- e -

  • Enable() : EQ3.LCP100.Demo.MainForm
  • Encode() : Eq3.Communication.DLEEncoder , Eq3.Communication.DataFrameWriter

- f -

  • FireReceiveDataFrame() : Eq3.Communication.AsyncDataFrameReader

- g -

  • GetChecksum() : Eq3.Communication.CRC16
  • GetVersion() : Eq3.LCP100.LCP100

- h -

  • HighByte() : Eq3.Communication.DataFrameWriter

- i -

  • IndexComboBox_SelectedIndexChanged() : EQ3.LCP100.Demo.MainForm
  • IsControlChar() : Eq3.Communication.DLEEncoding

- l -

  • LCP100() : Eq3.LCP100.LCP100
  • LoadPage() : Eq3.LCP100.LCP100
  • LoadPictureButton_Click() : EQ3.LCP100.Demo.MainForm
  • LowByte() : Eq3.Communication.DataFrameWriter

- m -

  • Main() : EQ3.LCP100.Demo.Program
  • MainForm() : EQ3.LCP100.Demo.MainForm

- o -

  • OnReceiveData() : Eq3.Communication.AsyncDataFrameReader

- p -

  • Process() : Eq3.Communication.CRC16 , Eq3.Communication.DataFrameDecoder , Eq3.Communication.CRC16

- r -

  • Read() : Eq3.Communication.DataFrameReader
  • ReceiveDataFrameEventArgs() : Eq3.Communication.AsyncDataFrameReader.ReceiveDataFrameEventArgs
  • Reset() : Eq3.Communication.DLEDecoder , Eq3.Communication.CRC16
  • Resources() : LCP100Demo.Properties.Resources

- s -

  • SaveButton_Click() : EQ3.LCP100.Demo.MainForm
  • SavePage() : Eq3.LCP100.LCP100
  • SavePicture() : EQ3.LCP100.Demo.MainForm
  • SendCommand() : Eq3.LCP100.LCP100
  • SendData() : Eq3.LCP100.LCP100
  • ShowImage() : EQ3.LCP100.Demo.MainForm
  • ShowPage() : Eq3.LCP100.LCP100
  • ShowTestImage() : Eq3.LCP100.LCP100
  • ShowTestImageButton_Click() : EQ3.LCP100.Demo.MainForm
  • Stop() : Eq3.Communication.AsyncDataFrameReader
  • SwitchBacklightOff() : Eq3.LCP100.LCP100
  • SwitchBacklightOffButton_Click() : EQ3.LCP100.Demo.MainForm
  • SwitchBacklightOn() : Eq3.LCP100.LCP100
  • SwitchBackLightOnButton_Click() : EQ3.LCP100.Demo.MainForm

- u -

  • UpdateVersion() : EQ3.LCP100.Demo.MainForm

- w -

  • Write() : Eq3.Communication.DataFrameWriter
  • WriteBuffer() : Eq3.LCP100.LCP100


LCP100-PC-Software: Class Members - Properties

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events

  • BaseStream : Eq3.Communication.AsyncDataFrameReader , Eq3.LCP100.LCP100 , Eq3.Communication.DataFrameWriter , Eq3.Communication.DataFrameReader
  • Checksum : Eq3.Communication.CRC16
  • Culture : LCP100Demo.Properties.Resources
  • Default : LCP100Demo.Properties.Settings
  • ResourceManager : LCP100Demo.Properties.Resources


LCP100-PC-Software: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • w

- a -

  • ACK : Eq3.LCP100.LCP100
  • asyncResult : Eq3.Communication.AsyncDataFrameReader

- b -

  • baseStream : Eq3.Communication.AsyncDataFrameReader , Eq3.Communication.DataFrameReader , Eq3.LCP100.LCP100 , Eq3.Communication.DataFrameWriter
  • BAUD_RATE : EQ3.LCP100.Demo.MainForm
  • buffer : Eq3.Communication.AsyncDataFrameReader

- c -

  • checksum : Eq3.Communication.CRC16
  • crc : Eq3.Communication.DataFrameDecoder

- d -

  • DATA_BITS : EQ3.LCP100.Demo.MainForm
  • decoder : Eq3.Communication.AsyncDataFrameReader , Eq3.Communication.DataFrameReader
  • defaultInstance : LCP100Demo.Properties.Settings
  • DLE : Eq3.Communication.DLEEncoding
  • dleDecoder : Eq3.Communication.DataFrameDecoder

- i -

  • INDEX_COUNT : EQ3.LCP100.Demo.MainForm
  • INIT : Eq3.Communication.CRC16
  • isConnected : EQ3.LCP100.Demo.MainForm
  • isEscaped : Eq3.Communication.DLEDecoder

- l -

  • lcp100 : EQ3.LCP100.Demo.MainForm

- m -

  • Major : Eq3.LCP100.LCP100.Version
  • MAX_PAYLOAD_LENGTH : Eq3.Communication.DataFrameDecoder
  • Minor : Eq3.LCP100.LCP100.Version

- n -

  • NAK : Eq3.LCP100.LCP100

- p -

  • PAGE_SIZE : EQ3.LCP100.Demo.MainForm
  • PAGES_PER_IMAGE : EQ3.LCP100.Demo.MainForm
  • PARITY : EQ3.LCP100.Demo.MainForm
  • payload : Eq3.Communication.DataFrameDecoder
  • Payload : Eq3.Communication.AsyncDataFrameReader.ReceiveDataFrameEventArgs
  • payloadIndex : Eq3.Communication.DataFrameDecoder
  • payloadLength : Eq3.Communication.DataFrameDecoder
  • POLYNOM : Eq3.Communication.CRC16

- r -

  • READ_TIMEOUT : EQ3.LCP100.Demo.MainForm
  • reader : Eq3.LCP100.LCP100
  • resourceCulture : LCP100Demo.Properties.Resources
  • resourceMan : LCP100Demo.Properties.Resources

- s -

  • serialPort : EQ3.LCP100.Demo.MainForm
  • state : Eq3.Communication.DataFrameDecoder
  • STOP_BITS : EQ3.LCP100.Demo.MainForm
  • STX : Eq3.Communication.DLEEncoding

- w -

  • writer : Eq3.LCP100.LCP100


LCP100-PC-Software: Class Members

  • File List
  • File Members
  • All
  • Variables
  • Enumerator

  • CRC_HIGH : DataFrameDecoder.cs
  • CRC_LOW : DataFrameDecoder.cs
  • LENGTH_HIGH : DataFrameDecoder.cs
  • LENGTH_LOW : DataFrameDecoder.cs
  • READ_DATA : DataFrameDecoder.cs
  • WAIT_FOR_STX : DataFrameDecoder.cs


LCP100-PC-Software: Class Members

  • File List
  • File Members
  • All
  • Variables
  • Enumerator

  • Reflection : Eq3/Properties/AssemblyInfo.cs , LCP100Demo/Properties/AssemblyInfo.cs , LCP100/Properties/AssemblyInfo.cs
  • System : Program.cs


LCP100-PC-Software: Graph Legend

Graph Legend

This page explains how to interpret the graphs that are generated by doxygen.

Consider the following example:

/*! Invisible class because of truncation */
class Invisible { };

/*! Truncated class, inheritance relation is hidden */
class Truncated : public Invisible { };

/* Class not documented with doxygen comments */
class Undocumented { };

/*! Class that is inherited using public inheritance */
class PublicBase : public Truncated { };

/*! A template class */
template<class T> class Templ { };

/*! Class that is inherited using protected inheritance */
class ProtectedBase { };

/*! Class that is inherited using private inheritance */
class PrivateBase { };

/*! Class that is used by the Inherited class */
class Used { };

/*! Super class that inherits a number of other classes */
class Inherited : public PublicBase,
                  protected ProtectedBase,
                  private PrivateBase,
                  public Undocumented,
                  public Templ<int>
{
  private:
    Used *m_usedClass;
};
This will result in the following graph:

The boxes in the above graph have the following meaning:

  • A filled gray box represents the struct or class for which the graph is generated.
  • A box with a black border denotes a documented struct or class.
  • A box with a grey border denotes an undocumented struct or class.
  • A box with a red border denotes a documented struct or class forwhich not all inheritance/containment relations are shown. A graph is truncated if it does not fit within the specified boundaries.
The arrows have the following meaning:
  • A dark blue arrow is used to visualize a public inheritance relation between two classes.
  • A dark green arrow is used for protected inheritance.
  • A dark red arrow is used for private inheritance.
  • A purple dashed arrow is used if a class is contained or used by another class. The arrow is labeled with the variable(s) through which the pointed class or struct is accessible.
  • A yellow dashed arrow denotes a relation between a template instance and the template class it was instantiated from. The arrow is labeled with the template parameters of the instance.


LCP100-PC-Software: Main Page

LCP100-PC-Software Documentation

Generated on Thu May 7 08:08:53 2009 for LCP100-PC-Software by doxygen 1.5.7.1


LCP100-PC-Software: Member List

Eq3.LCP100.LCP100.Version Member List

This is the complete list of members for Eq3.LCP100.LCP100.Version, including all inherited members.

Major | Eq3.LCP100.LCP100.Version
Minor | Eq3.LCP100.LCP100.Version