Introduction
MidiPiano is a very simple and useful application, you can open MIDI file and simulate play it in a virtual keyboard and record MIDI file by the virtual keyboard or MIDI IN device.
1. Support MIDI IN/MIDI OUT devices.
2. Simple to Play and Record MIDI file.
3. Different color for tracks simulate hands.
4. Support 128 GM Patches selection.
5. Support customize keyboard layout.
6. Support plugins with user message.
7. Support multi-language.
Oops:
I'm not well at English, if you can't understand when reading. please email me or view my website.


Keyboard Layout
This is the default keyboard layout.
This is the Cakewalk keyboard layout.
Tips:
The "Layout" folder include these two configuration files.


Content
Common:
1. Volume: Set main MIDI Out Volume, same with System MIDI Volume Settings.
2. Octave: Set keyboard range from C2 to c5.
3. Speed: Set speed ratio when playing MIDI file, 1%~200%.
4. Group: Set keyboard visible range.
5. Color: Set default key down color, Right hand(Red) and Left hand(Blue) track not effected by it.
Channel:
Can set each channel's volume here, It will auto changed by MIDI event.
Display and Control:
1. Open: Open MIDI file.
2. Play: Play MIDI file.
3. Record: Record MIDI file.
YES: A new file will created.
NO: A new track will created in the opened MIDI file.
CANCEL: Cancel the record action.
4. Stop: Stop played or recorded MIDI file.
5. Save: Save the opened file to another file or save the record file.
6. Plugins: Show the plugins list, See more here.
7. Repeat: If this checked, application repeat playing until stop.
Configuration:
1. Select Midi Input and Output Devices.
2. Select GM Patches (Only touch channel-0).
3. Customize Keyboard: Set Keyboard Layout, See more here.
It can be save and load form "MidiPiano Keyboard Layer File (*.kbl)" files.
* Notice: If you changed it, you must Apply it and Save it to file, or you will lost the setting when the application closed.
Virtual Keyboard:
1. You can use computer keyboard to play piano.
2. if you press [CTRL], the key will played raise 1 note.
3 .if you press [SHIFT], the key will played with a 12 upper note.
Track/Event:
1. If the midi file have multi-tracks, you can drag each track to assign it's hand.
2. Event show MIDI Event of 0xFF(MIDI_SYSTEMRESET).
Progress Bar:
You can click it, then change the playing position, begin play at the selected position, it only enabled at playing status.
Menu:
1. About: Show about windows.
2. Help: Show help file, you are looking it...
3. Stay On Top: When it checked, the application will stay on top.
About:
The "About Windows" not support translation, and no need to registered it, I'm not ready get money from this software:~)


Contact Me
Website: http://www.MidiPiano.net
Google Group: http://groups.google.com/group/MidiPiano
Email: webmaster@midipiano.net
Author: ZiZii Wan


Last Update
v1.85 2007-7-25
1. Add space-key to pause/play.
2. Speed ratio instead of BMP.
3. Fixed crash when MIDI Devices connected error at playing time.
v1.83 2006-12-18
1. GM Patches changes can record now.
2. Application can send message to plugin's WinFrom if it's exists.
3. Fixed MIDIOutput SysExData Error.
v1.82 2006-10-29
1. Add "Auto Speed" selection.
v1.81 2006-07-05
1. Fixed keyboard group title display issue.
2. Add "Stay On Top" function in application menu.
3. Add plugins support.
v1.72 2006-06-06
1. Display betterment when Ctrl and Shift key down.
2. Fix keyboard issue when same note key down at one time.
3. Fix customize keyboard issue about note display.
4. Default select all Midi Devices, not first one.
v1.7 2006-05-29
1. Add 128 GM Patches selection function.
2. Add Repeat function, delete Reset function.
3. Fix keyboard error with [Num Lock] close.
v1.6 2006-04-30
1. Rewrite Midi File analyse/Midi Input/Output modules, it works better.
2. Support customize keyboard layout now.
3. Support Mouse move on keyboard now.
4. Spilt MidiDrum from self, load it as a external application.
v1.5 2006-03-24
1. Add Meter display.
2. Change channel display the volume.
3. Add Midi Drum Rhythm support.
4. Auto select language file.
5. Add help file (Reading?).
v1.4 2006-03-20
1. Record support pause.
2. All forms support multi-language.
3. Buttons enabled with Playing/Recording status.
v1.3 2006-03-17
1. Change name from PianoEx to MidiPiano.
2. Fixed some defects.
v1.2 2006-03-14
1. Add record function.
2. multi-language support.
3. If track = 2, auto assign hands.
4. Shareware now.
v1.1 2005-12-24
1. If track = 3, auto assign hands.
2. Save configuration, auto open last midi file.
v1.0 and before
1. Add Midi information form.
2. Speed now will changed by track event automatically.
3. Change GUI to English all.
4. Can change playing position directly now.
5. Repacked some components of this application.
6. Add blue, green colors for piano key down.
7. Different color of tracks for Left/Right hand.
8. Support MIDI input device.
9. Auto associated tracks and channels of MIDI file.
10. Auto Stop when file completed.
11. Multi-threading to play file.
12. Add volume adjustor.
13. Fix issue that pause will also make sounds.
14. Fix some sound card open MIDI failed will cause crash.
15. Add red color of piano key down.
16. Add control for channels selection.
17. Add channels display for MIDI.
18. Add control for tracks selection.
19. Fix some issue when MIDI file have no Note OFF event.
20. Add tracks information.
21. Fix MIDI file reward issue.
22. Add Pause function.


捐赠

Donate:

If you like this application, you could donate it, thank you:

Paypal Internation(USD) Donate: ziziiwan@hotmail.com

Paypal China(RMB) Donate: wanzhong@gmail.com


介绍：
迷迪虚拟钢琴是一个简单却又有用的程序，您能够通过他播放MIDI文件并在虚拟键盘模拟钢琴弹奏，也能够通过虚拟键盘或者MIDI输入设备录制MIDI文件。
1、支持 MIDI 输入/输出。
2、简单方便的播放和录制MIDI文件。
3、对轨道使用不同的颜色模拟左右手。
4、支持128种GM音色选择。
5、支持自定义键盘按键设置。
6、支持自定义消息插件。
7、支持多种语言界面。


Content

内容：
常用：
1、音量：调整 MIDI 输出主音量，同更改系统“软件合成器”效果一样。
2、音阶：设置键盘音阶范围从 C2 到 c5。
3、速度：设置播放 MIDI 文件的速率，1%～200%。
4、键组：设置键盘可见的音阶组。
5、键色：设置默认的按下键的键色，设置了左右手的情况（右手红色，左手蓝色）不受此设置影响。
通道：
能够设置每个通道的音量，此音量会受播放文件的事件自动改变。
显示与控制：
1、打开：打开播放的文件。
2、播放：开始播放文件。
3、录音：录制 MIDI 文件。
是：一个新的文件会被创建。
否：一个新的轨道会被加入打开的 MIDI 文件中。
取消：取消录音操作。
4、停止：停止播放或者录制的 MIDI 文件。
5、保存：保存打开的文件或者新录制的文件。
6、插件：显示插件列表，更详细的信息请查看这里。
7、重复：如果设置，则程序会重复播放文件直到按下停止。
配置：
1、设置 MIDI 输入/输出设备。
2、设置 GM 音色，仅对通道0有效。
3、自定义键盘：设置键盘布局，请查看这里。
自定义键盘可以保存和打开“MidiPiano Keyboard Layer File (*.kbl)”文件。
* 注意，如果改变了他，必须应用才会生效，如果不保存设置，下次打开程序会丢失配置。
虚拟钢琴键盘：
1、使用电脑键盘弹奏音符。
2、如果按下[CTRL]键，音符会高半度。
3、如果按下[SHIFT]键，音符会连同高8度音符一起弹奏。
轨道/事件：
1、如果 MIDI 文件是多个轨道，能够用拖放的方式设置左右手弹奏的轨道。
2、事件能够显示 MIDI 文件中的文字等系统事件。
播放进度条：
能够单击它改变当前文件播放的位置，仅在播放过程中有效。
菜单：
1、关于：显示关于界面。
2、帮助：显示帮助文件，就是您正在看的这个。
3、置顶：选择此选项后，程序会显示在最前面。
关于：
关于窗口没有翻译，也不需要注册，免费软件，注册模块是写着玩的。


Keyboard Layout

键盘布局：
上面是默认的键盘布局。
这个是 Cakewalk 的键盘布局。
提示：
在“Layout”目录包含了以上两个键盘布局的配置文件。


Contact Me

联系我：
网站： http://www.MidiPiano.net
论坛： http://groups.google.com/group/MidiPiano
邮件： webmaster@midipiano.net
作者：万重


Last Update

更新历史：
v1.85 2007-7-25
1. Add space-key to pause/play.
2. Speed ratio instead of BMP.
3. Fixed crash when MIDI Devices connected error at playing time.
v1.83 2006-12-18
1. GM Patches changes can record now.
2. Application able to send message to plugin's WinFrom if it's exists.
3. Fixed MIDIOutput SysExData error.
v1.82 2006-10-29
1. Add "Auto Speed" selection.
v1.81 2006-07-05
1. Fixed keyboard group title display issue.
2. Add "Stay On Top" function in application menu.
3. Add plugins support.
v1.72 2006-06-06
1. Display betterment when Ctrl and Shift key down.
2. Fix keyboard issue when same note key down at one time.
3. Fix customize keyboard issue about note display.
4. Default select all Midi Devices, not first one.
v1.7 2006-05-29
1. Add 128 GM Patches selection function.
2. Add Repeat function, delete Reset function.
3. Fix keyboard error with [Num Lock] close.
v1.6 2006-04-30
1. Rewrite Midi File analyse/Midi Input/Output modules, it works better.
2. Support customize keyboard layout now.
3. Support Mouse move on keyboard now.
4. Spilt MidiDrum from self, load it as a external application.
v1.5 2006-03-24
1. Add Meter display.
2. Change channel display the volume.
3. Add Midi Drum Rhythm support.
4. Auto select language file.
5. Add help file (Reading?).
v1.4 2006-03-20
1. Record support pause.
2. All forms support multi-language.
3. Buttons enabled with Playing/Recording status.
v1.3 2006-03-17
1. Change name from PianoEx to MidiPiano.
2. Fixed some defects.
v1.2 2006-03-14
1. Add record function.
2. multi-language support.
3. If track = 2, auto assign hands.
4. Shareware now.
v1.1 2005-12-24
1. If track = 3, auto assign hands.
2. Save configuration, auto open last midi file.
v1.0 and before
1. Add Midi information form.
2. Speed now will changed by track event automatically.
3. Change GUI to English all.
4. Can change playing position directly now.
5. Repacked some components of this application.
6. Add blue, green colors for piano key down.
7. Different color of tracks for Left/Right hand.
8. Support MIDI input device.
9. Auto associated tracks and channels of MIDI file.
10. Auto Stop when file completed.
11. Multi-threading to play file.
12. Add volume adjustor.
13. Fix issue that pause will also make sounds.
14. Fix some sound card open MIDI failed will cause crash.
15. Add red color of piano key down.
16. Add control for channels selection.
17. Add channels display for MIDI.
18. Add control for tracks selection.
19. Fix some issue when MIDI file have no Note OFF event.
20. Add tracks information.
21. Fix MIDI file reward issue.
22. Add Pause function.


捐赠：

如果您觉得本软件不错，又看在是个不错的免费软件的份上，可以适当捐赠以鼓励作者继续开发与更新：

人民币捐赠可以通过贝宝中国：wanzhong@gmail.com

其他货币捐赠可以通过Paypal国际：ziziiwan@hotmail.com