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General Introduction

General Introduction

Draw is a vector graphics drawing tool. It offers a series of powerful tools that enable you to 
quickly create all sorts of graphics.

It is perfectly integrated into the OpenOffice.org suite, and this makes exchanging graphics 
with all components of the suite very easy. For example, if you create an image in Draw, 
reusing it in a Writer document is as simple as copy and paste. You can also work with 
drawings directly from within Writer and Impress, using a subset of the functions and tools 
from Draw.

Draw’s functionality is very extensive and complete. Even though it was not designed to rival 
high-end graphics applications, Draw still possesses more functions than the majority of 
drawing tools that are integrated into office productivity suites.

A few examples of drawing functions might whet your appetite: layer management, magnetic 
grid point system, dimensions and measurement display, connectors for making organization 
charts, 3D functions enabling small three-dimensional drawings to be created (with texture 
and lighting effects), drawing and page style integration, and Bezier curves, just to name a 
few.

This document describes only the functions associated with Draw. Some notions such as file 
management or the way the OpenOffice.org environment works are mentioned only briefly as 
they are covered in the Getting Started guide.
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The Workplace

The Workplace

The main components of the Draw interface have the appearance shown in Figure 1.

Figure 1. Initial Draw window

The large area in the center of the window is where the drawings are made. It is surrounded 
by toolbars and information areas. You can vary the number and position of the visible tools, 
so your setup may look a bit different. For example, many people put the main Drawing 
toolbar on the left-hand side of the workspace, not at the bottom as shown here.
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The Toolbars

The Toolbars

The various Draw toolbars can be displayed or hidden according to your needs.

Many of the floating toolbars in OOo 1.x have become main toolbars in OOo 2.0.

Note To access any toolbar, choose View > Toolbars.

To display or hide the toolbars, simply click View > Toolbars. On the menu that appears, 
choose which toolbars to display.

You can also select the buttons that you wish to appear on the corresponding toolbar. On the 
View > Toolbars menu, select Customize, click on the Toolbars tab (see Figure 2), and then 
select the desired buttons for that toolbar. Each toolbar has a different list of buttons.

Figure 2. Customizing a toolbar
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The Toolbars

Many toolbar buttons are marked with a small arrow beside the button. The arrow indicates 
that this button has additional functions. Click the arrow and a submenu or floating toolbar 
appears, showing its additional functions (see Figure 3).

Figure 3 An arrow next to a button 
indicates additional functions

Similarly, click on the arrow on the title bar of a floating toolbar to display additional 
functions (see Figure 4).

Figure 4. An arrow on a floating toolbar indicates additional functions

You may wish to keep this submenu displayed on your screen, but in a different position than 
the default location. You can make this submenu into a floating toolbar. To do so, click the 
submenu title bar, drag it across the screen, and then release the mouse button.

Note Most buttons marked with the small arrow can become floating toolbars. The floating 
toolbar capability is common to all components of the OpenOffice.org suite.

The tools available in the various toolbars are explained in the following sections.
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The Toolbars

The Standard Bar
The Standard Bar looks like this:

It is the same for all parts of OpenOffice.org.

The Line and Filling Bar
The Line and Filling Bar (called the Object Bar in OOo 1.x) lets you modify the main 
properties of a drawing object. 

In the example above, the available functions enable you to change the color of the line 
drawn, the fill color, and so on, of a selected object. If the selected object is text, the toolbar 
changes to the one below, which is very similar to the Formatting toolbar in Writer.

The Drawing Toolbar
The Drawing toolbar is the most important toolbar in Draw. It contains all the necessary 
functions for drawing various geometric and freehand shapes and organizing them on the 
page.

The Color Bar
To display the Color Bar, use View > Toolbars > Color Bar. The toolbar then appears at the 
bottom of the workspace.

This toolbar lets you rapidly choose the color of the objects in your drawing. The first box in 
the panel corresponds to transparency (no color). 

The color palette that is shown by default can be changed using Format > Area as shown in 
Figure 5. Choose the tab marked Colors.
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The Toolbars

Figure 5. Changing the color palette

If you click on the Load Color List button (circled), the file selector asks you to choose a 
palette file (bearing the file extension .soc). Several palettes are supplied as standard with 
OpenOffice.org. For example, web.soc is a color palette that is particularly adapted to 
creating drawings that are going to appear in Web pages, because the colors will be correctly 
displayed on workstations with screens displaying at least 256 colors.

The color selection box also lets you individually change any color by modifying the 
numerical values in the fields provided to the right of the color palette. You also can click on 
Edit to display a dialog box (shown in Figure 6), making the choice of colors easier.

Figure 6. Defining color schemes
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The Toolbars

You can use the color schemes known as CMYK (Cyan, Magenta, Yellow, Black), RGB 
(Red, Green, Blue) or HSB (Hue, Saturation, Brightness).

The Options Bar
This toolbar lets you activate or deactivate various drawing aids. The Options Bar is not 
displayed by default. To display it, select View > Toolbars > Options.

The Rulers

You should see rulers on the upper and left-hand side of the workspace (see Figure 7). These 
show the size of the objects on the page. The rulers show the location of the mouse to help 
you position objects more precisely. The rulers also are used to manage handle points and 
capture lines that make positioning objects easier. 

The page margins in the drawing area are also represented on the rulers. You can change the 
margins directly on the rulers by dragging them with the mouse. To modify the units of 
measurement of the rulers, right-click on one of the two rulers. The two rulers can have 
different units.

Figure 7. Rulers in a drawing
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The Status Bar

The Status Bar

The Status Bar is located at the bottom of the screen. The middle part of this area is 
particularly relevant to the Draw module.

The sizes are given in the current unit (not to be confused with the ruler units). This unit is 
defined in Tools > Options > OpenOffice.org Draw > General, where you can also change 
the scale of the page. Another way to change the scale is to double-click on the number 
shown in the status bar.
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Drawing Basic Shapes

Drawing Basic Shapes

This chapter describes how to draw simple shapes. All shapes, whether they are simple lines, 
rectangles, or more complicated shapes, are objects. This is common notation in vector 
drawing software.

The following sections illustrate how to draw three basic shapes: a line, a rectangle and an 
ellipse. Figure 8 shows the buttons on the Drawing toolbar that correspond to the next three 
sections.

In previous versions of OOo, several toolbar buttons expanded by a long-click on a 
button with an arrow . In OOo 2.0 the expanded toolbars are separate. To see 
other button options, select View > Toolbars and choose the toolbar you need.

Figure 8: The Drawing toolbar

Note The Drawing toolbar can be positioned anywhere on or around the screen. 

Drawing a line

Click on the Line button  on the Drawing toolbar  and place the mouse cursor at the point 
where you wish to start drawing.

Click to start the line, then drag to where you want the line to end. A handle will appear at 
each end of the line, showing that this is the currently selected object. 

Figure 9: Drawing a line

12 Chapter 2  Drawing Basic Shapes



Drawing Basic Shapes

Hold down the Shift key while drawing the segment to force the line to be drawn at a multiple 
of 45° from the horizontal. 

Hold down the Alt key to draw the line symmetrically from the start point (the line extends 
out to both sides of the start point equally). This lets you draw lines by starting from the 
middle of the line.

The line you draw will have the default attributes (such as color and line type). To change the 
line attributes, click on the line to select it, right-click and change the attribute from the Line 
dialog.

Drawing a rectangle

Drawing rectangles is similar to drawing lines, except that you use the Rectangle tool  
from the Drawing toolbar. The (imaginary) line drawn with the mouse corresponds to the 
diagonal of the rectangle.

Figure 10: Drawing a rectangle

Hold down the Shift key to draw a square. Hold down the Alt key to draw a rectangle starting 
from its center.

Drawing a circle or ellipse

To draw an ellipse, use the Ellipse Button  from the Drawing toolbar. The ellipse drawn is 
the largest ellipse that would fit inside the (imaginary) rectangle drawn with the mouse.

Figure 11: Drawing a circle

Other shapes are available on the Drawing toolbar. In previous versions of OOo, 
these shapes were extended functions shown by long-clicking the Ellipse button.
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Drawing Basic Shapes

There are three other ways to draw an ellipse or circle:

• Hold down the Shift key while drawing to force the ellipse to be a circle.

• Hold down the Alt key to draw a symmetrical ellipse or circle from the center instead 
of dragging corner to corner. 

• Hold down the Ctrl key while drawing to snap the ellipse or circle to grid lines.

Note If you first press (and hold) the Control key before clicking on any of these buttons 
(Line, Rectangle, Ellipse, and Text), the chosen object appears directly on the page 
with a default size, shape and color. All of these attributes can then be changed.

The Basic Drawing Shapes

This section provides a complete overview of the basic objects in the Draw module. These 
objects can be edited, combined, and manipulated to create more complex shapes. We have 
already seen how to use some of these.

All of the tool palettes described here can be displayed from the Drawing toolbar (View > 
Toolbars > Drawing).

Text

Use the Text tool  to write text and select the font, color, size, and other attributes. Click 
on an empty space in the workspace to write the text at that spot. Press Enter to drop to the 
next line. 

When you have finished typing text, click outside the text frame. Double-click on the text at 
any time to edit it.

To add text to an object, double-click on the object, or click on the object to select it and then 
click the text tool.

When you type text, the upper toolbar includes the usual paragraph attributes: indents, first 
line and tab stops.

You can change the style of all or part of the text. The Styles and Formatting window also 
works here (select Format > Styles and Formatting or press F11), so you can create styles 
that you can reuse in other text frames exactly as you would with Writer.

Text frames can also have fill colors, shadows and other attributes, just like any other Draw 
object. You can rotate the frame and write the text at any angle. These options are available 
by right-clicking on the object.

Use the Callout tool, located on the Drawing toolbar, to create captions (also known as 
callouts or figure labels).
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Rectangles and Squares

The toolbar palette previously had 8 tools. In OOo 2.0 the rectangle is located on the 
Drawing toolbar. The other rectangle and square tools are located under the Basic 
Shapes button on the Drawing toolbar.

Circles, Ellipses and Arcs

The toolbar palette previously had 14 tools. In OOo 2.0 the Ellipse is located on the 
Drawing toolbar. The other circles, ellipses and arcs are located under the Basic 
Shapes button on the Drawing toolbar.

3D Objects
The 3D Objects palette (Figure 12) has 8 primitives that can be used to create more complex 
three-dimensional objects through merging or combination.

In OOo 2.0 the 3D Objects palette is located on the Drawing toolbar. The palette is 
not loaded by default. To load it:

1) Click on the shaded area at the far end of the Drawing toolbar  .

2) Select Visible Buttons > 3D Objects.
3) The 3D Objects button appears in the Drawing toolbar.

Figure 12: 3D objects palette

All 3D objects work in the same way: click on the button and draw a rectangle on the work 
area. You will see a boundary box (Figure 13). The final object will be drawn inside this box.
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The Basic Drawing Shapes

Figure 13: 3D boundary box

Draw includes a wide variety of 3D effects (right-click on the object and select 3D Effects 
from the pop-up menu). These include the geometry, shading, texture, color, material and 
lighting of the object. For more information, see Chapter 6, “Managing 3D Objects and 
Bitmaps” in this guide.

Curves
The Curves palette (Figure 14) offers 8 tools for drawing non-linear profiles.

In OOo 2.0 the Curve palette is located on the Drawing toolbar. If you tear off this 
palette, the title bar on the palette shows Lines, as shown in Figure 14.

Figure 14: The curves palette (incorrectly titled “Lines” in OOo 2.0)

Lines and Arrows
The Arrows palette (Figure 15) offers 10 tools for drawing lines (with or without arrows).

In OOo 2.0 the Arrows palette is located on the Drawing toolbar. If you tear off this 
palette, the title bar on the palette shows Arrows, as shown in Figure 15.
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Figure 15: The Arrows palette

Connectors
Connectors are a type of line or arrow whose ends stick to glue points on other objects. When 
you move the other object, the connector moves with it.

Connectors are particularly useful for making organizational charts. You can reorganize the 
blocks of your chart and all the connectors stay connected.

Draw has a range of advanced connector functions. 

Connector drawing basics

All objects have invisible glue points associated with them. Connectors attach themselves 
automatically to the glue points of an object. Draw sets the default number of glue points for 
an object to 4. We will see later how you can add new glue points.

The default glue points are located at the midpoints of the sides of the square bounding the 
object, as shown in Figure 16. 

Figure 16: 4 glue points

When you move one of the ends of a connector over an object, its glue points become visible. 
You can drop the end of the connector onto one of the glue points. Afterwards, whenever 
either the connector or the object is moved, the end of the connector will remain attached to 
the object glue point.
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Note Glue points are different from handles (the small blue or green squares around an 
object). Use the handles to move or resize an object; use the glue points to attach 
connectors to an object.

Figure 17: Selecting a connector

You can also drop the end of the connector onto the object. In this case, when you move the 
object or the connector, Draw will automatically choose the best glue point to minimize the 
length of the connector:

Figure 18: Selecting a gluepoint

Draw will try to avoid drawing the connector on top of the object. 

You can always break the link between a connector and an object by moving the end of the 
connector away from the glue point to which it was attached.

As with all objects, connectors have control points to make drawing easier. The main control 
point is located in the middle of the connector and lets you set the length of the segments on 
either side of the control point.

The Connectors toolbar

In OOo 2.0 the Connectors palette is located on the Drawing toolbar. If you cannot 
see it, you can launch it by clicking on the shadowed arrow at the end of the toolbar 
and choosing Visible Buttons > Connectors.

The connector toolbar (Figure 19) contains a large number of buttons. 
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Figure 19: The Connectors palette

Connectors can be grouped into four categories: 

• Traditional Connectors are like the ones you have seen so far.

• Line Connectors are made up of a line segment and two smaller segments at the 
horizontal or vertical ends.

• Straight Connectors are made up of a simple straight line.

• Curved Connectors are based on Bezier curves (Bezier curves are discussed in another 
chapter).

Editing Glue points
Glue point management is handled by a special toolbar. This toolbar is not visible by default. 
Select View > Toolbars > Gluepoints to display it.
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The Basic Drawing Shapes

Here is a brief description of the way these buttons work.

This button lets you insert a new glue point. Draw a new object. If the object is 
filled, the point can be inserted anywhere within the object, not only on its contour. 
Choose the Glue Points button  on the Drawing Toolbar. After you have chosen 
this button, click on the object to add the glue points. 

The glue points remain visible for as long as the button appears as “pressed down”. 
They are displayed as little blue crosses and the selected glue point is highlighted. 
You can move the glue points with the mouse and delete them with the Del key.

These four buttons let you choose the directions of movement that are allowed 
around the junction of a connector glue point. You can select several of these 
buttons for any given glue point.  They specify from which directions a connector 
can arrive at the glue point.

If you click on the   button, any connector placed on the glue point is forced to 
come in from the left as shown in the following drawing.

When in glue point edit mode, if you click on the   button, you can add a new 
possible direction to a glue point. If we keep the preceding example, this would 
give:

The addition of this extra direction enabled OOo to draw a shorter connector.
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When this button (“Glue Point Relative”) is active (which it is by default), resizing 
an object causes glue points to move too. The glue point moves relatively, as shown 
in the following example.

        

      If this button is deactivated, the glue point will not move.

When the button is deactivated, the last six buttons on the toolbar that were grayed 
out become usable. These buttons let you choose how the glue points will be 
rearranged when the object is resized.

These three buttons let you choose the horizontal position of the glue point. You 
can choose to maintain the same position with respect to the left edge (first button), 
the center (second button) or the right edge (third button).

As an example, in the following figures you see a glue point Horizontal left. The 
distance from the glue point to the left edge will always remain the same, unless the 
distance is larger than the object itself.

These three buttons let you choose the vertical positioning of the glue point. You 
can choose to maintain the same position with respect to the upper edge (first 
button), the center (second button) or the lower edge (third button).
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Introduction

Introduction

In this chapter, we shall look at the tools and functions that let you modify existing drawings. 
All of the functions apply to the selected object or group of objects. The selected object 
differentiates itself from any others by small colored squares or circles located around the 
object (this is also true when several objects are selected simultaneously). In the rest of this 
document, we call these points handles.

These handles form a rectangular frame that is just big enough to contain the object. Where 
several objects are selected, the frame around them corresponds to the smallest rectangle that 
can contain all of the objects. This frame is called the selection rectangle.

If the Options Bar is displayed, you can change the size of the handles using two buttons: 
Simple Handles shows the handles as flat squares, and Large Handles shows the handles in 
a larger size. You can combine the effects obtained by pressing on both buttons. You can thus 
have large handles having a 3D shape or small handles having no 3D shape. This illustration 
shows the location of the handles and other buttons.

Selection modes
There are three selection modes: moving and changing size, rotating, and editing points.

To set the default mode for selecting objects, click on the Points button  on the Drawing 
Toolbar.

When the Points button is not active, the default mode is for selections to be moved or 
changed in size; these selections are indicated by small green squares.

When the Points button is active, the default mode is for selections to be edited; these 
selections are indicated by blue squares. Some objects will have one or more extra handles, 
which are larger or colored differently. This is explained in more detail in “Editing object
points” on page 29.
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Selection modes

Selections for rotating objects are indicated by small red circles and a symbol representing 
the center of rotation. To choose these selections click on the Effects drop-down button   
from the Drawing Toolbar.

Changing the selection mode
To go from one mode to another, you can do one of the following:

Choose the Points button  from the Drawing Toolbar to switch from simple selection 
mode to Points mode. You can also use the keyboard shortcut F81 (Points).

Choose the Effects drop-down button from the Drawing Toolbar  to activate the 
Rotation mode for a selected object.

By choosing the Rotation Mode after Clicking Object button  from the Options bar, 
you can cycle through normal and rotation modes just by clicking on the object. This can 
be more convenient than clicking the object, then clicking the Rotate button from the 
Drawing Toolbar.

Selecting objects

Direct selection
To select an object, the easiest way is to click directly on it. For objects that are not filled, you 
have to click directly on the object's outline to select it.

Selection by framing
You can select several objects by dragging a large rectangle around 
the objects with the select button, as shown.

For an object to be selected, it must be entirely within the rectangle.

1 Keyboard shortcuts can be configured by the user (Tools  > Configure > Keyboard). See Chapter 1 for more 
information.
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Selecting hidden objects
When objects are located behind others, they can still be selected. To select an object that is 
covered by another object, hold down the Alt key and click the object. To select an object that 
is covered by several objects, hold down the Alt key and click through the objects until you 
reach the required underlying object. To cycle through the objects in reverse order, hold down 
the Alt+Shift keys when you click. To help in making accurate selections, you can check the 
number and type of the selected objects, shown at the left of the status bar.

Note There may be some variation in the use of the Alt key on different operating systems. 

To select an object that is covered by another object using the keyboard, press Tab to cycle 
through the objects. To cycle through the objects in reverse order, press Shift+Tab.

The easiest method is to use the Tab key to cycle through the objects, stopping at the object 
you wish to select. (This may not be practical if you have a large number of objects in your 
drawing). When you click on your selected object, its outline will appear briefly through the 
objects on top of the selected object.

In the illustration below, the square located beneath the circle was selected in this way (the 
circle was made transparent in order to see the square).

Arranging objects
In a complex drawing, you may have objects stacked up, one on top of the other. You can 
rearrange stacked objects by clicking Modify > Arrange and selecting the appropriate Bring 
Forward or Send Backward options, or by right-clicking the object and selecting Arrange 
from the context menu, then selecting the appropriate Bring Forward or Send Backward 
options. A keyboard shortcut is Shift+Ctrl++ to bring an object to the top, and Shift+Ctrl+− 
to send an object to the bottom.

Selecting several objects
To select or deselect several objects one by one, press the Shift key and click on the various 
objects to be selected or deselected. 

26 Chapter 3  Editing Objects Part 1:



Moving and dynamically adjusting an object’s size

Moving and dynamically adjusting an object’s 
size

There are several ways of moving or changing the size of an object. The method described 
here will be called dynamic in the sense that it is carried out using the mouse.

When you dynamically change an object, remember to check the right hand area of the status 
bar at the bottom of your screen. This shows detailed information about the ongoing 
manipulation. For example, during a resizing manipulation, you will see the following 
information displayed.

The information displayed changes when the mouse is moved.

Dynamic movement of objects
To move an object, select it and then click within the object’s border and hold down the left 
mouse button while moving the mouse. To drop the object at its new location, let go of the 
mouse button. During movement, the shape of the object appears as dotted lines to help with 
repositioning.

                    

Dynamic size modification of objects
To change the size of an object (or group of selected objects) with the mouse, you need to 
move one of the handles located around the selection. As shown in the following illustration, 
the outline of the resulting new object appears as a dotted line.

The results will differ depending on which handle you use. If you choose a corner handle, 
you will resize the object along two axes at the same time. If you use a side handle, the 
objects will only be resized along one axis.
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Moving and dynamically adjusting an object’s size

Note If you press the Shift key at the same time as you carry out the resizing operation, 
the size change will be carried out symmetrically with respect to the two axes, 
which enables you to keep the height/length ratio of the object.

Rotating an object
Rotating an object lets you slant the object along an axis. To do this dynamically, use the red 
handles, as you do when changing the size of the object.

Note Rotation works in a slightly different way for 3D objects, since the rotation occurs 
in 3D space and not in one plane. See also page 34 regarding rotation when Edit 
Points mode is active.

To rotate an object (or a group of objects), drag the red corner handle points of the selection 
with the mouse. The mouse cursor takes the shape of an arc of a circle with two arrows at 
each end. A dotted outline of the object being rotated appears and the current angle of rotation 
is dynamically shown in the status bar.

Rotations are made about an axis which is displayed as a small symbol. You can move the 
axis of rotation with the mouse, as shown below.

If you hold down the Shift key during the rotation, the operation will be carried out in 
increments of 15°. 

Inclination
To incline or slant an object, use the red handles located on one of the edges of the selected 
object. The inclination axis is shown as the nearest handle to the opposite edge.

As with rotation, you can set the inclination to occur as steps of 15° by pressing the Shift key 
while moving the handle.
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Figure 21 - Rounded rectangle

Figure 22 - Pie Figure 23 - Moving 
control points in the pie

Figure 24 - Circular 
segment

Figure 25 - Moving 
control points of the 

segment

Figure 20 - Simple rectangle

Editing object points

Editing object points

Draw offers a complete set of tools that let you accurately edit the contour of an object. As we 
shall see, the functions related to editing points work substantially in the same way as on 
curves. To make the most of these tools, you need to convert your objects into curves. To do 
this, select the object, then right-click and choose Convert > To Curve or choose Modify > 
Convert > To Curve  from the menu bar.

Direct operation
Some objects can be manipulated in Points mode without converting them into curves. When 
you do this, you act directly on the properties of the object. The objects involved are defined 
by the presence of one or more extra handle points. When you manipulate this handle (which 
is generally larger than the other selection handles), you will obtain various effects. The 
mouse cursor takes the shape of a pointing hand when it passes over one of these points. Here 
is the complete list of the objects concerned.

Rectangle or square. 

You can make the corners more 
or less rounded.

Arc or ellipse. 

You can change the associated 
angles. Arcs have two control 
handles.

Circular or elliptical segments. 

You can change the position of 
the edge of the segment.
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Figure 26 - Definition of 
a tangent

Editing object points

How curves work
Editing curves works on the basis of a method called Bezier curves2. The complete study of 
such curves goes beyond this particular work. We shall cover only the basics of this powerful 
method of editing the contour of an object.

Editing a point in a Bezier curve uses several mechanisms as 
represented in the drawing on the left: The main point is called 
the junction point. Two tangents project from this point, 
enabling manipulation of the curve that passes through the 
junction point. The basic idea is that, around the junction point, 
the two sides of the curve flatten out more or less along the 
tangent depending upon the size and position of the tangent.

You can create many different shapes by moving either the junction point itself, or one or 
both of the round handle points at either end of the tangent. 

The Bezier Curve Toolbar
When you work in Edit Points mode, use the Edit Points Toolbar as shown in Figure 27. 

Figure 27 - Edit Points Toolbar

On this toolbar, depending upon the selected object some buttons can be selected or not. 
When selected, their behavior is different. The role of the three buttons enabling you to 
choose the type of tangent will be described in the following chapter. The functioning of the 
other buttons will be described in relation to working examples.

The three kinds of tangent
Three buttons in the Edit Points Toolbar let you select the type of tangent and convert from 
one type to another. Only one of these buttons can be active at any given time.

2 Bezier curves were invented by Pierre Bézier, an engineer working with the Renault car manufacturer, who 
developed the technique in the 1960s. The technology was intended to make modeling the surface of vehicles 
easier.
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Figure 29 - 
Asymmetrical tangent

Figure 30 - Inflexion 
point

Figure 28 - Symmetrical 
transition

Figure 31 - Moving a junction point

Editing object points

The Symmetric Transition button   lets you work with a 
symmetrical tangent. Any movement of one or the other of the 
handles will be carried over symmetrically to the other one.

The Smooth Transition button   lets you separate the 
lengths of the two parts of a tangent. In the drawing opposite, 
you can clearly see that the curve is flatter on the longest side 
of the tangent. This kind of tangent is known as a smooth 
junction. This button should not to be confused with the 
preceding one, since their representations are fairly similar.

It is also possible to completely detach both sides of the 
tangent. In this case, the central point is known as the 
inflexion point. Using this technique, you can draw spikes and 

troughs in objects. Use the Corner Point button   to create 
an inflexion point around the selected point.

Examples
The following examples start from a filled circle. As mentioned earlier, in order to use Edit 
Points mode, you first need to convert the object to a curve. 

You will notice that after conversion, the handles located in the corners of the rectangle have 
disappeared. This behavior is normal in that the handles which are used in Edit Points mode 
are located along the trace of the drawn object.

The Move Points button  is the default mode when editing 
points. If it has not been activated, click on the button. When 
this mode is active, the mouse cursor has the following shape 
when it is hovered over an edit point:

Movement of a point is one of the easiest manipulations to do. 
Figure 35 illustrates how an egg can be drawn very easily by 
starting from a circle and dragging the the top point upwards.
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Figure 32 - Rotating a tangent

Figure 33 - Adding an edit point to 
a curve

 

Figure 34 - Deleting points from a 
curve

Editing object points

To change the location of the tangents, just move the circular 
handles at each end. The mouse cursor then looks like this:

Use the Add Points button  to add an extra edit point to an 
existing curve. Click on the curve at the spot where you want 
to insert a point and then move the mouse slightly, in any 
direction, while holding down the button. If you just click, the 
new point will not be added. 

The tangent attributes associated with the new point depend 
on the buttons that are selected on the toolbar.

The Delete Points button  has the opposite effect: it 
subtracts one or more points from the curve. The resulting 
curve stretches itself automatically around the remaining 
points after subtraction.

Select one or more points to delete. You can select several 
points by holding down the Shift key (➊).

Then click the Delete Points   button. The selected points 
disappear from the curve, which then reforms around the 
remaining points (➋).

You can also delete the selected points by pressing the Del 
key on the keyboard.
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Figure 36 - Moving a segment

Figure 37 - Closing an open 
curve

Editing object points

 

Figure 35 - Cutting a curve

Use the Split Curve button  to split or cut a curve at the 
location of the selected handle. If the object is filled, it will be 
emptied, because the curve that represented the edge is no 
longer closed.

Check that you have selected the correct handle (➊), click the 

Split Curve button  (➋) and notice that the object is no 
longer filled. You can then check, by moving the point, that 
the curve has indeed been separated (➌).

If you have an open curve, the start point of the curve is larger 
than the others.

You can also separate a curve at several points 
simultaneously. Just keep the Shift key pressed down and 
select all of the points at which the cut should occur. 

To close an existing curve, select an open curve and click on 

the Close Bézier button  . 
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Figure 39 - Moving a point on a 
curve

Editing object points

The Select button  on the Drawing Toolbar functions as a 
switch. It works as follows.

If you have two points linked together by a straight line (you 
do not need to have a curve between the points) and you insert 
a new point between them that is set at an angle to the initial 
straight line (and hence the two endpoints), then:

• If the Select button is active, you will have a drawing 
similar to that illustrated in ➊.

• If the Select button is not active, and you move the point 
you have just inserted to bring it back close to its initial 
position in the straight line, you will have a drawing 
similar to that illustrated in ➋.

The Effects drop-down button  on the Drawing Toolbar 
and the Rotation Mode after Clicking Object button  on 
the Options Toolbar can be used in Edit Point mode. In this 
case, it can be used to move a point around the contour of an 
object.

Switch into Rotation mode by clicking on either of the 
rotation buttons. Notice that in rotation mode, all of the 
tangent points become red dots.

Select the point to be moved and then drag it around the 
contour while keeping the left mouse button pressed down 
(➊). When you let go of the mouse button, the point will be 
moved to the new position (➋). 

If you move one of the handles located at the end of the 
tangents during rotation, you will make the object rotate in 
exactly the same way as with the usual rotation operations.
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Toolbars and menus

Toolbars and menus

To change an object’s attributes (such as color, border width, etc) you can use the Line and 
Filling toolbar or the context menu.

Line and Filling toolbar
If the Line and Filling toolbar is not visible, you can display it using View > Toolbars > Line 
and Filling. From here you can edit the most common object attributes. You can also open 
the Line dialog by clicking on the   icon and the Area dialog by clicking on the  icon to 
see more options.

1  Styles & Formatting 4  Line Style 7      Area dialog
2  Line dialog 5  Line Width 8–9  Area Style/Filling 
3  Arrow Style 6  Line Color 10    Shadow

When you select text, this toolbar changes to show text formatting options.

The context menu
When an object is selected, you can right-click on the object to bring up a context menu. The 
context menu provides another way to change an object’s attributes. The entries with an 
arrow contain a submenu.

Figure 40: Right-click on an object to see the context menu.
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Editing lines and borders

Editing lines and borders

Lines (like arrows) and the borders of an object are managed through the same dialog. An 
object’s border is just one type of line.

Figure 41: Lines and borders

You can change some properties from the Line and Filling toolbar. To see more options, 
select the object and click on the  icon or right-click and choose Line. This opens the Line 
dialog.

Figure 42: Line dialog (right-click on an object and choose Line).

Common line properties
Most often the property you want to change is the line’s style (solid, dashed, invisible, etc), 
its color or width. These options are all available from the Line and Filling toolbar.

Figure 43: Common line options (style, width, color).

You can also edit these properties from the Line dialog. They are on the first tab, left column. 
In addition, from the Line dialog you can also change the line’s transparency.
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Editing lines and borders

Figure 44: The blue lines have different levels  
of transparency (0%, 25% and 50%).

Drawing arrows

Arrowheads are a line property. Select a line and click on the  button. This opens the 
Arrowheads dialog. There are several types of arrowheads available. Each end of the line can 
have a different arrowhead (or no arrowhead).

Note Arrowheads are only applicable to lines. They have no effect on an object’s border.

With the Line dialog you can fine tune the arrow properties.

Figure 45: Line dialog.
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Editing lines and borders

Synchronize ends forces the two arrow ends to be the same. The Center option is easier to 
see than to explain. It makes the arrow head move outwards to be centered around the end 
point (see below).

Figure 46: Default arrowheads (left) vs  
Centered arrowheads (right).

Customizing line and arrow styles
You are not constrained to only using the line and arrow styles provided by default. You can 
modify the styles, and create your own.

Customizing line styles

On the Line dialog, click on the Line Styles tab. From here you can customize the line styles 
or create your own (click on the Add button to create your own). You can change the length 
of the dashes, the space between them, and other attributes.

Figure 47: Editing line styles.

Use the Load Line Style and Save Line Style buttons to save a new definition or read one 
from disk (file extension .sod).
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Editing lines and borders

Customizing arrow styles

You can also create your own arrowheads to create some interesting effects, such as:

The first step is to draw a curve with the shape you want for the arrowhead.

Figure 48: To create your own 
arrowhead you must first draw a curve.

Note The arrowhead must be a “curve”. A curve is something you could draw without 
lifting a pencil. For example,  is a curve but  is not a curve.

Select the curve, open the Line dialog, and go to the Arrow Styles tab. Click on Add, enter a 
name for the arrow style and click OK.

Figure 49: Adding an arrow style.

Now you can access the new style from the Arrow style list (Figure 40).
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Editing lines and borders

Figure 50: Arrow Styles list.

Editing the inside (fill) of an object

The OpenOffice.org term for the inside of an object is Area fill. The area fill of an object can 
be a uniform color, a gradient, or an image.

Figure 51: Different types of area fill.

Common fill properties
Most often you will want to use one of the standard fill options, whether it is a color, a 
gradient or an image. These options are all available from the Line and Filling toolbar.

Figure 52: Common fill options.
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Editing the inside (fill) of an object

Fill with a uniform color

Select the object you wish to edit. On the Line and Filling toolbar, select Color and then 
choose a color from the right-hand menu.

Fill with a gradient

Select the object you wish to edit. On the Line and Filling toolbar, select Gradient and then 
choose a gradient from the right-hand menu.

Fill with a line pattern

The OpenOffice.org term for line patterns is Hatching. Select the object you wish to edit. On 
the Line and Filling toolbar, select Hatching and then choose an option from the menu.
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Editing the inside (fill) of an object

Fill with an image

You can fill an object with a bitmap image (as opposed to a vector graphic image). Select the 
object you wish to edit. On the Line and Filling toolbar, select Bitmap and then choose an 
option from the menu.

Adding a shadow

In OpenOffice.org shadows are considered an area property. Click on the  icon on the Line 
and Filling toolbar (next to the area fill functions).

Advanced area fill options

Click on the Area button  to bring up the Area dialog. From this dialog you can fine tune 
the area fill of an object in greater detail.

Creating your own fill color

Click on the Colors tab. From here you can modify existing colors or create your own.
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Editing the inside (fill) of an object

Figure 53: Customizing the color palette.

Every color is specified by a combination of the three primary colors (Red, Green and Blue), 
hence the notation RGB. Change these values and click on Add.

Creating your own gradient

On the Area dialog, click on the Gradients tab. From here you can modify existing gradients 
or create your own.

Figure 54: Customizing gradients.

First you need to choose two colors. A gradient works by creating a smooth transition from 
one color to another.
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Editing the inside (fill) of an object

Then choose a type of gradient. There are several available (Linear, Axial, Radial, etc) and 
each has different options. For example, a radial gradient has a center you can specify.

Figure 55: Center option in a radial gradient.

Creating your own line pattern

On the Area dialog, click on the Hatching tab. From here you can modify existing hatchings 
(line patterns) or create your own.

Figure 56: Modifying line patterns (hatchings).

You can customize options like the spacing between lines, the angle and the color of the 
lines. There is no way to edit the line thickness.
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Editing the inside (fill) of an object

Creating your own bitmap fill

You can add your own bitmap images to the area fill. First you need to create the bitmap 
image. For example, draw something with Draw and export it to PNG.

Now open the Area dialog and click on the Bitmaps tab. From here you can add new bitmap 
images to serve as area fill.

Figure 57: You can add your own bitmap images.

Click on Import and choose the file you saved. Now you can use that image as an area fill.
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Editing the inside (fill) of an object

Customizing shadows

First select the object you want to apply a custom shadow to. Open the Area dialog and go to 
the Shadow tab. Here you can customize the shadow’s position, distance and color.

Figure 58: Customizing shadows.

Shadows can also have transparency, so that the shadow will not hide objects behind it.

Figure 59: Shadow with 50% transparency.

Adding transparency

You can make objects semi-transparent. On the Transparency tab, choose Transparency (for 
a uniform transparency) or Gradient for a gradient transparency.
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Editing size and position precisely

You can move and resize objects using a mouse, but this method is not very precise. There is 
a tool for setting an object’s size and position precisely. Right-click on an object and choose 
Position and Size (or press the F4 key).

Position and size

Open the Position and Size dialog. On the first tab you can specify the size and position of an 
object. The position is specified as the (x,y) coordinate of the base point. By default, the base 
point is the top-left corner of the object, but you can change that too on this tab.

TIP The Keep ratio checkbox is your friend. Use it to keep the right object proportion.

To “Protect” the position means that the object is fixed in place and cannot be changed. This 
is useful to avoid moving the object accidentally. Un-protect it to move it again.

TIP Cannot move an object? Check that the position is not “protected”.

Figure 60: Object size and position.
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Rotate objects

Under the Rotation tab you can rotate the object. Set the angle and center of rotation (pivot).

Figure 61: Rotating an object.

Rounded corners and shear (slant)

OpenOffice.org considers rounded corners and shear a “position and size” property. Both are 
configured on the Position and Size dialog, under the Slant & Corner Radius tab.

The corner radius gives rounded corners (the greater radius the more rounded). The Slant 
angle gives a shear. 0 degrees means “no change”, and higher degrees give more shear.
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Using styles

Suppose that you want to apply the same area fill and border to a set of objects. You can 
define a style with this combination and apply that style to multiple objects. For an 
introduction to styles, see the chapter titled “Introduction to Styles” in the Writer Guide. 
Click on the  icon on the Function Bar or press the F11 key to open the Styles and 
Formatting window.

Creating a new style

Select an object and customize the area fill and border. When you are satisfied, click on the 
 icon on the Styles and Formatting window. This defines a new style based on the selected 

object. Type a name for the new style and click OK.

Applying a style

Once the new style is defined, select another object and double-click on the style name you 
defined. The new object will acquire the area fill and line properties of that style.

TIP What happens if I modify a style after it has been applied?
Then every object with that style is updated automatically.

How to modify a style

Modifying a style is similar to creating a new style. Select an object with that style and 
change the area and line properties. When satisfied, click on the Update Style icon  .
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Special effects

Special effects

First make sure that the Drawing toolbar is selected (View > Toolbars > Drawing). On the 
Drawing toolbar, locate the Effects icon . Click on the arrow next to that icon. This 
opens a submenu with all the special effect tools (see below).

1  Effects 4  3D Rotation Object 7  Distort
2  Rotate 5  Set in Circle (Perspective) 8  Transparency
3  Flip 6  Set to Circle (Slant) 9  Gradient

Rotating an object

Click on the  icon to select the rotate tool. Then select an object. The selected object will 
have red handles instead of the usual green handles.

Grab one of the handles and move it to rotate the object. The black circle in the middle of the 
object is the pivot (center of rotation). You can move the pivot with the mouse.

Flip an object
Select an object and click on the flip icon . You will see a red line through the middle.
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Special effects

This red line is the axis of symmetry. The object will be reflected about this line. You can 
move the ends of the line with your mouse.

Then grab one of the green handles and move it across to the other side of the red line.

3D rotations
Imagine that you take a 2D object and rotate it around an axis to create a 3D object. Like this:

Start by drawing the 2D “profile” of the object.
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Special effects

Click on the 3D rotation icon . You will see a red axis with a handle at each end. This will 
be the axis of rotation for the 3D figure.

Move the ends of the axis line (the handles).

Click outside the image to complete the rotation.

To complete the effect, change the area fill to some color and add some transparency. The 
transparency makes the object look like it is made of glass.
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Distorting an image
There are two tools that let you drag the corners and edges of an object to distort the image.

Distort tool  

Slant tool    

Select an object and click on the distort icon  or the Set to circle (slant) icon . If these 
icons are not visible, you can display them using View > Toolbars > Mode. OpenOffice.org 
will ask you if you want to transform the object to a curve. This is a necessary step before 
distortion, click Yes. Then you can move the object handles to stretch it.

Note Transforming an object into a curve is a safe operation, but it cannot be reversed 
other than by clicking the Undo button.

Dynamic gradients
A “transparency gradient” is something like this. The direction and degree of an object’s fill 
color changes from opaque to transparent. In a regular gradient, the fill changes from one 
color to another, but the degree of transparency remains the same.

   

Figure 62: Transparency gradient (left) vs regular gradient (right).

To define a transparency gradient, select an object with a color fill, and then click on the 
transparency icon . A dashed line connecting two small squares appears on top of the 
object, as shown in Figure 63. Click outside the object to set the gradient.
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Special effects

Figure 63: To modify a transparency gradient, move the squares.

To define a regular gradient, select an object, choose a gradient fill from the Line and Filling 
toolbar, The gradient icon  is now active. When you click on the gradient icon, a dashed 
line connecting two squares appears on the object, just as it does for a transparency gradient.

Move the two squares to modify the gradient. You can define the direction of the gradient 
(vertical, horizontal, or at any angle) and the spot at which the transparency begins.

Note If the transparency and gradient  icons are not visible, you can display them using 
View > Toolbars > Mode.
Moving the squares will have different effects depending on the type of gradient. 
For example, for a linear gradient, the start and end squares of the gradient will 
always be situated to either side of the center point of the object.
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Managing 3D Objects

Managing 3D Objects

Even though OpenOffice.org does not claim to rival leading 3D image software packages, it 
contains a number of tools that let you create powerful 3D drawings.

Rotating 3D objects
The rotation function also works with 3D objects, but differently from flat objects. Rotation 
acts in a three-dimensional space as shown in Figure 64.

Figure 64: Rotation of a 3D object

For 3D objects, the axis of rotation is indicated by the symbol .

To do this Do this
Rotate the object about the x-axis. Move the left and right (edge) handles.
Rotate the object about the y-axis. Move the top and bottom (edge) handles.
Rotate the object about the z-axis (the axis 
coming out of the page).

Move the corner handles.

Re-locate the axis of rotation. Move the  symbol.

3D effects
3D objects have their own configuration dialog, called the 3D Effects dialog. The dialog 
contains several pages that can be selected through the buttons at the top. This chapter 
discusses each of these pages in turn.

To display the 3D Effects dialog, right-click on the object and select 3D Effects.

You can use the Material page of the 3D Effect dialog to apply 3D attributes to any 3D 
object (Figure 65).
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Figure 65: The 3D Effects dialog

To apply a 3D attribute to a selected object, choose one of the attributes from the Favorites 
zone and click the Assign icon  . 

Note Only the attributes are applied; no objects are transformed. For example, a circle 
will not turn into a torus if you click on the first defined effect in the Favorites drop-
down menu.

If the selected object is not a 3D object, it will be converted into one. The operation that 
converts a 2D object into a 3D object is called an extrusion. This mechanism lets you create a 
variety of objects.

To apply a 3D attribute to a 2D object: 

1) Choose one of the attributes from the Favorites zone and click on the Assign icon  .

2) If you do not have the 3D Effects dialog open, right-click on your 2D object, and 
choose Convert > To 3D, or go to Modify > Convert > To 3D.

An example is shown on the right.

1) Draw a circle.

2) Go to Modify > Convert > To 3D to change the circle to 3D.
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Geometry Management page

Use the Geometry page (Figure 66) to define the geometric settings that are linked to a 3D 
object. To access this page, right-click on the object, and select 3D Effects. The 3D Effects 
dialog opens, then click on the Geometry icon  .

Figure 66: The Geometry Page

The Rounded edges parameter applies when you turn a 2D shape into a 3D shape. It defines 
the degree of rounding of edges during conversion, as shown in Figure 67.

(a ) (b)   

Figure 67:  Rounded edges with (a) 0% rounding and (b) 30% rounding

This parameter is particularly useful for texts that have been extruded into 3D shapes.
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The Scaled depth parameter defines the dimension ratio between the front face and the back 
face of the object. By default, the scale is set to 100%, which means that both faces will have 
the same dimensions. If you set the scaled depth to 50%, for example, with the cube above, 
you get the object shown in Figure 68.

Figure 68: Scaled depth of 50%

Here you can see that the front face has a length and breadth that is 50% smaller than the 
back face. It is even possible to set the scaled depth to more than 100% and thus have a front 
face that is larger than the back face.

The Rotation angle parameter is useful for some shapes that are made by revolving a profile 
about an axis. Use this parameter to decide whether or not the rotation will be complete 
(360°). Figure 69 shows what you can obtain with a half-sphere and a value of 270°.

Figure 69: Rotation angle of 270°

Use the Depth parameter to define the depth of a 2D object that has been transformed into a 
3D object. This value can be changed at any time. The parameter does not apply to 3D 
primitives.

Use the Horizontal and Vertical Segments parameters to define the number of segments for 
the rounded shapes. The higher the number is, the smoother the surface of the shape will be, 
but the longer it will take to display. In Figure 70 the left-hand sphere is made up of 10 
horizontal and vertical segments, whereas the right-hand sphere is made up of  25 segments.

Figure 70: 10 line segments (left) 
and 25 line segments (right).

The icons in the Normals zone let you modify the normals of 3D objects. A normal is a 
straight line that is directed perpendicularly across the surface of an object. 
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Figure 71 shows a few normals drawn on a sphere with 10 segments.

Figure 71: Object Normals

Normals let you define the exterior aspect of an object and its interactions with textures and 
lighting. When you change the normal mode (also known as the projection mode), you act on 
the geometry of an object. Here is a description of the functions that act on normals.

Object-Specific: Lets you choose the object-specific rendering that is best suited to 
the object.

Flat: Lets you create smooth surfaces. Where a sphere is concerned, we obtain a 
perfect sphere:

Sphere with smooth faces

Here in the drawing above the normals have been kept drawn on the shape so that 
you will remember that the faces are still present even if they cannot be seen.

Invert Normals: Lets you invert the normals.

Spherical: Corresponds to the projection mode illustrated above, wherein each of the 
faces is visible.

Double-Sided Illumination: Lets you light an object from the inside and outside.

Double-Sided: Lets you create double or single-sided 3D objects. When the 
extrusion function is used, the resulting objects are closed (for example, a square 
will give a cube). If you use this function, Draw will produce open objects.
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Shading Management page

The Shading page (Figure 72) covers the parameters linked to the shading of objects (such as 
shading type and shadow).

Figure 72: The Shading Page

The Shading mode refers to the method that Draw uses to render objects and their 
interaction with light. Draw offers three choices: Flat, Phong and Gouraud.

• Flat is the quickest technique, but it also gives the worst results (all of the faces are 
visible).

• Phong is an intermediate technique.

• Gouraud renders objects with the highest quality.

                                       

In the above drawing, flat shading (left) is clearly less attractive, whereas it is more difficult 
to distinguish between Phong (middle) and Gouraud shading (right). One might simply note 
that the shading appears to be more realistic with Gouraud shading than with Phong shading.
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The Shadow area of the dialog lets you display shadows under 3D objects. By changing the 
surface angle, you can obtain shadows that look more elongated or less elongated:

                                  

The first 3D sphere has a shadow with a surface angle of 0° (the paper is vertical) and the 
second has a surface angle of 45° (paper inclined at 45°).

You can also see that the shadow is displayed in such a way that it corresponds to the angle of 
illumination of the sphere.

Use the other parameters on this page to define the focal length and distance of the virtual 
camera that displays the 3D object. The closer the camera (focal length, distance)is, the 
greater the effect of perspective will be. 

Illumination Management page

Use the Illumination page (Figure 73) to define the way in which 3D objects are illuminated. 
Contrary to most 3D drawing software, the parameters can be set for each object 
independently of the others. However, in order for the drawing to be coherent, set these 
parameters the same way for all 3D objects.

Figure 73: The Illumination Page
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On this page you can select eight different light sources to illuminate the currently selected 
object. For each light source, you can specify its color and position with respect to the object. 

To choose the current light source, use the buttons representing a small light bulb. The bulbs 
that are lit correspond to an active light source and those that are not correspond to an 
inactive light source. Double-click on a button to active or deactivate the corresponding light 
source. A button that appears pressed down indicates the currently selected light source.

You can choose the color from the drop-down list or by using the small button on the right of 
the list. Define the position of the light source by moving the blank dot with the mouse or the 
slider bars on the small inset drawing located in the lower area of the Illumination page. 
Then click the Assign icon  to implement the light source setting.

Textures Management page

Before using this page, we will look at the two ways you can apply bitmapped images to an 
object.

• Right-click on the object and select Area, then on the Bitmaps tab select a bitmap 
motif.

• Use the Gallery (Figure 74). To apply a texture, first display the Gallery (Tools > 
Gallery). Then drag and drop the motif with the mouse while pressing the 
Shift+Control keys.

Figure 74: Applying a texture

The first method is better in that you can easily choose the number of tiles of the bitmap 
motif to be applied.  To open the Bitmap Application settings dialog (Figure 75), select 
Format > Area and make your background edits there.
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Figure 75: Bitmap application settings

Note The checkbox Tile in the dialog lets you specify whether you want the motif to be 
repeated (as in the cube top left) or not (as in the bottom right cube).

We have just seen how to change the number of tilings of the bitmap pattern. Now we will 
look at the method that Draw uses to project the image onto the object. This is done on the 
Textures page (Figure 76). The Textures page lets you manage the properties of a bitmap 
texture applied to an object.

Figure 76: The Textures Page
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Type lets you choose to project the image in Black & White or in Color.

Mode tells Draw whether you want to manage lighting and shadow on the selected object. In 
Figure 77 the first sphere corresponds to the setting Only Texture and the second (more 
realistic) to the setting Texture and Shading.

  

Figure 77: Example of texture settings

The six Projection X / Y icons specify the type of projection used to draw the motif on the 
object.  The settings on the X and Y axes are Object-Specific, Parallel and Circular. 
Generally, the default setting of Object-Specific can be left as it is because it gives the best 
results. 

Material Management page

The Material page (Figure 78) concerns the use of materials on the surface of 3D objects. 
Use this page to give object the appearance of commonly used materials such as plastic or 
metal.

Figure 78: The Material Page
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Use the drop-down list Favorites to choose a predefined texture. The default choices are 
Metal, Gold, Chrome, Plastic and Wood (see Figure 79).

Figure 79: Texture examples. From left to right: 
Metal, Gold, Chrome, Plastic and Wood.

The parameters you need to define are the default color and the lighting of the object, and the 
color and intensity of the spot. The spot shows how the light reacts on the object. 

Note that materials are compatible with textures. The use of materials generally lets you 
accentuate the effect of any applied textures.

Managing Bitmaps

Up to now, we have only dealt with vector drawings. Draw also includes functions for 
managing bitmaps, such as photographs. 

We will not deal very much with the bitmap editing tools since other programs (such as The 
Gimp) have more advanced functionality.

The Picture Toolbar
When a bitmap image is selected in the workspace, the Picture toolbar is displayed.

The Bitmap Image toolbar has been replaced with the Picture toolbar in OOo 2.0. 
The filters are also located on this toolbar.
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Note Any changes you make to a bitmap will change only a copy of the image file in your 
document. The original image will not be modified.

Graphics Mode:  The type of display for the image. The four 
options are:

• Default.

• Grayscale: displays the bitmap with 256 levels of gray.

• Black/White: transforms the image into a black and white 
representation.

• Watermark: fades the colors of the bitmap image to make it 
extremely pale.

Color:  The control menu is visible when you click on the 
Color button. Use the color controls to modify the level for 
each of the primary colors in the image.

You can set each color level from –100% (no color) to +100% 
(full intensity).

Adjust the brightness of the image from –100% (totally black) 
to +100% (totally white).

Adjust the contrast of the image from –100% (least contrast) 
to +100% (most contrast).

Adjust the gamma level from 0.10 to 10. This control lets you 
effectively set the monitor balance for an image created on one 
computer when the image is loaded on another computer.

Adjust the transparency of the image from 0% (opaque) to 
100% (totally transparent).

Use this tool to crop an image. When you click this button, the 
Crop dialog (Figure 80) appears. 
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In the Crop dialog (Figure 80) you can do the following:

• Cut out a part of the contour of the image. To do this, change the values in the Crop 
section (such as Left and Right). The preview display area shows the new image frame.

• Change the scale of the image up to 100%.

• Change the size of the bitmap in the current measurement unit.

Figure 80: Cropping an image

Bitmap Image Management Palette
Use the leftmost button on the Picture toolbar to display and pick the bitmap filters. 
OpenOffice.org offers 11 filters.

Inverts the colors in an image. The result looks like a color negative. This filter 
is useful for resetting the colors in a scanned negative.
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Smooths an image.

                                

Sharpens an image.

                                

Removes noise pixels from an image.
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Applies a solarization effect to an image. You can choose the degree of 
solarization for the image using a dialog box.

                                

Applies an aging effect to the image. You can set the degree of aging using a 
dialog box.

                                

The Posterize filter lets you reduce the number of colors in an image. You can 
choose the number of colors in the dialog box. The result is an image that looks 
a bit like a drawing.
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The pop art filter applies an effect that transforms the image into something 
resembling a pop art drawing:

                                

Simulates a charcoal drawing effect

                                

Applies a relief aspect to your image.
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The mosaic filter transforms the image into a pixellated mosaic.
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Grouping and combining objects

Using Draw, you can combine drawing objects together in two distinct ways: grouping and 
combining. These two methods allow you to treat multiple objects as one unit, or to merge 
objects to form a new shape.

Grouping is like putting objects in a container. You can move them in group and apply global 
changes to them. A group can always be undone and the objects that make up the group can 
always be manipulated separately.

A combination is a permanent fusion of objects leading to a new object. The original objects 
are no longer available as individual entities and the operation is irreversible.

TIP To select multiple objects, click on each object while holding down the Shift key or 
click the Select icon (on the Drawing toolbar) and draw a rectangle around the 
objects.

Grouping objects

Group by common selection

When several objects are selected, any operations you carry out are applied to all of the 
objects. For example, you can rotate a group of objects in its entirety. Groups obtained 
through common selection of several objects are undone as soon as you click outside the 
group. However, you can group objects and keep those selected objects grouped together.

Maintaining groups and undoing groups

To group selected objects, right-click and choose Group from the context menu. You can also 
use the keyboard shortcut Control+Shift+G or choose Modify > Group from the menu bar.

Figure 81: Grouping objects from the context menu.

When objects are grouped, any editing operations carried out on that group are applied to all 
members of the group. If you click on one member of the group, the whole group is selected.

The objects of a group maintain their individuality. To undo a group, right-click and choose 
Ungroup from the context menu or choose Modify > Ungroup from the menu bar.

Editing individual objects in a group

You can always edit a member of a group individually without breaking the group. To do this, 
right-click and choose Enter group or double-click on the group.
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Figure 82: When you enter a group, objects outside the group 
can not be selected and are grayed out.

Once inside the group, click on any object to edit it.

Figure 83: Editing an object inside a group.

To leave this mode, right-click and choose Exit group or double-click outside the group.

Nesting groups

You can create “nested” groups, or groups of groups. In this case, OpenOffice.org keeps the 
initial group hierarchy. If you ungroup a group made of other groups, you are left with 
individual groups that you can then ungroup further.

Combining objects
In contrast to grouping functions, combinations create a new object. Select a collection of 
objects, then right-click and choose Combine from the context menu. The result of this 
operation is shown below.

  

Figure 84: Combining objects

At first glance, this can seem rather surprising. Once you have understood the rules governing 
combination in OpenOffice.org, it will become clear.

• The attributes (for example, area fill) of the resulting object are those of the object furthest 
back. In this example, it is the circle.

• Where the objects overlap, the overlapping zone is either filled or empty depending on the 
number of overlaps. When the number of overlaps is even, you get an empty space; when 
the number is odd, you get a filled area.
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1

1

132

2

2

Figure 85: Odd overlaps are filled, even 
overlaps are empty.

TIP How do I move an object so it is further back or closer to the front? See page 80.

Merge, subtract or intersect shapes
The functions Merge, Subtract, and Intersect can be reached though the group’s context 
menu, under the heading Shapes.

Merge

When you merge objects, the new object covers the entire surface of the original objects (it is 
the union of the objects).

Subtract

When you subtract, the upper object is subtracted from the lower object.
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Intersect

When you intersect two objects, you get the area covered by both objects.

TIP How do I move an object so it is further back or closer to the front?
See page 80.

Practical example

The following example shows how one can use the shape merge functions to create a 
complex shape.

1) Draw an ellipse and then a rectangle overlapping half of its width.

2) Select both shapes, right-click, and choose Shapes > Subtract from the context menu.

    

3) Draw another rectangle and put it over the top half of the ellipse. Then subtract again.

    

4) Draw a small ellipse covering just the lower corner and subtract again.

    

5) To make the handle, draw a rectangle and an ellipse as shown.
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6) Merge the shapes together.

    

7) Group this image with the previous one.

Aids for positioning objects

Draw has various tools to help you arrange the objects with respect to each other. Here we 
explore some of the more important ones.

Moving an object to the front or to the back
When you combine or merge objects, the end result varies drastically depending on which 
object is “in front” and which one is “in the back”.

  

Figure 86: Subtracting objects: the result varies depending on which object is in front

First select an object, then click on  to open the Position toolbar.

1  Bring to Front 5  In Front of Object
2  Bring Forward 6  Behind Object
3  Send Backward 7  Reverse
4  Send to Back
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 brings the selected object to the front of the group.

 brings the selected object one step upwards.

 brings the selected object one step backwards.

 brings the selected object to the back of the group.

 moves the selected object in front of another chosen object.
 moves the selected object behind another chosen object.
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 reverses the order of the selected objects.

Aligning objects

Click on  to open the Align toolbar. This toolbar helps you position an object with 
respect to another.

1  Align left 4  Align top
2  Centre horizontally 5  Centre vertically
3  Align right 6  Align bottom

 Align left.

 Center horizontally.

 Align right.
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 Align top.

 Center vertically.

 Align bottom.
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Place objects with precision

Draw has several tools to help you place objects with precision.

Use zoom to place objects with precision

Figure 87: With zoom you can place objects with 
higher precision.

Zoom using the status bar

The current zoom value is displayed in the status bar:

Figure 88: Zoom level on the status bar.

Double-click on the zoom value to display the Zoom window. From the Zoom window you 
can change the zoom factor.

You can enter a zoom value in the Variable box, or you can choose from one of the pre-set 
zoom values (see Figure 89):

• Entire Page displays the whole page on the screen.

• Page Width sets the right and left edges of the page to the window.

• Optimal sets the zoom so that your drawing just fits in the window.
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Figure 89: Zoom values: Entire Page, Page Width, Optimal

Zoom toolbar

The Zoom toolbar provides additional zoom options. On the Standard toolbar (View > 
Toolbars > Standard), click on the downwards arrow of the Zoom button .

Click on the Zoom In button  and then on an object to zoom into that object. Click on the 
Zoom Out button   to zoom out.

You can also zoom in using the + key on the numeric keypad and zoom out using the – key.

Use snap to grid to place objects with precision
The grid utility is one of Draw’s most useful tools for moving objects precisely. First, make 
the grid visible with View > Grid > Display Grid.

Figure 90: Black dots on the background show the grid.

I can’t see the grid dots!

By default the grid dots are light gray, which can be very hard to see. To improve visibility, 
go to Tools > Options, then OpenOffice.org > Appearance.

Figure 91: Changing the grid color.
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Under Custom colors, scroll down until you see Drawing / Presentation. Then set the Grid 
color to a darker color like black.

Snap to grid

What makes the grid really useful is that you can have objects snap to the grid. That is, the 
object handles are always positioned exactly on the dots of the grid. Choose View > Grid > 
Snap to Grid.

Figure 92: With snap to grid, objects align 
to the grid precisely.

Configuring the grid

You can configure several aspects of the grid like the spacing between dots. Go to Tools > 
Options > OpenOffice.org Draw > Grid.

Figure 93: Configuring the grid.
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On this dialog you can configure several grid properties.

• Resolution: The width (horizontal) and height (vertical) of the grid rectangles.

  

Figure 94: Grid resolution.

• Subdivisions: Additional points that appear along the sides of each rectangle or square 
in the grid. Objects snap to subdivisions as well as to the corners of the grid.

Figure 95: Grid subdivisions.

Use snap lines to place objects with precision
Guides or snap lines are dashed horizontal or vertical lines to which you can snap objects. 

Figure 96: Object snaps to the 
snap line.

Inserting a snap line

To insert a snap line:

1) Hover the mouse cursor over either ruler.

2) Click and hold the left mouse button down.

3) Move the mouse cursor into the drawing area to drag the snap line.

You can always move a snap line with the mouse. However, moving snap lines will not move 
any objects that have been snapped to that line.
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Position a snap line with precision

Go to Insert > Insert Snap Point/Line. In the following dialog, define the X or Y position of 
the snap line. You can use this same dialog to create a snap point.

You can also edit an existing snap point or snap line. Right-click on the snap line and choose 
Edit Snap Line.

Use guiding lines to place objects with precision
You can have OpenOffice.org Draw display guiding lines while an object is being moved. 
They show more clearly the edges of the object being moved.

Figure 97: Guiding lines when an 
object is moved.

Go to Tools > Options > OpenOffice.org Draw > View. Under Display, check Guides 
when moving. Now all objects will show guiding lines when you move them.
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Make complex diagrams with layers

Layers are like transparencies on an overhead projector. You can create complex drawings by 
stacking layers together. For example, in architecture you could have the basic plan of a 
building in one layer and the piping on another layer, and the electrical circuits on another.

In Draw, three layers are always present by default: Layout, Controls, and Dimension Lines.

To activate a layer, click on its tab. When you draw something, the drawing is placed on the 
currently selected layer (usually “Layout”). To create a new layer, select  Insert > Layer.

Right-click on a layer tab to bring up a menu where you can insert or delete a layer, rename 
an existing layer or modify it. You can change the names of user-defined layers; the default 
layer names cannot be changed.

If you choose Modify, you will see the following dialog box:

On the Modify Layer dialog, you can specify layer properties:

• Visible: Whether the layer is visible.

• Printable: Whether or not the layer is printed. This is useful for guides or annotations 
that help you make the drawing but should not appear in the final output.

• Protected: Objects on a protected layer cannot be moved. For example, if one layer has 
the basic plan of a building, you could protect it while you draw the pipes.
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Cool effects

Duplication

Duplication makes copies of an object while applying a set of changes (such as color or 
rotation) to the duplicates. To start duplication, click on an object or group and choose Edit > 
Duplicate. The Duplicate dialog appears:

Choose the number of copies, their separation (placement), rotation, and so on. Here is an 
example of the result.

Figure 98: The duplicate tool in action.
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Cross-fading

Cross-fading transforms one shape into another. The result is a new group of objects 
including the two end points and the intermediate steps. To do a cross-fade, select two 
objects.

Then choose Edit > Cross-fading.

On the dialog choose the number of increments (transition steps). You probably want to have 
Cross-fade attributes and Same orientation both checked. The end result is shown below.

Figure 99: Cross-fading.
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Which object goes in front?

How do I tell OpenOffice.org  I want  and not ?

If you want  then select  (the object we want in front), right-click and choose 

Arrange > Bring to Front. Or select  (the object we want behind), right-click and choose 
Arrange > Send to Back.
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