Discovery Session 12

Using the Touch Screen

In this session we will implement the touch screen 10 and discover how to display (x, y) points detected whenever
pressure is applied — sending them to the Terminal instrument in Altium Designer.

This tutorial assumes you have an elementary understanding of how to create a System-on-FPGA design in Altium
Designer using OpenBus and Schematic Documents, how to configure peripherals and break-out their connections, as
well as create a linked embedded project containing the Software Platform Builder. No additional information is

required.

This exercise uses the following components:
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Component Library Name in Library
TSK3000A
TSK-3000A
32-hit RISC
Processor OpenBus Palette TSK3000A
10 MEM
WB_INTERCON
OpenBus Palette Interconnect
WB_MULTIMASTER
1
OpenBus Palette Arbiter

WB_MEM_CTRI, SRAM
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OpenBus Palette
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TERMIMAL

L

OpenBus Palette

Terminal instrument
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WE_ILIS320

£

OpenBus Palette

VGA 32-Bit ILI19320

WE_SPI |

sel

OpenBus Palette

SPI

WE_TIPENDOWHN

2,

OpenBus Palette

Touchscreen Pen Control

FPGA Generic.IntLib

IOBUF16B

o e

FPGA Generic.IntLib

INV

@ [COKERD=-

FPGA NB3000 Port-Plugin.IntLib

CLOCK_BOARD

TFT_DB[15.0] <t

FPGA NB3000 Port-Plugin.IntLib TFT_LCD
[ TFTTSC BUSY >
TFT_TSC CLK <+
— D FPGA NB3000 Port-Plugin.IntLib TFT_PEN
TFT_TSC DIN >
[ TFT_TSCIRQ N -~
<= SRAMO_D[15..0]
=3 SRAMO_A[17..0]
- SRAMO_E
B SRAMO
| S]U\MU_UIS
-~ SRAMO_LB
FPGA NB3000 Port-Plugin.IntLib
<r= SRAMI_D[15..0]
=3 SRAMI_A[17.0]
-4 SRAMI_E
- ."?R}\MI_W:
S SRAML
~={_SRAMI_LB

FPGA NB3000 Port-Plugin.IntLib

TEST_BUTTON

Table 1. List of components required by the design
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1. Create a new FPGA project in a new folder and name it TFT_TOUCH.PrjFpg. Add a new OpenBus document
and a Schematic document, saving them respectively as TFT_TOUCH_OB.OpenBus and
TFT_TOUCH_TOP.SchDoc.

2. Inthe OpenBus document, create a system design with the following components from the OpenBus Palette:

a. TSK-3000A CPU
b. Wishbone Interconnect (x2)
c. Wishbone Arbiter
d. Terminal Instrument
e. Touchscreen Pen Control
f.  SPI Controller
g. VGA 32-Bit ILI9320
h. SRAM Controller
TERMIMAL_1
TOUTCHSCR. E
w |
‘_ﬂj” WE_INTERQON 1

SPI

TSK30004_1
WB_INTERCON 2 WEB_MULTIMASTER_1

TSK-2000A
32-hit RISC é 1 [ g
Processor

10

4

WB_ILI9320_1

Figure 1. OpenBus System for the TFT_TOUCH design.

Join up the components as shown in Figure 1.

Configure the SRAM controller (called XRAM in Figure 1) to be Asynchronous SRAM, 1 MB (256K x 32-bit), 2
x 16-bit Wide Devices.

Configure the SPI device to use 32-hit transfers and uncheck the Enable Mode Pin option.

Make sure the TFT controller (designator WB_ILI9320 1) is the high-priority master (0) to the Arbiter
(designator WB_MULTIMASTER_1), then save your work.

Select Tools»OpenBus Signal Manager from the menus, to open the OpenBus Signal Manager dialog.
Select the Interrupts tab and assign the 1LI9320 Controller (TFT controller) interrupt to INT_IO of the
TSK3000A.

In the schematic document, add all the components listed in Table 1.

Add the necessary Sheet Symbol for the OpenBus system document using Design»Create Sheet Symbol
from Sheet of HDL.
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Figure 2. Top-level schematic for the TFT_TOUCH design.

10.

11.
12.

13.
14.

15.
16.

Wire up the top-level schematic as shown in Figure 2, using the pre-defined Harness Connectors as done in
prior sessions.

Save your work using File»Save All.

Compile the FPGA project to ensure there are no errors in your wiring.

Create a new embedded project in the workspace and save it as Embedded_TFT_TOUCH.PrjEmb.

Use the Structure Editor view in Projects panel to link the new embedded project to your FPGA project, as
done in earlier sessions.

Add a new Software Platform Builder document to the project and name it TFT_TOUCH.SwPlatform.

In the TFT_TOUCH. SwPlatform document, import the C code wrappers from the FPGA project, and grow
the software stacks up to contain the Graphics, Pointer and Serial 10 services. It should look like Figure 3.
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E Senal Device 1/0 Context

D SERIAL_1
Pointer Context {
POINTER_1 "'
Touchscreen Context
TOUCHSCREEN 1 A
ADT843 Touchscreen Digitizer Driver Graphics Context | | Serial Device I,/0 J
) Context
DRY_AD7843_1 Al GRAPHICS_1 SERIAL_1
SPI Driver Touchscreen Pen ¥GA Module Driver ¥irtual Terminal Driver
Detector
DRY_SPI_1 DRY_YGA_ILI9320_1 M | | DRY_TERMIMAL_1
SPI Master Controller ¥GA TFT-Module ¥irtual Terminal
Controller Instrument

SPI TOUCHSER, A WE_ILI9520_1 A | | TERMIMAL 1
o Import from FPGA ] [ J Add New Wrapper... l [ ) Grow Stack Up...

Tvpe Included Service Description # [ Related Options: Generic Device 1A~

Optional Mot Currently Ir Message Queuss Supp Support For POSIX message communications Standard Input  [¥

Cptional Mok Currently Ir Signalling Support Basic support For POSLY signals stdin device name SERIAL_1

Optional Mok Currently Ir Multithreading Suppor! Basic suppark For POSTE mulki-threading stdin buffering typ None
4 Syskem #lways Inchudec Software Platform Cor Global configuration for the Software Platform Standard Output [
4 Aubomatic Included Graphics Services Graphics routines For line, reckangle, kriangle, circ stdout device nan SERIAL 1
# Aubomatic Included Pointer Services Generic pointer routines stdout buffering ty Line [
# Aubomatic Included Touchscreen Services Generic kouchscreen routines, inluding calibr ation
# Aubomatic Included Serial Device I Seryi POSIX compatible interface for serial devices,

e
) APl Reference -k Compile Project

Figure 3. Software Platform for the TFT_TOUCH design.

17. Inthe TFT_TOUCH.SwPlatform file, select the Touchscreen Context. In the right-hand panel ensure that
the Settings field is set to NB300O, by clicking in the field and selecting from the drop-down that appears.

18. Next, select the Pointer Context, and in the right-hand panel set the Left Boundary and Top Boundary fields
to 0, the Right Boundary to 320 and the Bottom Boundary to 240.

19. Select the Serial Device I/O Context and note it's ID. Then in the Software Services (lower) pane of the
TFT_TOUCH.SwPlatform file select Serial Device I/O Services. Check the boxes and link Standard Input,
Standard Output and Standard Error to the SERIAL_1 device (Terminal Instrument). This allows you to use
C Standard 10 printf() to put text on the terminal in Altium Designer. It should look like Figure 3.

20. Add a source code file main.c to your embedded project, and add the code to it as shown in Table 2. Save
your work.
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#include <stdio.h>

#include <graphics.h>
#include <touchscreen.h>
#include <pointer.h>
#include "generic_devices.h"
#include "devices.h"

#define WIDTH 320
#define HEIGHT 240

// Function prototypes
static void draw_mark(int x, int y, int width, int height, void *vp);

char *call = "Touch screen at marker";
char *cal2 = "Calibration done";

// Pointers for LCD, Touch panel, and graphics drivers
graphics_t * display;

canvas_t * canvas;

touchscreen_t * tft_touch;

touchscreen_data_t * position;

touchscreen_callback_t callback;

pointer_t * ptr;

pointer_state_t * pointer_state;

void main (void)

{
// Open instances of drivers for LCD, Touch and Graphics
tft_touch = touchscreen_open(TOUCHSCREEN_1);
ptr = pointer_open(POINTER_1);
display = graphics_open(GRAPHICS 1);
canvas = graphics_get_canvas(display, GRAPHICS 1);
// Tell Touch driver which function to call for display during calibration
touchscreen_set_callback(tft_touch, draw_mark, canvas);
while(1touchscreen_calibrate(tft_touch, 320, 240));
graphics_fill_canvas(canvas, 0x080008);
graphics_set_visible_canvas(display, canvas);
while(l)
if (pointer_update(ptr, pointer_state))
// Send point to Terminal in Devices View.
printf( "Touched screen at point (%d,%d)\n",
pointer_state->x,
pointer_state->y );
}
¥
3

// Calibration call-back function - used to display a cross-hair at
// Calibration points on TFT panel.
static void draw_mark(int x, int y, int width, int height, void *vp)

{
graphics_draw_circle(canvas, x, y, 10, OxFfOOff);
graphics_draw_line(canvas, x - 15, y, x + 15, y, OxXOO0ffff);
graphics_draw_line(canvas, x, y - 15, x, y + 15, OxO0ffff);
graphics_draw_string(canvas, 50, 50, call, NULL, OXFFFfff, 0);
graphics_set_visible_canvas(display, canvas);

3

Table 2. Code for Main.c
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21. In the Embedded Project Options, go to Configure Memory tab, and split the external SRAM into 512K of
ROM, and 512K of RAM, as shown in Figure 4

Options for Embedded Project Embedded_TFT_TOUCH.PrjEmb

Compiler Options | Files ‘with Options | Parameters

Device Sheets

Configure Memory | Locate Options

Sections/Reserved Areas

Memory Architecture

0xFFFF_FFFF

Device Memory

0xFFFF_FFFF

Application Memory

0xFFFF FFFF

Processor 1/0 Space
10 Port
of the processor

OxFFFF_FFFF

OxFFOO_0000

OxFFFF_FFFF

OxFFLD_0000

RAM_XMEM [Volatile RAM

External-Memory Space

O0xFEFF_FFFF

Ox0l0o-—0000

XRAM
WE_INTERCOMN_2

0x010F_FFFF

0x0100_0000

0x010F_FFFF

0x0108_0o0o

Internal-Memory
‘whhere the
boot code resides

Ox00FF_FFFF

Gx0000_0000

ROM_XMEM [ROM)
WE_INTERCON_2

0x0107_FFFF

0x0100_0ooo

TSK3000A_1

0xz0000_-3FFF

0xz0000_0000

TSK32000A_1 [ROM)

Ox0000_0OFFF

Ox0000_aoo0o

0x0000_0ooo

Qx0000_000o0

Ox0000_0000

MHame Addreszs Size Type Intermipts
TSK30008 1 0=0 4036 RO
ROM_<MEM 01000000 512K ROM
R _<MEM 0x01080000 512K Walatile Rk
Automatically impaort when compiling FPGA project
oK. | [ Cancel

Figure 4. Embedded project memory configuration.
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22. Open Devices View < . you should see your connection to the NB3000. Right-click on the NB3000 icon and
Auto-Configure your project. At this point it's a good idea to do File»Save All.

23. Build and download the project.

Uip fo Date

24. You will need to click the Up to Date Download o= button under the TSK-3000A soft-chain icon in
Devices View once the hardware design has been downloaded.

25. Follow the prompts on-screen on the NB3000 TFT Panel for calibration.

26. Open the TERMINAL instrument in Devices View. Note the coordinates are received wherever you press the
TFT panel.

¢ Referring to the Graphics Context documentation in the Knowledge Center panel, modify the code to draw
lines between each point where the stylus (pen) touches the TFT screen.

¢ Modify the code to print the co-ordinates to the TFT screen as a text string, as well as to the Terminal
Instrument.

¢ Modify the call-back function draw_mark to display some shapes other than the cross-hair and circle. Try
squares, triangles etc.

¢ Remove the Terminal Instrument from the design and re-build it to work just with the TFT for visual feedback.

¢ Note that the graphics drivers used in this project make use of “double buffering” — where you can change
screens on the TFT rapidly by switching canvases (a canvas is a screen-sized pixel buffer in memory that the
TFT panel reads it's pixel data from). See if you can find where in the SwPlatform file you can specify how
many canvas buffers you want.
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Date Revision No. | Changes

29-Jul-2009 1.0 New document release

Software, hardware, documentation and related materials:
Copyright © 2009 Altium Limited.

All rights reserved. You are permitted to print this document provided that (1) the use of such is for personal use only and will not be copied or
posted on any network computer or broadcast in any media, and (2) no modifications of the document is made. Unauthorized duplication, in whole
or part, of this document by any means, mechanical or electronic, including translation into another language, except for brief excerpts in published
reviews, is prohibited without the express written permission of Altium Limited. Unauthorized duplication of this work may also be prohibited by local
statute. Violators may be subject to both criminal and civil penalties, including fines and/or imprisonment. Altium, Altium Designer, Board Insight,
Design Explorer, DXP, LiveDesign, NanoBoard, NanoTalk, P-CAD, SimCode, Situs, TASKING, and Topological Autorouting and their respective
logos are trademarks or registered trademarks of Altium Limited or its subsidiaries. All other registered or unregistered trademarks referenced
herein are the property of their respective owners and no trademark rights to the same are claimed.
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