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Chapter 1

Infroduction

This tutorial provides comprehensive information that will help you understand how to create a
FPGA design and run it on your DE10-Nano development board. The following sections provide a
quick overview of the design flow, explain what you need to get started, and describe what you will
learn.

1.1 Design Flow

Figure 1-1 shows the FPGA design flow block diagram.

The standard FPGA design flow starts with design entry using schematics or a hardware description
language (HDL), such as Verilog HDL or VHDL. In this step, you can create a digital circuit that is
implemented inside the FPGA. The flow then proceeds through compilation, simulation,
programming, and verification in the FPGA hardware.

|

Design  ——» Compile ——» Simulate ——» Program —— Hardware

This tutorial guides you through all of the steps except for simulation. Although it is not covered in
this document, simulation is very important to learn, and there are entire applications devoted to
simulating hardware designs. There are two types of simulation, Functional and Timing Functional
simulation allows you to verify that your code is manipulating the inputs and outputs appropriately.
Timing (or post place-and-route) simulation verifies that the design meets timing and functions
appropriately in the device.

Figure 1-1 Design Flow
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1.2 Before You Begin

This tutorial assumes the following prerequisites

B You generally know what a FPGA is. This tutorial does not explain the basic concepts of
programmable logic.

B You are somewhat familiar with digital circuit design and electronic design automation (EDA)
tools.

B You have installed the Altera Quartus Il 16.0 software on your computer. If you do not have
the Quartus Il software, you can download it from the Altera web site at www.altera.com/download.

B You have a DE10-Nano Development Board on which you will test your project. Using a
development board helps you to verify whether your design is really working.

B You have gone through the quick start guide and/or the getting started user guide for your
development kit. These documents ensure that you have:

¢ Installed the required software.
e Determined that the development board functions properly and is connected to your
computer.

Next step you should installed the USB-Blasterll driver, Plug in the 5-volt adapter to provide power
to the board. Use the USB cable to connect the leftmost USB connector on the DE10-Nano board to
a USB port on a computer that runs the Quartus Il software. Turn on the power switch on the
DE10-Nano board.

The computer will recognize the new hardware connected to its USB port and Power on the board
as shown in Figure 1-2, but it will be unable to proceed if it does not have the required driver
already installed. The DE10-Nano board is programmed by using Altera USB-Blaster 1l mechanism.
If the USB-Blasterll driver is not already installed, the Driver Software Installation in Figure 1-3
will appear.Click close.
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Power DC Jack

Mini USB

Figure 1-2 Connection Setup

Device driver software was not successfully installed

Please consult with your device manufacturer for assistance getting this device installed.

Unidentified Device ¥ Mo driver found

What can I do if my device did not install properly?

Close

Figure 1-3 Driver Software Installation

Since the desired driver is not available on the Windows Update Web site, open the Computer
Management and select the Device Manager. This leads to the window in Figure 1-4.
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Q Computer Management (Local

4 ﬁ’% System Tools
3 @ Task Scheduler
& fd] Event Viewer
1+ 3] Shared Folders
i & Local Users and Groups
3 @ Performance
|E Device Manager |
a g Storage
= Disk Management
3 ég Services and Applications

4 mn 13

|4 ﬂ terasic-PC

b 1% Computer

|‘>-E Disk drives

B, Display adapters

4 DVD/CD-ROM drives

b % Human Interface Devices

g IDE ATA/ATAPI controllers
DQ Junge

b Keyboards

|.>-E! Mice and other pointing devices
|‘>-EJ Maenitors

E-Q Network adapters

A-_@@ Other devices

% Unknown device

15 Ports (COM &LPT)

b w Processors

b 4 Sound, video and game controllers
b (:— Storage controllers

b 78| System devices

b E Universal Serial Bus controllers
- ok WSD Print Provider

Mere Actions

Figure 1-4 Device Manager

Right click Other devices>Unknown device and select Update Driver Software

Figure 1-5.

How

do you want to search for driver software?

= Search automatically for updated driver software
Windows will search your computer and the Internet for the latest driver software
for your device, unless you've disabled this feature in your device installation
settings.

< Browse my computer for driver software
Locate and install driver software manually.

... This leads to the window in

Cancel
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The driver is available within the Quartus Il software. Hence, click Browse my computer for device software to

get to Figure 1-6.

: ,

@ |l Update Driver Software - Generic USE Hub

Browse for driver software on your computer

Search for driver software in this location:

Chaltera'l6.0hquartush driversush-blaster-ii -

[¥]Include subfolders

= Let me pick from a list of device drivers on my computer
This list will show installed driver seftware compatible with the device, and all driver
software in the same category as the device.

[ Mext ][ Cancel

Figure 1-6 Specify the location of the driver

Now, click Browse to get to the pop-up box in Figure 1-7 Find the desired driver, which is at
location C:\altera\16.0\quartus\drivers\usb-blaster-ii. Click OK and then upon returning to Figure
1-6.click Next.
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| bing4

. common

!
b
1 cusp
!

J drivers
L 386
[= 1. sentinel
= 1 ush-blaster
[> 1 usb-blaster-ii
by wdrer
< | m

Folder: usb-blaster-i

Figure 1-7 Browse to find the location

The driver will now be installed as indicated in Figure 1-8 Click close and you can start using the
DE10-Nano board.

river Software - Altera USE-Blaster I (Unconfigured)

Windows has successfully updated your driver software '
Windows has finished installing the driver software for this device:

Altera USB-Blaster II (Unconfigured)

Figure 1-8 The driver is installed
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1.3 What You Will Learn

In this tutorial you will perform the following tasks:

Create a design that causes LEDs on the development board to blink at a speed that is controlled by
an input key — This design is easy to create and gives you visual feedback that the design works.
Of course, you can use your board to run other designs as well. For the LED design, you will write
Verilog HDL code for a simple 32-bit counter, add a phase-locked loop (PLL) megafunction as the
clock source, and add a 2-input multiplexer megafunction. When the design is running on the board,
you can press an input switch to multiplex the counter bits that drive the output LEDs.

Becoming familiar with Quartus 11 design tools—This tutorial will not make you an expert, but at
the end, you will understand basic concepts about Quartus Il projects, such as entering a design
using a schematic editor and HDL, compiling your design, and downloading it into the FPGA on
your DE10-Nano development board.

Develop a foundation to learn more about FPGAs — For example, you can create and download
digital signal processing (DSP) functions onto a single chip, or build a multi-processor system, or
create anything else you can imagine all on the same chip. You don’t have to scour data books to
find the perfect logic device or create your own ASIC. All you need is your computer, your
imagination, and an DE10-Nano FPGA development board.
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Chapter 2
Assign The Device

You begin this tutorial by creating a new Quartus Il project. A project is a set of files that maintain
information about your FPGA design. The Quartus Il Settings File (.qsf) and Quartus Il Project File
(.gpf) files are the primary files in a Quartus Il project. To compile a design or make pin
assignments, you must first create a project.

2.1 Assign The Device

1. Inthe Quartus Il software, select File > New Project Wizard. The Introduction page opens. See
Figure 2-1.
rG New Project Wizard [ﬁ1

Introduction

The New Project Wizard helps yvou create a new project and preliminary project settings, including the following:

Project name and directory

Name of the top-level design entity
Project files and libraries

Target device family and device
EDA tool settings

L X R J

ou can change the settings for an existing project and specify additional project-wide settings with the Settings command (A=szignments menu). You can
uge the various pages of the Settings dialog box to add functionality to the project.

|:| Don't show me this introduction again

< Back Next = Finizh Cancel || Heb

Figure 2-1 New Project Wizard introduction
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Click Next.

Enter the following information about your project:

a. What is the working directory for this project? Enter a directory in which you will store your
Quiartus Il project files for this design.

b. For example, C:\My_design\my_first_fpga.

c. File names, project names, and directories in the Quartus 11 software cannot contain spaces.

d. What is the name of this project? Type my_first_fpga.

e. What is the name of the top-level design entity for this project? Type my_first_fpga. See

Figure 2-2.

(T New Project Wizard [
Directory, Name, Top-Level Entity
What is the working directory for this project?
C:\My_design\my_first_fpaal D
What iz the name of this project?
my_first-fpga D
What iz the name of the top-level design entity for this project? This name is case sensitive and must exactly match the entity name in the design file.
my_first-fpga E]
Use Existing Project Settings. ..

[ < Back ] [ Next = ] [ Finish ] [ Cancel ] [ Help
Figure 2-2 Project information
f. Click Next.
DE10-Nano 9 www. terasic.com
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g. You will assign a specific FPGA device to the design and make pin assignments. See Figure
2-3.

Tk New Project Wizard Y

Family, Device & Board Settings

Device Board
Select the family and device you want to target for compilation.
You can install addtional device support with the Install Devices command on the Tools menu.
To determine the version of the Quartus Prime software in which vour target device is supported, refer to the Device Support List webpage.
Device family Show in "Available devices' list
Family: | Cyclone V (E/GX/GTISXISEIST) v|  Package: [any -]
Devices: [AII V] Pin count: [An}r v]
Target devics Core Speed grade: [Any v]
Auto device selected by the Fitter Name fittsr:
@ Specific device selected in 'Available devices® list Show advanced devices
Other: n/a
Available devices:

Hame Core Voltage ALMs Total 0= GPIOs GXB Channel PMA GXB Channel PC5 H=
SCSEBASU23CE 1AW 41810 34 14 0 0 0
SCSEBASU23CES 1.1 41910 34 314 0 0 0
SCSEBABLZ3IT 1.1V 41910 314 4 0 0 o

I SCSEBABLZ3ITS 1.1 41910 34 4 0 0 0 |J
SCSEMAZUZ23AT RAT 9430 34 14 0 0 o
T o J ) b

| <Back |[ Mext> || Fnish || cancel |[ Hep

Figure 2-3 Specify the Device Example
h. Click Finish.

4.  When prompted, choose Yes to create the my_first_fpga project directory. You just created
your first Quartus Il FPGA project. See Figure 2-4.
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{Th Quartus Prime Standard Edition - Cy/My_design/my.first_fpga/my. first fpga - my_first_fpga [E=EER
File Edit View Project Assignmentz Processing Tools Window Help Search altera.com .
‘DEE D0 D C moeme /&S Or ¥ ES SAVE

Project Navigatur[ 4 Higrarchy - ]E @e = IP Catalog @e =

Q X =
4 g Installed P
4 Project Directory
No Selection Available
4 Library

Entity:Instance
#% Cyclone V: SCSEBASU23IF
» my_first_fpga ©i

[» Basic Functions
DsP

Interface Protocols

( Qua rtus P}\""J}T?e E WMemory Interfaces and Controllers

Processors and Peripherals.
< m | 3

- University Program
Tasks [compiation ~|l=@e =

. Search for Partner IP
Task i

4 P Compile Design D

> B Analysis & Synthesis

: = [ b Fitter (Plara & Rautel a2 m

I ; @) (&) [A) V <<Fiter=» [ 88 Find.. | (@8 Find nex] ||
? Type ID Message
H
EA v
]
£ | System Processing

0% oo:00:00

Figure 2-4 my_first_fpga project
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Chapter 3

Design Entry

Add a PLL Megafunction
This section describes How to Add a PLL Megafunction

In the design entry step you create a schematic or Block Design File (.bdf) that is the top-level
design. You will add library of parameterized modules (LPM) functions and use Verilog HDL code
to add a logic block. When creating your own designs, you can choose any of these methods or a
combination of them.

1. Choose File > New > Block Diagram/Schematic File (see Figure 3-1 to create a new file,
Block1.bdf, which you will save as the top-level design.

MNew Quartus Prime Project

4 Design Files
AHDL File
Block Diagram/Schematic File
EDIF File
(Q=sys System File
State Machine File
System\ferilog HOL File
Tel Script File
Werilog HOL File
WHOL File

4 Memory Files
Hexadecimal (Intel-Format) File
Memory Initialization File

4 \erification/Debugging Files
In-3ystem Sources and Probes File
Logic Analyzer Interface File
SignalTap Il Logic Anahyzer File
University Program WWF

4 QOther Files
AHDL Include File
Block Symbaol File
Chain De=scription File
Synopsys Design Constraints File
Text File

[ OK ][ Cancel ” Help ]

Figure 3-1 New BDF
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2. Click OK.

3. Choose File > Save As and enter the following information.

e File name: my_first_fpga
e Save as type: Block Diagram/Schematic File (*.bdf)

4. Click Save. The new design file appears in the Block Editor (see Figure 3-2).

i ™Y
(% Quartus Prime Standard Edition - Ci/My_design/my_first_fpga/my_first_fpga - my_first_fpga @M
File Edit Wiew Project Assignments Processing Tools  Window  Help Search attera.com e

O = r [my_ﬂrst_fpga v] - .. W1 > FES RLY @
Project Navigatur[ 4 Higrarchy ']E@ﬁ' x Iiﬂ Block1.bdf 8 | ||P Catalog @Me =
Entity:Instance E]es WATEZ-OTTTINNY = L} X =

4% Cyclone \V': SCSEBASUZ3T
» my_first_fpga ~@

s

S 24 gl nstaled P
4 Project Directory

No Selection Available
4 Library

7

Basic Functions

> DSP
= > Interface Protocols
> Memory Interfaces and Controllers
» Processors and Peripherals
1 [ | r
> University Program
Tasks [CD”"F'“ﬁ“D” i ]E @ = @ search for Parner IP
Task '

4 | Compile Design

= P Analysis & Synthesis

> B Fitter (Plare & Rnutel

| T ] 3 + Add..

; @] @ E] <<Fitter>= [ 88 Find... ] [” FindNext]

g Type ID Message

w

H K ;
w

é System Processing

402,96 0% 00:00:00

Figure 3-2 Bank BDF
5.  Add HDL code to the blank block diagram by choosing File > New > Verilog HDL File.
6. Click OK to create a new file Verilogl.v, which you will save as simple_counter.v.
7. Select File > Save As and enter the following information (see Figure 3-3).

e File name: simple_counter.v
e Save as type: Verilog HDL File (*.v, *.vlg, *.verilog)

DE10-Nano 13 www. terasic.com
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Sawve s

Save in: | o my_first_fpga j Ic_ui( E-
= Marne ‘ * | Date modified Type Size
e B
o | db S/7/2013 1030 A6 File falder
Recent Places
Desktop
w=uH
Libraries
Computer
@;
Metwork
File: name: :s:irn le_counter. v j
Save as ype: |Verilog HOL Files [*.w " vlg * verilog) j

v &dd file to curent project

Save

T
Cancel

Figure 3-3 Saving the Verilog HDL file

The resulting empty file is ready for you to enter the Verilog HDL code.

8. Type the following Verilog HDL code into the blank simple_counter.v file (see Figure 3-4 The
Verilog File of simple_counter.v).

module simple_counter (

input CLOCK 50;

/11t has a single clock input and a 32-bit output port

CLOCK_50,

counter_out

output [31:0] counter_out;

reg [31:0] counter_out;

always @ (posedge CLOCK_50)

// on positive clock edge

lmaslc
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begin

end

endmodu

le

counter_out <= #1 counter_out + 1;// increment counter

/I end of module counter

-
(W Quartus Prime Standard Edition - C2/My_design/my_first_fpga/my_first_fpga - my_first_fpga

Or~Hd

File Edit Wiew Project Assignments

Processing Toole  Window  Help

| nliRe) [ my_first_fpga

Project Navigatur| 4% Hierarchy = @ g =

Entity:Instance

> B Fitter (Place & Route)
|

% Cyclone V: SCSEBABUZIT
» my_first_fpga ©&
4| m | b
Tasks compilation ~l=@s x
Task s
4 | Compile Design L

> P Analysis & Synthesis

Search altera.com e
S EEN DK ES SAVE
T Blockibdf [ | G simple_counterv: [ | |IP Catalog @Me =
BT == mnefh 0w P B o X =
1 //It _has a single clock input and a 32-bit oL . =
2 [Emodule simple_counter ( 4 g} Installed IP
i Elaﬁﬁ&foéut 4 Project Directory
5 bF - No Selection Available
6 input CLOCK_50 ; .
7 output [31:0] counter_out; 4 Library
8 reg [31:0] counter_out; > Basic Functions
9
10 always @ (posedge CLOCK_50) > bse
11 [@begin > Interface Protocols
12 Lcounter‘_out <= #1 counter_out + 1;// incremer
13 end > Memory Interfaces and Controllers
14 endmodule > Processors and Peripherals
15

7

University Program
e Search for Partner IP

\ e s ————

Figure 3-4 The Verilog File of simple_counter.v

0%

| [ 3 4 (o] + Add...

; @] @ [I] <=Fiter== [ @4 Find... ] [u FindNext]

[g} Type IiD Message

w

% 1 3
w

§ System Processing

00:00:00

9. Save the file by choosing File > Save, pressing Ctrl + s, or by clicking the floppy disk icon.

10. Choose File > Create/Update > Create Symbol Files for Current File to convert the

simple_counter.v file to a Symbol File (.sym).You use this Symbol File to add the HDL code to
your BDF schematic.

The Quartus Il software creates a Symbol File and displays a message (see Figure 3-5).
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GIRIs
Type ID Message

e m =

R R R R R R R R R R R R R
i ] Running Quartus Prime Create Symbol File
i) Command: quartus_map --read_settings_files=on --write_settings_files=off my_first_fpga -c my_first_fpga --generate_symbol=D:\sy|
> @ Quartus Prime Create Symbol File was successful. 0 errors, 0 warnings
[l m | 1]

|Messages

System Processing (4)

Figure 3-5 Create Symbol File was Successful

11. To add the simple_counter.v symbol to the top-level design, click the my_first_fpga.bdf tab.

12.

Insert Symbol or click Add Symbol on the toolbar.

13. Double-click the Project directory to expand it.

14. Select the newly created simple counter symbol by clicking it’s icon.

You can also double-click in a blank area of the BDF to open the Symbol dialog box (see Figure

3-6).
F
] Symbol
Libraries:
4 [ Project
£F counter_bus_mux
£t pi
X simple_counter
'_ » 23 poattera/15.1/guartus/libraries/
---------------- L CLOCK_ 50 counter_out[31..0] o
4 I |
Name: s
simple_counter Lad |
[] Repeat-insert mode L LS AR SRR SRR EE R SRR SRS SRR
[ Insert symbol as biock SRS S S S S SRR LRSS RS S RN
|| oK ][ Cancel
| |
|
Figure 3-6 Adding the Symbol to the BDF
16. Click OK.
17.  Move the cursor to the BDF grid; the symbol image moves with the cursor. Click to place the

simple_counter symbol onto the BDF. You can move the block after placing it by simply clicking
and dragging it to where you want it and releasing the mouse button to place it. See Figure 3-7.
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|_# Quartus Prime Standard Edition - C:/My_design/my_first_fpga/my_first_fpga - my_first_fpga O | B S
File Edit View Project Assignmentz Processing Tools Window  Help Search altera.com e
OFRH -0 " [ my_first_fpga 7] & P FESISAVE
Project Navigatnr{ % Higrarchy v]E@ﬁl x Iiﬂ Block1.bdf* @ | <3— simple_counter.v | |IP Catalog @ﬁ' =
Entity:Instance == [EQ WATT-OT1TTTNNY = H» L} X =
4% Cyclone V: SCSEBASLIZAIT - J Installed 1P
* my_first_fpga & 4 Project Directory

Mo Selection Available
4 Library
» Basic Functions

[Eimpile_counter » DSP

> Interface Protocols

CLOCK_ED counter_out[31..0]

> Memory Interfaces and Controllers

> Processors and Peripherals

1 [ | +

> University Program
e Search for Partner IP

Tasks [Cumpilatiun - ]E @Me =

Task |~

4 [ Compile Design

> P Analysis & Synthesis

» e Fitter (Place & Rnutel o
< [T ] 3 “ [T | + Add..

x

- @) &) A <<Fiter>> [ 88 Find.. | [ Find e

@ Type ID Message -

) Quartus Prime Create Symbol File was successful. 0 errors, 0 warnings A
4| [Tl | b
System Processing (4)

55,106  100% 00:00:08

Figure 3-7 Placing the simple_counter symbol

18.  Press the Esc key or click an empty place on the schematic grid to cancel placing further
instances of this symbol.

19.  Save your project regularly.
Using Quartus Add a PLL Megafunction.

Megafunctions, such as the ones available in the LPM, are pre-designed modules that you can use in
FPGA designs. These Altera-provided megafunctions are optimized for speed, area, and device
family. You can increase efficiency by using a megafunction instead of writing the function yourself.
Altera also provides more complex functions, called MegaCore functions, which you can evaluate
for free but require a license file for use in production designs. This tutorial design uses a PLL clock
source to drive a simple counter. A PLL uses the on-board oscillator (DE10-Nano Board is 50 MHz)
to create a constant clock frequency as the input to the counter. To create the clock source, you will
add a pre-built LPM megafunction named Altera PLL.

1. Choose Edit > Insert Symbol or click Add Symbol on the toolbar---

2. Tools > Click IP Catalog (see Figure 3-8).
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4.

Selecting IP Catalog.

[Tc-ms] Window Help @

@ ¥ >

e
L

cC2¢ 2@ &

i.

a=

Run Simulation Tool
Launch Simulation Library Compiler

Launch Design Space Explorer Il
Timelluest Timing Analyzer
Advisors

Chip Planner
Design Partition Planner

Netlist Viewers

SignalTap Il Logic Analyzer
In-System Memory Content Editor
Logic Analyzer Interface Editor
In-System Sources and Probes Editor
SignalProbe Pins...

Programmer

JTAG Chain Debugger

Fault Injection Debugger

System Debugging Tools

IP Cataleg
Nios Il Software Build Tools for Eclipse
Qzys

Tel Scripts. ..
Customize...
Options...

License Setup...

Inztall Devices. ..

Figure 3-8 Tools Icon

a. Under IP variation file type, Choose Verilog HDL.

Selection Altera PLL in the Library/Clocks/PLL , click "+Add" bar. See Figure 3-9

b. Under IP variation file, Type pll.v at the end of the already create directory name.

C. Click OK.
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I Quartus Prime Standard Edition - C:/My_design/my_first_fpga/my_first_fpga - my_first_fpga =@ )
File  Edit Vie Project  Assignments  Processing Tools  Windo Heilp Search altera.com .
Of= ||+ B D ¢ [my_ist_foga S EES T ¥ ESSADE
Project Navigatnr[m = @ 5 = | ﬁ Block1.bdf* m | ‘@- =imple_counter.v |:| | |IP Catalog @ g x
Entity:Instance E]es WADTR-OTTIANNY » = o, pl X =

4% Cyclone V: SCSEBABLZ3IT
» my_first_fpga &

4 gt Installed IP
4 Library
4 Basic Functions
4 Clocks, PLL= and Resets
= ALTCLKCTRL
4 PLL

= Altera PLL I
I Alera PLL Reconfig

4 Interface Protocols

CLOCK_BD counter_out[31..0]

a |t o

4 Transceiver PLL

Tasks [compiation ~|=@e =
Task 3 (G Save IP Variation g

4 [ Compile Design |:|

IP wariation file name:
> [ Analysis & Synthesis

C:J‘My_design!my_ﬂrst_fpga.fpll.v{

i i Cancel
b I _ElicsPace & Bouic) IP variation file type

I L3

1 Cyclone V Transceiver PLL

Search for Partner IP

LU

) WHOL

= 5
5 © (&) (&) Y <reedl | G \eriog

g} Type ID Message :
) Quartus Prime Cre

< 1 | F

System Processing (4)

4 [ »

7,2 100% ooomoe |

Figure 3-9 |IP Catalog Selections
In the Altera PLL windows, make the following selections (see Figure 3-10).
The device speed grade choose 6 for DE10-Nano.

Set the frequency of the refclk input 50 MHz.
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Altera PLL

|| A

1
i |'Bb|:l(Dingmn i l/GeneraI rCIockSwitchover rCascading rMIF Streaming rSenings rAdvancedF'arameters |

| [] Show signals || Device Speed Grade:
|| PLL Moge: Integer-NPLL &
Reference Clock Frequency: EI MHz
ook (240 Operation Mode: m
locke:

conduit W Enable locked output port

altera_pll

[1 Enakle physical output clock parameters

[~ output Clocks
Number Of Clocks:
[+ outciko
Desired Frequency: 100.0 J MHz

Actual Frequency: 100.000000 MHZ.

Phase Shift units:

Phase Shift:
Actual Phase Shift:

Duty Cycle:

Copy

@ Info: pll: The legal reference clock frequency is 5.0 MHz..700.0 MHz
@ Info: pll: Able to implement PLL with user seftings

| Cancel || Finish |

Figure 3-10 Selections of Altera PLL windows

6. Turn off the Enable locked output port option on IP windows. As you turn it off, pin disappear
from the PLL block’s graphical preview. See Figure 3-11 for an example.
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Altera PLL

altera_pll

1
i l/ General r Clock Switchover rCascading r MIF Streaming r Settings r Advanced Parameters |

Device Speed Grade:

:| | PLL Mode: Integer-N PLL [
Reference Clock Frequency: [50.0 MHz

| outchly || operation Made: normal .

altera_pll

[1 Enakle physical output clock parameters
~ Output Clocks

Number Of Clocks:
[+ outciko
Desired Frequency: 100.0 J MHz

Actual Frequency: 100.000000 MHZ.

Phase Shift units:

Phase Shift:
Actual Phase Shift:

Duty Cycle:

@ Info: pll: The legal reference clock frequency is 5.0 MHz..700.0 MHz
@ Info: pll: Able to implement PLL with user seftings

| Cancel || Finish |

Figure 3-11 Selections of Altera PLL windows
7. Then, make the following selection (see Figure 3-12).

In Desired Frequency, keyin 5.0 .
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Altera PLL

|' Block Diagram 1 l/ General r Clock Switchover rCascading r MIF Streaming r Settings r Advanced Parameters |

| [ Show signals Device Speed Grade:
|| PLL Mode: Integer-NPLL  [&]
Reference Clock Frequency: [50.0 MHz
| outchly || operation Made: normal .

[1 Enable locked output port

altera_pll

[1 Enakle physical output clock parameters

[ Output Clocks
: Mumber Of Clocks:
[+ outciko
Desired Frequency: 50 MHz

Actual Frequency: 5.000000 MHZ.

Phase Shift units:

Phase Shift:
Actual Phase Shift:

Duty Cycle:

Copy

@ Info: pll: The legal reference clock frequency is 5.0 MHz..700.0 MHz
@ Info: pll: Able to implement PLL with user seftings

| Cancel || Finish |

Figure 3-12 Selections of Altera PLL windows

8. Click Finish. It leads to Figure 3-13.Click Exit.

r+ B
¥ Generation - Altera PLL 16.0 | B

(%) Info: pll: Variation language : Verilog ]
(3) Info: pll: Qutput directory - C:\WMy_designimy_first_fpoga

[3) Info: pll: Generating variation file C:\My_designimy_first_fpgaipllv

[7) Info: pll: Generating synthesizable HOL design

(3 Info: Generating altera_pll “pll” for QUARTUS_SYMNTH

[3) Info: “plI" instantiated altera_pll “pll”

'| (D Info: Done “plI" with 2 modules, 3 files

(3} Info: pll: Generating simulation model

(3 Info: Generating altera_pll “pll” for SIM_VERILOG

(3} Info: Generating simgen maodel .ﬂ i

< >

Generation Successful
Cancel Exit |

Figure 3-13 PLL Generation
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9. The Symbol window opens, showing the newly created PLL megafunction. See Figure 3-14.

B I ==

Libraries:

4 [ Project
£Y counter_bus_mux
[ ol
ﬂmple_cuunter
> €3 p/atera/15.1/quartus/libraries’

4 I

Name:

pl ]
|:| Bepeat-ingert mode

[7] In=ert symbol as block

LTI pll STt
o bt |5
I A3 e A k_0 A
SEEEEEEE T SHEEEEHER
I B 4 recet A
I afters_pll| o 0oLl Lol Ll

Figure 3-14 PLL Symbol

10. Click OK and place the pll symbol onto the BDF to the left of the simple_counter symbol. You
can move the symbols around by holding down the left mouse button, helping you ensure that they

line up properly. See Figure 3-15.

G Quartus Prime Standard Edition - C:/My_design/my_first_fpga/my_first_fpga - my_first_fpga - = |-:-|JEL|Q
File Edit View Project Assignments Processing Tools Window Help Search altera.com .
D & 00D ¢ my st foga S EELDrFES @AVE

Project Nawgatnr{ 4 Hierarchy - ] =[@aF = |—ﬁ my_first_fpga.bdf* (] | "P Catalog @Me =

Entity:Instance = @Q ¥WACTE-O 1T 1A ~NYOox Y » H» L} X =
ay Cyclone V' SCSEBABUZ3T | LIt = 4 Library -
> m_st e IS 3 PR
. | simple_countes . [ Arithmetic
CLOCK_50  counter_out[31..0] I> Bridges and Adaptors
: - [» Clocks; PLLs and Resets
. T [> Configuration and Programming | =
: S - b 0
ol 4 Miscellaneous
: : £ ALTECC
: refclk outclko | - - & LPM_CLSHIFT
: Ko . # LPM_CONSTANT
reset 4 LPM_DECODE f
: rst reset = LPM_MUX i
: . I b # LPM_SHIFTREG
. e it o I _Mn Chin Mamane =
; ....................................... I ] m | b
Ll [ T 3 + Add..
OEE & v
Type ID Message
] G
System Processing
508, 260 0% 00:00:00 |
Figure 3-15 Place the PLL Symbol
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11.  Move the mouse so that the cursor (also called the selection tool) is over the pll symbol’s
outclk 0 output pin. The orthogonal node tool (cross-hair) icon appears.

12.  Click and drag a bus line from the outclk_0 output to the simple_counter clock input. This
action ties the pll output to the simple_counter input (see Figure 3-16).

pll S R

. ko | mmple_cnunter |

refclk kO g CLOCK_S0  counter_put[31..0] —
reset I A

rst e SESESEREE SRR
inzt1 altera_pll| - . L

Figure 3-16 Draw a Bus Line connect pll outclk_0 port to simple_counter CLOCK_50 port
13.  Add an input pin and an output bus with the following steps:
a. Choose Edit > Insert Symbol.
b.  Under Libraries, select quartus/libraries > primitives > pin >input. See Figure 3-17
c. Click OK

If you need more room to place symbols, you can use the vertical and horizontal scroll bars at the
edges of the BDF window to view more drawing space.
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rﬂ Symbol

Libraries:

4 [ primitives -

> 3 buffer

> B3 logic

> 21 other

4 [ pin
£F bidir
£ input
£F output

» [ storage

m

4 F

Name:

input E]

|| Repeat-insert mode

NSEM SYMDol 85 DIDCK

Figure 3-17 Input pin symbol
d. Place the new pin onto the BDF so that it is touching the input to the pll symbol.

e. Use the mouse to click and drag the new input pin to the left; notice that the ports remain
connected as shown in Figure 3-18.

p|| .......................................

ek 5|m|:|e_counter ..................................................................

k_0 clk CLOCK_50 counter_out[31..0] [

........................... rsi [reset cee ... inst
I I E1S altera_pll| - oo 0D

Figure 3-18 Connecting the PLL symbol and Input port

f.  Change the pin name by double-clicking pin_name and typing CLOCK_50 (see Figure 3-19).
This name correlates to the oscillator clock that is connected to the FPGA.

g. Using the Orthogonal Bus tool, draw a bus line connected on one side to the simple_counter
output port, and leave the other end unconnected at about 4 to 8 grid spaces to the right of the
simple_counter.
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i Ty
=] Pin Properties ﬁ
General Format |

To create multiple ping, enter a name in AHDL bus notation
(For example: "name[3..0]"}, or enter a comma-seperated list of names.

Pin name(s): CLOCK_50|

Default value: VCC -

OK ][ Cancel H Help

Figure 3-19 Change the input port name

h.  Right-click the new output bus line and choose Properties.

i. Using the Orthogonal Bus tool 1 , draw a bus line connected on one side to the

simple_counter output port, and leave the other end unconnected at about 6 to 8 grid spaces to the
right of the simple_counter.

j. Type counter [31..0] as the bus name (see Figure 3-20). The notation [X..Y] is the Quartus 1l
method for specifying the bus width in BDF schematics, where X is the most significant bit (MSB)
and Y is the least significant bit (LSB).

k. Click OK. Figure 3-21 shows the BDF.
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T . e

General | Font | Format |

Name: counter[31..0]

Hide name in block design file.

| ok || cancel || Hep

Figure 3-20 Change the output BUS name

(T Quartus Prime Standard Ediﬁun-c;my_designlmy_ﬁm_fpgarw_ﬁm_fpga- my. first_ipga ettt (e )
Fie Edit View Project Assignments Processing Tools Window  Help Search altera.com .
OFH ~ D0 C | [mrstpea Y| LSS S DS RAEDR
Project Navigato] s\ Hierarchy  ~ |=(@@ x | | my_first_fpga.bdf* (] ‘
Entity:Instance @ma*ADIE'D.—ljﬁ\\\DD\—\ﬂki‘;ﬁ E@?‘r@t} 00
4% Cyclone V: SCSEBABUZ3T e )
» my_first_fpga o&

m

refclk outclkp | - o - P SmERSRunE L
O T CIN I

refok k0 o ——CLOGK 50 counter_out[31.4] —x
reset]

inst

st rest

altera_pll| | |

I 3 i
Project Navigator £} 1 3
B & @ A ¥ <
Type ID Message
] »
System Processing

509,320 0%  00:00:00

Figure 3-21 BDF
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3.1 Add a Multiplexer

This design uses a multiplexer to route the simple_counter output to the LED pins on the
DE10-Nano development board. You will use the MegaWizard Plug-In Manager to add the
multiplexer, lpom_mux. The design multiplexes two variations of the counter bus to four LEDs on
the DE10-Nano development board.

1. Choose Tool> IP catalog.
2. Click Library.

3. Click Miscellaneous.

4. Choose LPM_MUX.

5.  Choose the device family that corresponds to the device on the development board you are
using, choose Verilog HDL as the output file type, and name the output file counter_bus_mux.v (see
Figure 3-22).

6. Click OK.

Ok Quartus Prime Standard Edition - C:/My_design/my_first_fpga/my_first_fpga - my_first_fpga = & =
Search altera.com e
Ord b» [ my_first_fpga z) S & E G e 8 AVE
Project Nﬁwgatnr{ 4% Hierarchy - ] =@ = ﬂ my_first_fpga.bdf* B8 | "P Catalog @ =
Entity:Instance @Q*ADIE'DT.—IET\'\\DQ\K » Q”Q X =
% Cyclone V: SCSEBAGU23IT ol . - Lo > Bridges and Adaptors -
» my_first_foga 7 : Clocks; PLLs and Resets
> Configuration and Programming
] =
= 4 Miscellangous
L 5 =
-1 G save P variation 3 =) = aLTECC
N . =
1 ko LPM_CLSHIFT =
IP wariation file name: b # LPM_CONSTANT
C:.n’My_design.n’my_ﬁrst_fpgﬁr’cuunter_bus_muxvi E] E 4 LPM_DECODE
Cancel — -
IP wariation file type  LPM_MUX
© vHoL > 1 LPM_SHIFTREG
_ > On Chip Memo
@ Verilog i ¥
> Simulation; Debug and Verificatit
> DSP
. _Intarfara Bratnenle o2
< m ,ZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZv‘\ 1] | »
Tasks Project Navigator L] [T} ] +
x
@ ea® CYE
@ Type ID Message
o
1
g b
b
2| System Processing
672,312 0% 00:00:00
Figure 3-22 Selecting Ipm_mux
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Under How many ‘data’ inputs do you want? Select 2 inputs (default).

Under how wide should the 'data’ input and 'result’ output be? Select 4 (see Figure 3-23).

-

= Mega\Wizard Plug-In Manager [page 1 of 3]

A==

2§ LPM_MuUX

Parameter
Settings

counter_bus_mux

dataix=[3..0]
 datalx=[3..0] =

How wide should the 'data’ input and
the 'result’ output buses be?

Currently selected device family:

How many 'data’ inputs do you want? 2 -

Do you want to pipeline the multiplexer?

4 * bits

Cydone V

Match project/default

@ Mo
(™) Yes, I want an output latency of | 1 dock cydes
Create an asynchronous Clear input
Create a Clock Enable input
Resource Usage
1 lpm_mux | Cancel | | = Back | | Mext = | | Finish |
e
Figure 3-23 [pm_mux settings
Click Next.
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+  MegaWizard Plug-In Manager [page 3 of 3] ' | ? 2 |

'Zp LPM_MUX

urmnmary

Turn on the files you wish to generate. A gray checkmark indicates a file that is
automatically generated, and a green checkmark indicates an optional file. Click Finish
to generate the selected files, The state of each checkbox is maintained in subsequent
MegaWizard Plug-In Manager sessions,

data1x]3..0]
datal=[3..0] =

The MegaWizard Flug-In Manager creates the selected files in the following directory:
C:'\My_design'ymy_first_fpga\,

File Description

counter_bus_mux.v | Variation file
[ counter_bus_mux.inc  AHDL Include file
[ counter_bus_mux.c... WHDL component dedaration file
counter_bus_mux.bsf Quartus Prime symbal file
[ counter_bus_mux_i... Instantiation template file
counter_bus_mux_... Verilog HOL black-box file

10. Click Finish twice. The Symbol window appears (see Figure 3-24 for an example).

e . e )

Libraries:

4 [ Project
[&t counter_bus_mux
£t pl
£t} simple_counter
[» 3 pi/aterai15.1iguartusilibraries/

counter_bus_mux

dataix[3..0]

3.0
datalx[3..0] .ﬁq :

Hame:

counter_bus_mux

|:| Repeat-insert mode

|:| Insert symbol as block

Figure 3-24 Ipm_mux Symbol

11. Click OK
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12. Place the counter_bus_mux symbol below the existing symbols on the BDF. See Figure 3-25

pll
refclk outclk
_{refck gk 0 o
reset|
- st Ireset
inst1 altera_pill
i counterBusmux i
LI  datatx3.0) P I I
.......................................... resunao.
i g 0] T
D S I L O N
....................................................................... |

Figure 3-25 Place the Ipm_mux symbol
13. Add input buses and output pins to the counter_bus_mux symbol as follows:
a.  Using the Orthogonal Bus tool, draw bus lines from the datalx[3..0] and dataOx[3..0].
Input ports to about 8 to 12 grid spaces to the left of counter_bus_mux.

b. Draw a bus line from the result [3..0] output port to about 4 to 8 grid spaces to the right of
counter_bus_mux.

c. Right-click the bus line connected to datalx[3..0] and choose Properties.
d. Name the bus counter[26..23], which selects only those counter output bits to connect to
the four bits of the datalx input.

Because the input busses to counter_bus_mux have the same names as the output bus from
simple_counter, (counter[x .. y]) the Quartus Il software knows to connect these busses.

e. Click OK.
f.  Right-click the bus line connected to dataOx[3..0] and choose Properties.

g. Name the bus counter [24..21], which selects only those counter output bits to connect to the
four bits of the datalx input.

h. Click OK. Figure 3-26 shows the renamed buses.
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If you have not done so yet, have your project file before continuing.

.. counter26..23]. . . . .
LY

data1x[3..0]

... .. ‘lounter24.21] . . . .

data0x[3..0]

counter_bus_mux

resUK[3.0] L Ll
LW J

’ el

result[3..0] |

14. Choose Edit > Insert Symbol.

Figure 3-26 Renamed counter_bus_mux Bus Lines

15. Under Libraries, double-click quartus/libraries/ > primitives > pin > output (see Figure 3-27).

rﬂ Symbol

Libraries:

4 [ primitives

> €3 buffer

> 21 logic

> 3 other

4 [Er pin
£} bidir
£ input
£ output

> (2] storage

4

m

Name:
output
|:| Bepeat-ingert mode

Insert symbol as block

oK l [ Cancel

16.
17.

18.

lmaslc

www.terasic.com

Click OK.

Figure 3-27 choose an output pin

Place this output pin so that it connects to the counter_bus_mux result [3..0] bus output line.

Rename the output pin as LED [3..0] as described in steps 13 ¢ and d. (see Figure 3-28).

DE10-Nano
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_ . counter26..23] . . .

counter_bus_mux

data1x[3..0]

. Z’Eoumeq24..21]. o

19.

20.

21.

22.

23.

24,

25.

26.

27.

data0x[3..0]

result[3..0]

. resutt [3..0] . .

inst2

Figure 3-28 Rename the output pin

Choose Edit > Insert Symbol.

QUTPUT  — pin_namef

Attach an input pin to the multiplexer select line using an input pin:

Under Libraries, double-click quartus/libraries/ > primitives > pin > input.

Click OK.

Click OK.

Choose Edit > Insert Symbol.

DE10-Nano
www_zeii.lcncm My First FPGA

Rename the input pin as KEY [0].

Place this input pin below counter_bus_mux.

33

Connect the input pin to the counter_bus_mux sel pin.

Place this not pin so that it connects to KEY[1] and the pll rst (see Figure 3-31).

Place another input pin at the left of the pll and rename it as KEY[1] (see Figure 3-29) .

Under Libraries, double-click quartus/libraries/ > primitives >logic > not (see Figure 3-30).
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L TKEWT]

o simple_counter

CLOCK_50 counter_out{31..0]

o o
| ek outclkO
CLOCK_ S0 — n{gér ~refclk | k_0 ok

Lol . reset,
D i = S
D inst1 altera_pll|

‘counter31.0] - . D0
vy

| data1x[3.0]

counter_bus mux

- | data0x[3..0]

resuf[3..0]

-y

inst2

NEES

T S

Libraries:

|:| Repeat-insert mode

Insert symbol as block
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Figure 3-30 choose an not pin
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simple_counter

refclk outclkO

refclk gl | CLOCK_50 counter_out[31..0]

altera_pll

............................................... COUnter_bUS_mUX

................................... cuunter[ZG..ZE].....datah:[su]
................................... - - K[3.01 .. .
................................... ﬁnunter{Z;..Zﬂ. e CIEIIBU.‘([S. 0] FE.‘SUTI[S. 0] result 3.0} JDUTFOT .

inst2 i
w

Figure 3-31 Place the not pin

You have finished adding symbols to your design. You can add notes or information to the project
as text using the Text tool on the toolbar (indicated with the A symbol). For example, you can add
the label “OFF = SLOW, ON = FAST” to the KEY [0] input pin and add a project description, such
as “My First FPGA Project.”

3.2 Assign the Pins

In this section, you will make pin assignments. Before making pin assignments, perform the
following steps:

1. Choose Processing > Start > Start Analysis & Elaboration in preparation for assigning pin
locations.

2. Click OK in the message window that appears after analysis and elaboration completes.

To make pin assignments that correlate to the KEY[1:0] and CLOCK 50 input pins and LED[3..0]
output pin, perform the following steps:

1. Choose Assignments > Pin Planner,which opens the Pin Planner, a spreadsheet-like table of

specific pin assignments. The Pin Planner shows the design’s six pins. See Figure 3-32.
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%% LED[3] Output PIN_V15 3.3V LVTTL 16mA (defautty 1 (defautt)
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0% 00:00:00

Figure 3-32 Pin Planner Example

2. In the Location column next to each of the seven node names, add the coordinates (pin
numbers) as shown in Table 3-1 for the actual values to use with your DE10-Nano board.

Table 3-1 Pin Information Setting

Pin Name FPGA Pin Location
CLOCK_50 V11

KEY[1] AH16

KEY[O] AH17

LEDI[3] V15

LED[2] V16

LEDI[1] AA24

LED[O] W15

Double-click in the Location column for any of the seven pins to open a drop-down list and type the
location shown in the table alternatively, you can select the pin from a drop-down list. For example,
if you type F1 and press the Enter key, the Quartus 11 software fills in the full PIN_F1 location name
for you. The software also keeps track of corresponding FPGA data such as the 1/0 bank and VREF
Group. Each bank has a distinct color, which corresponds to the top-view wire bond drawing in the
upper right window. See Figure 3-33.
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S LED[Z] Output PIN_\16 5A BSA_ND PIN_V16 3.3V LVTTL 16mA (default) 1 (defautt)
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Figure 3-33 Completed Pin Planning Example

Now, you are finished creating your Quartus Il design!

3.3 Create a Default TimeQuest SDC File

Timing settings are critically important for a successful design. For this tutorial you will create a
basic Synopsys Design Constraints File (.sdc) that the Quartus Il TimeQuest Timing Analyzer uses
during design compilation. For more complex designs, you will need to consider the timing
requirements more carefully.
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To create an SDC, perform the following steps:

1.  Open the TimeQuest Timing Analyzer by choosing Tools > TimeQuest Timing Analyzer.

2. Choose File > New SDC file. The SDC editor opens.

3. Type the following code into the editor:

create_clock -name "CLOCK 50" -period 20.000ns [get_ports {CLOCK_50}]

derive_pll_clocks

derive_clock_uncertainty

4. Save this file as my_first_fpga.sdc (see Figure 3-34).

r — —
Quartus Prime Standard Edition - D-/My_design/my_first_fpga/my_first_fpga - my_first fpga
Y. g i ¥ ¥ g

-:-JELQ1
File Edit View Project Assignments Processing Tools Window Hep @ Search altera.com [ ]
Or | nle) [ my_first_pga x| L P FES SLDS
Project Navigator | oy Hierarchy = |=(@& = || T mymstipgansr [ | & myfestpongst [ | & mysestmoasde [ | & myfist fooasdc [ ‘
Entity:Instance @ ” {-}' E:E E:E al] ﬂ‘ ‘h @ k1 "] Sgg :

% Cyclone V: SCSXFCECEU23CE

> ER my_first_fpga o derive_clock_uncertainty

a
2 derive_pll_clocks
B
4 I

|y 3

Ta.ska[ Full Design

Task ol
Start Project |7|
Create Design
Assign Constraints

create_clock -name "CLOCK_50" -period 20.000ns [get_ports {CLOCK_50%]

4 p Compil

4 P An = -
4| 1 | 2 4| 1 | +
x
@ o eE & v 88 ot
@ Type ID Message e
- © 293000 Quartus Prime Full Compilation was successful. 0 errors, 175 warnings [
o -
o
al | m | +
@
g System Processing (163)

100% 00:01:17

Figure 3-34 Default SDC

Naming the SDC with the same name as the top-level file except for the .sdc extension causes the

Quartus Il software to using this timing analysis file automatically by default. If you used another
name, you would need to add the SDC to the assignments file list.
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Chapter 4

Compile and Verify Your Design

After creating your design you must compile it. Compilation converts the design into a bitstream
that can be downloaded into the FPGA. The most important output of compilation is an SRAM
Object File (.sof), which you use to program the device. The software also generates other report
files that provide information about your code as it compiles.

4.1 Compile Your Design

If you want to store .SOF in memory device (such as flash or EEPROMS), you must first convert
the SOF to a file type specifically for the targeted memory device.

Now that you have created a complete Quartus Il project and entered all assignments, you can
compile the design.

In the Processing menu, choose Start Compilation or click the Play button on the toolbar.
If you are asked to save changes to your BDF, click Yes.

While compiling your design, the Quartus Il software provides useful information about the
compilation (see Figure 4-1).
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16.0.0 Build 211 04/27/2016 SJ Standard Edition
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» © 293000 quartus Prime Full Compilation was successful. 0 errors, 7 warnmings Ty
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H
£ || System(2) Processing (134}

00:02:19

Figure 4-1 Compilation Message for project

When compilation is complete, the Quartus Il software displays a message. Click OK to close the

message box.

The Quartus I Messages window displays many messages during compilation. It should not display
any critical warnings; it may display a few warnings that indicate that the device timing information
is preliminary or that some parameters on the 1/O pins used for the LEDs were not set. The software
provides the compilation results in the Compilation Report tab as shown in Figure 4-2.
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Flow Summary

Flow Status Successful - Mon Dec 05 18:00:06 2016
16.0.0 Build 211 04/27/2016 5J Standard Edition

Quartus Prime Version

Revision Mame

Top-level Entity Name

Famity

Device

Timing Models

Logic utilization (in ALMs)
Total registers

Total pins

Total virtual pins

Total block memory bits

Total DSP Blocks

Total HSSI BX PCSs

Total HSS| PMA RX Deserializers
Total HSSI TX PCSs
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Total PLL=
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my_first fpoga
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0
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0/ M2(0%)

0
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0

]

116 (17%)
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Figure 4-2 Compilation Report Example

4.2 Program the FPGA Device

After compiling and verifying your design you are ready to program the FPGA on the development
board. You download the SOF you just created into the FPGA using the USB-Blasterll circuitry on
the board. Set up your hardware for programming using the following steps:

a) Connect the power supply cable to your board and to a power outlet.

b) For the DE10-Nano board, connect the USB-Blasterll (included in your development kit) to
J13 and the USB cable to the USB-Blasterll. Connect the other end of the USB cable to the host
computer.

Refer to the getting started user guide for detailed instructions on how to connect the cables.

c) Turn the DE10-Nano board on using the on/off switch.
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Program the FPGA using the following steps.

1.

2.

3.

maslc

Choose Tools > Programmer. The Programmer window opens. See Figure 4-3.

. = —
“ Programmer - C:/My_design/my_first_fpga/my_first_fpga - my_first_fpga - [Chainl.cdf]

Fie Edit View

Processing Tools  Window

-
—_— - e
O e e 3

Search altera.com .

m@g

ﬂ;ﬂ‘utc Detect
Delete
e Change File...
& save File
|
I yp

™ Down

; Hardware Setup...| Mo Hardware Mode: [.JTAG b ] Progress: ]
|:| Enable real-time ISP to allow background programming when available
i File Uzercode Program/ WVerify Blank- Examine
Start Configure Check
it Stop

4

Click Hardware Setup.

Figure 4-3 Programmer Window

If it is not already turned on, turn on the DE-SoC [USB-1] option under currently selected
hardware. See Figure 4-4.
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5.

6.
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Hardware Settings | JTAG Seftings |

[t

Select a programming hardware setup to use when programming devices. Thiz programming
hardware setup applies only to the current programmer windows.

Currently =elected hardware: | No Hardware

d

Available hardware items

Hardware
DE-SolC

Server
Local

Port
UsB-1

| Add Hardware... I

Remove Hardware

Figure 4-4 Hardware Setting

Click Close.

Click Auto Detect to detect all the devices on the JTAG chain.

Select 5CSEBAS6 and click OK.

D Select Device

Found devices with shared JTAG ID for device 2. Please select your device.

=5

@ S5CSEBAG

() SCSEBAGES
) SCSEMAG

) SCSTFDGDS
D) 5CSXFCBCE
7) SCSXFCBLEES
(D) 5CSXFCED6

() SCSXFCEDEES

Figure 4-5 Select FPGA Device
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7. Click Yes to match device list.

.
\_@ Quartus Prime ﬁ

The auto-detected device chain does not match the Programmer's device list. Do you
I b want to update the Programmer's device list, overwriting any existing settings?

Yes ] [ No

Figure 4-6 Warning for device list not match

8. Both HPS and FPGA will be list on the programmer. Select FPGA device and click Change
File a .sof file.

& Programmer - F/nick/my_first_fpga/my_first_fpga - my_first_fpga - [my_first_fpga.cdfl* EI@
File Edit WView Processing Tools Window Help Search altera.com e

;Hardware Setup...| DE-SoC [USB-1] Mode: | JTAG - Progress: l ]

[T Enable real-time ISP to allow background programming when available

U o File Device Checksumn Usercode Program/  Werify  Blank- Examine
Start
Configure Check
fl stop §<none> SOCWVHPS 00000000 <nonex
< = < =
ﬁAutu Detect none SCSEBAG 00000000 none
Delete
Y add File..
] 1] | 3
& Change File...
) save File
- . EEEEEEEEN EEEEEEEEN
Add Device... u " o .
L] Ll L | Ll
m TDI . H . H
Uy SE— S —
L] Ll L | Ll
L] Ll L | Ll
TED T u m u| n
oW EEEEEEEER EEEEEEEEN
SOCVHPS SCSEBAG
TDO
4

Figure 4-7 Programmer window
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9. Selecting the my_first_fpga.sof file from the project directory (see Figure 4-8), select to
Program/Configure and click Start to program .sof file into FPGA. Please see Figure 4-9.

& Programmer - F/nick/my_first_fpga/my_first_foga - my_first_fpga - [my_first_foga.cdf]* EI@

File Edit ew Processing ools Window  Help Search altera.com .

.?-Hardware Setup...| DE-SoC [USB-1] Mode: |JTAG - Progress: ’ ]

[T Enable real-time ISP to allow background programming when available

U o File Device Checksurn Usercode Program/  Werify  Blank- Exarnine
Start
Configure Check
fl Stop <none> SOCVHPS 00000000 <none>
<nones SCSEBAG 00000000  <none»
- -
== 4% Select Mew Programming File @
W ] 4 [T )
[P changeFie. | Lookin: © 006 U
L} Save Fi -
savefile VA My Comp.. Name
ol EEEEEEEEE . E“.I‘m._.': R User i db
L] L L] -
ol . H E H | greybox_trp
— P : o
L] . L -
L] L L] -
% down L | pllsim
SOCVHPS SCSEBAG LI my_first fpgasof
TDC
= —
< | 1 | §
File name:  my_first_fpga.sof
Files of type: [ngramming Files (*.sof * po 'l l Cancel l

Figure 4-8 Selecting my_first_fpga.sof file.
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O Programmer - F:/nick/my_first_fpga/my_first_fpga - my_first_fpga - [my_first_fpga.cdf]* EI@
File Edit WView Processing Tools Window Help Search altera.com e‘

.?-Hardware Setup...| DE-SoC [USB-1] Mode: |JTAG - Progress: l 100% [Successful) ]

[T Enable real-time ISP to allow background programming when available

File Device Checksum Usercode Program Veri Blank- Examine
',‘IE“ Start B / f)‘
Configure Check
fl Stop <none> SOCWVHPS 00000000 <none>
wﬁ.utu e my_first_fpga.sof SCSEBABUZ3 O0BOS061 O0BOS061
Delete
U pdd File..
4 T 3
s Change File...
b Save File
- . EEEEEEEEE EEEEEEEER
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Figure 4-9 Downloading Complete

Congratulations, you have created, compiled, and programmed your first FPGA design! The
compiled SRAM Object File (.sof) is loaded onto the FPGA on the development board and the
design should be running.

4.3 Verify The Hardware

When you verify the design in hardware, you observe the runtime behavior of the FPGA hardware
design and ensure that it is functioning appropriately.

Verify the design by performing the following steps:

1. Observe that the four development board LEDs appear to be advancing slowly in a binary
count pattern, which is driven by the simple_counter bits [26..23].

The LEDs are active high, therefore, when counting begins all LEDs are turned off (the 0000 state).
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2. Press and hold KEY [0] on the development board and observe that the LEDs advance more
quickly. Pressing this KEY causes the design to multiplex using the faster advancing part of the
counter (bits [24..21]).

3. If other LEDs emit faintness light, Choose Assignments > Device. Click Device and Pin
Options. See Figure 4-10.

rO Device ' . » ' g
Device Board

Select the family and device you want to target for compilation.
You can install additional device support with the Install Devices command on the Tools menu.

To determine the version of the Quartus Prime software in which your target device is supperted, refer to the Device Support List webpage.

Device famiby Show in "Available devices’ list
Famiy: | Cyclone V (E/GX/GTISX/SEST) v|  Package: [Any v
Devices: [AII v] Pin count; [Any v]
Target device Core Speed grade: [Any v]
Name fitter:

Auto device selected by the Fitter

@ Specific device selected in "Available devices® list Show advanced devices

Other: nfa [Devic:e and Pin Options...

Available devices:

Name Core Voltage ALMs Total V0= GPIOs GXB Channel PMA GXB Channel P *
SCSEBABUTSITS 1.1 41910 205 205 0 0
SCSEBABLZ3AT 1.1V 41910 314 314 0 0
SCSEBABUZ3CE 1.1V 41910 34 314 0 0
SCSEBABUZ3CT 1.1 41910 314 314 0 o
SCSEBABUZ3CTS 1.1V 41910 34 314 0 0
I SCSEBAEBLZ3CE 1.1V 41910 314 314 0 0
SCSEBABUZ3CES 1.1V 41910 0 0
m-—mn—_u
SCSEBABUZ3ITS 1.1V 41910 314
SCSEMAZUZ3AY 1.1V 9430 34 314 0 0 %
1 [ 1 | r

Migration Devices...| 0 migration devices selected

[ ok || cancel |[ Hep

Figure 4-10 Device and Options

Choose Unused Pins. Reserve all unused pins: Choose the As input tri-stated option. See Figure
4-11.
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Category:
Configuration
. : Specify device-wide options for reserving all unused pins on the device. To reserve individual
Programming Files . . . .
Unused Pins dual-purpose configuration ping, go to the Dual-Purpose Pins tab. To reserve other pins

. individually, use the Assignment Editor.
Dual-Purpose Pins

Capacitive Loading
Board Trace Model

'O Timing

Voltage

Pin Placement

Error Detection CRC
CvP Settings

Partial Reconfiguration

Reserve all unused pins: [A.s. input tri-stated - ]

Description:

Reserves all unused pins on the target device in one of 5 states: as inputs that are tri-stated,
as outputs that drive ground, as outputs that drive an unspecified signal, as input tri-stated
with bus-hold, or as input tri-stated with weak pull-up.

Figure 4-11 Setting unused pins

Click twice OK.

4. In the Processing menu, choose Start Compilation. After the compile, Choose Tools >
Programmer. Select the my_first_fpga.sof file from the project directory. Click Start. At this time
you could find the other LEDs are unlighted.
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Chapter 5

Appendix

5.1 Headquarter & Branches

o Tel :+886-3-575-0880

e Fax : +886-3-572-6690

e Add : 9F, No.176, Sec.2, Gongdao 5th Rd, East Dist, Hsinchu City, Taiwan 300-70
e Email : sales@terasic.com / support@terasic.com
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